Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th February 2008, 10:43
stoa05 stoa05 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default locating named.conf failed

running CentOS 5.1, I am unable to start named. I did a yum install of:
bind-utils-9.3.3-10.el5
bind-9.3.3-10.el5
bind-libs-9.3.3-10.el5
bind-devel-9.3.3-10.el5

I did chkconfig --levels 35 named on
I tried: service named start
and I get the error:
[root@localhost named]# service named start
Locating //etc/named.conf failed: [FAILED]

First thing I noticed is the double forward slashes //etc - this must be a mistake, but how did it happen and how do I correct it.

If I do: ls -la /etc | grep -i bind
nothing is returned, thus named.conf does not exist, but how can this be?
Does it matter that I was in X in a terminal when I did the yum install?

I tried to get some information by debugging:
I did /etc/init.d/named -d 1
and I got the file named.run:
cat named.run
27-Feb-2008 02:57:43.829 starting BIND 9.3.3rc2 -d 1
27-Feb-2008 02:57:43.832 found 1 CPU, using 1 worker thread
27-Feb-2008 02:57:44.021 loading configuration from '/etc/named.conf'
27-Feb-2008 02:57:44.024 none:0: open: /etc/named.conf: file not found
27-Feb-2008 02:57:44.034 load_configuration: file not found
27-Feb-2008 02:57:44.035 loading configuration: file not found
27-Feb-2008 02:57:44.035 exiting (due to fatal error)

I don't know what to try next. Any help is gratefully accepted.
Reply With Quote
Sponsored Links
  #2  
Old 27th February 2008, 12:16
cooljai cooljai is offline
Member
 
Join Date: May 2007
Location: /dev/random
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to cooljai
 
Default

This will help you: http://www.howtoforge.com/forums/showthread.php?t=17029

Thanks
__________________
Jagbir
Registered Linux User #468658.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Help me PLEASEEEE - PHP Griff Installation/Configuration 21 27th July 2007 19:29
Anyone figured out to integrate FuzzyOCR into ISPConfig on Ubuntu? friday Installation/Configuration 16 10th May 2007 16:25
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 06:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.