Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th February 2008, 21:00
Horizon Horizon is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 6
Thanked 0 Times in 0 Posts
Default Question on Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch)

The message you have entered is too short. Please lengthen your message to at least 10 characters.

Last edited by Horizon; 27th May 2011 at 01:50.
Reply With Quote
Sponsored Links
  #2  
Old 21st February 2008, 17:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

You can use any email client (such as Thunderbird, Evolution, Outlook, etc.) for it. As SMTP- and POP3 server you can use any FQDN or IP address that's pointing to your server; the username is the email address, and then you need the password for that account. Don't forget to enable "Server requires authentication".
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Horizon (26th February 2008)
  #3  
Old 21st February 2008, 19:42
Horizon Horizon is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Edit: the current situation is almost completely working! I got the virtual user logins and such checked out (just a note, maybe clarify the bit about mailbox setup in /home/vmail - I had to make the domain folder and the user folder, then send an email to the account so all the courier stuff got made)

Right now I have Thunderbird talking to them and retrieving emails just fine, however it seems that sending mail from inside Thunderbird doesn't work.

I'm guessing this has to do with the listening on local ports or something, is there a way I can open it up to allow me to send through thunderbird?

It just hangs for a minute or two, then gives me this message:
Sending of message failed.
The message could not be sent because connecting to the SMTP server scriptsamurai.com failed. [...]

Last edited by Horizon; 22nd February 2008 at 03:47.
Reply With Quote
  #4  
Old 22nd February 2008, 17:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by Horizon
I had to make the domain folder and the user folder, then send an email to the account so all the courier stuff got made)
The folders are created automatically when you send the first email to that account.

Quote:
Originally Posted by Horizon
Right now I have Thunderbird talking to them and retrieving emails just fine, however it seems that sending mail from inside Thunderbird doesn't work.

I'm guessing this has to do with the listening on local ports or something, is there a way I can open it up to allow me to send through thunderbird?

It just hangs for a minute or two, then gives me this message:
Sending of message failed.
The message could not be sent because connecting to the SMTP server scriptsamurai.com failed. [...]
What's the output of
Code:
netstat -tap
and
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Horizon (26th February 2008)
  #5  
Old 22nd February 2008, 19:50
Horizon Horizon is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 6
Thanked 0 Times in 0 Posts
Default

Netstat at:
http://s3rve.com/netstat.txt

And the iptables output:
Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
Reply With Quote
  #6  
Old 23rd February 2008, 17:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

The outputs look ok.
Is scriptsamurai.com pointing to the correct server? Have you tried to use the server's IP address in your email client instead of a domain name?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Horizon (26th February 2008)
  #7  
Old 23rd February 2008, 20:52
Horizon Horizon is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 6
Thanked 0 Times in 0 Posts
Default

No, I haven't. I'll try that now. Also, I just had a problem crop up - Clam AV would hang or something and crash hard, making all my mail not get delivered, so it just sat in queue. What I did to fix it was disable antivirus scanning and flush the queue. I'm going to re-enable antivirus scanning in a minute, but have you heard of this happening before?

Edit: Just tried with my server IP, still no dice on sending out. I should be setting up thunderbird to send out on port 25, right?

Edit: After some more tinkering, the issue with the Clam hang is still an issue. I've got it disabled right now (re-commented the antivirus line in /etc/amavis/conf.d/15-content_filter_mode) so mail is delivering properly and such, but I'd like to be able to enable scanning. It just hangs really bad and I get errors in /var/log/mail.log about "all antivirus scanners failed" and it taking longer than 315s to execute and will be killed. top shows a clam process or two that are really CPU-intensive, over 100% CPU usage. I thought maybe it was an issue with my mail queue - maybe a file got sent in that was too large or something? - so I cleared out the mail queue with postsuper. Going to try re-enabling it in a bit.

Last edited by Horizon; 23rd February 2008 at 21:49.
Reply With Quote
  #8  
Old 24th February 2008, 14:20
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Is your server in a local network, or is it connected directly to the internet?
If it's in a local network, have you tried the server private IP address or the public IP address of your router?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Horizon (26th February 2008)
  #9  
Old 24th February 2008, 19:15
Horizon Horizon is offline
Junior Member
 
Join Date: Feb 2008
Posts: 8
Thanks: 6
Thanked 0 Times in 0 Posts
Default

It's a remote server connected to the internet in a datacenter. I've tried two domain names and the IP address. Everything else works fine, it's JUST the connecting to the server to send outgoing mail from within Thunderbird. If I'm on the server as a real user in SSH, I can send from mutt/mail fine, but it shows up as the default hostname for my @ address, not the virtual host I want.
Reply With Quote
  #10  
Old 25th February 2008, 17:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

I can connect:
Code:
mh1:~# telnet scriptsamurai.com 25
Trying 67.207.134.15...
Connected to scriptsamurai.com.
Escape character is '^]'.
220 s3rve.com ESMTP Postfix (Debian/GNU)
ehlo localhost
250-s3rve.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.
mh1:~#
Maybe it'S a problem with your local firewall? Have you tried to connect from another computer?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Horizon (26th February 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) ShadyB HOWTO-Related Questions 1 2nd November 2007 18:23
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) - Page 5 MisterVlad HOWTO-Related Questions 1 2nd November 2007 14:11
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) kdclaver HOWTO-Related Questions 36 23rd August 2007 19:02
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) mcg HOWTO-Related Questions 2 25th July 2007 16:00
Virtual Users And Domains With Postfix, Courier And MySQL & debian etch Tortanick HOWTO-Related Questions 5 19th June 2007 12:29


All times are GMT +2. The time now is 22:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.