Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th February 2008, 09:09
ensens ensens is offline
Member
 
Join Date: Mar 2007
Posts: 35
Thanks: 3
Thanked 0 Times in 0 Posts
Default Debian Etch and Automatix GPG error

Hello,

RE: The Perfect Desktop - Debian Etch (Debian 4.0)

I followed the tutorial and would like to know if anyone knows why the following error pops up when running Synaptic Package Manager:

W: GPG error: http://www.getautomatix.com etch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B87687BBB9E1273B

Thank you for your time and help.

Brian
Reply With Quote
Sponsored Links
  #2  
Old 17th February 2008, 09:30
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Its because you dont have the key that was used to sign the packages do this to fix it
Code:
wget http://www.getautomatix.com/keys/automatix2.key
gpg --import automatix2.key
gpg --export --armor E23C5FC3 | sudo apt-key add -
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 17th February 2008, 12:35
sjau sjau is offline
Local Meanie
 
Join Date: Apr 2006
Location: Switzerland
Posts: 1,149
Thanks: 4
Thanked 56 Times in 52 Posts
Default

I would advice against installing automatix.
__________________
"Common sense is not as common as commonly believed" by sjau

Auto-Install Script for ISPConfig and Horde on a Vanilla Debian Stable

Need more Repos for Ubuntu? Repository Generator
Need more Repos for Debian? Debian Repository Generator
Reply With Quote
  #4  
Old 17th February 2008, 19:31
ensens ensens is offline
Member
 
Join Date: Mar 2007
Posts: 35
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Hi topdog and sjau,

A)
I made a mistake. I'm sorry.
I didn't get that error when I ran Synaptic Package Manager as I wrote in my post.
I got the error when I run apt-get update.

topdog, I ran the commands you told me about previously when I installed Debian following the instructions in the The Perfect Desktop - Debian Etch. Thanks though.

I tried to be accurate with the following information. The end result being I'm going to uninstall Automatix2.

B) Output of the lsb_release & sources.list:
# lsb_release -c
Codename: etch

# lsb_release -r
Release: 4.0

# lsb_release -i
Distributor ID: Debian

# cat /etc/apt/sources.list
####################################
### Official Debian Repositories ###
####################################

deb http://ftp.debian.org/debian/ etch main non-free contrib
deb-src http://ftp.debian.org/debian/ etch main non-free contrib

deb http://security.debian.org/ etch/updates main non-free contrib
deb-src http://security.debian.org/ etch/updates main non-free contrib

deb http://www.debian-multimedia.org etch main
deb-src http://www.debian-multimedia.org etch main

##############################
### Automatix Repositories ###
##############################

deb http://www.getautomatix.com/apt etch main

C) The following is output from apt-get update showing the errors:
# apt-get update
Get:1 http://security.debian.org etch/updates Release.gpg [189B]
Hit http://security.debian.org etch/updates Release
Ign http://security.debian.org etch/updates/main Packages/DiffIndex
Get:2 http://www.debian-multimedia.org etch Release.gpg [189B]
Ign http://security.debian.org etch/updates/non-free Packages/DiffIndex
Ign http://security.debian.org etch/updates/contrib Packages/DiffIndex
Ign http://security.debian.org etch/updates/main Sources/DiffIndex
Ign http://security.debian.org etch/updates/non-free Sources/DiffIndex
Ign http://security.debian.org etch/updates/contrib Sources/DiffIndex
Hit http://security.debian.org etch/updates/main Packages
Hit http://security.debian.org etch/updates/non-free Packages
Hit http://security.debian.org etch/updates/contrib Packages
Hit http://security.debian.org etch/updates/main Sources
Hit http://security.debian.org etch/updates/non-free Sources
Hit http://security.debian.org etch/updates/contrib Sources
Hit http://www.debian-multimedia.org etch Release
Get:3 http://ftp.debian.org etch Release.gpg [378B]
Ign http://www.debian-multimedia.org etch/main Packages/DiffIndex
Ign http://www.debian-multimedia.org etch/main Sources/DiffIndex
Hit http://ftp.debian.org etch Release
Get:4 http://www.getautomatix.com etch Release.gpg [189B]
Hit http://www.debian-multimedia.org etch/main Packages
Hit http://www.debian-multimedia.org etch/main Sources
Ign http://ftp.debian.org etch/main Packages/DiffIndex
Ign http://ftp.debian.org etch/non-free Packages/DiffIndex
Ign http://ftp.debian.org etch/contrib Packages/DiffIndex
Hit http://www.getautomatix.com etch Release
Err http://www.getautomatix.com etch Release

Ign http://ftp.debian.org etch/main Sources/DiffIndex
Ign http://ftp.debian.org etch/non-free Sources/DiffIndex
Ign http://ftp.debian.org etch/contrib Sources/DiffIndex
Hit http://ftp.debian.org etch/main Packages
Hit http://ftp.debian.org etch/non-free Packages
Hit http://ftp.debian.org etch/contrib Packages
Hit http://ftp.debian.org etch/main Sources
Hit http://ftp.debian.org etch/non-free Sources
Get:5 http://www.getautomatix.com etch Release [6744B]
Hit http://ftp.debian.org etch/contrib Sources
Ign http://www.getautomatix.com etch Release
Ign http://www.getautomatix.com etch/main Packages/DiffIndex
Hit http://www.getautomatix.com etch/main Packages
Fetched 6936B in 2s (2452B/s)
Reading package lists... Done
W: GPG error: http://www.getautomatix.com etch Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY B87687BBB9E1273B
W: You may want to run apt-get update to correct these problems

D) I searched the forum at http://www.getautomatix.com and found a post that may have something to do with my errors. But, I don't know enough about Automatix to know if the post below has anything to do with the errors I'm getting but here's the link to the post at getautomatix.com/forum:

http://tinyurl.com/2b5dhb
If that link doesn't work try,
http://www.getautomatix.com/forum/in...8&hl=NO_PUBKEY

E) I think the instructions in the Perfect Desktop tutorial imply that Automatix2 is needed. The instructions are:

In the left window you see all available package groups (File Sharing, Web Browsers, etc.), and in the right window there are all packages that belong to the package group and that can be installed by Automatix. Select the following packages for installation:

* Skype
* AUD-DVD Codecs
* Flash Player
* MPlayer and FF Plugin
* Multimedia Codecs
* Sun Java 1.5 JRE
* DVD Ripper
* RealPlayer
* Automatix read/write NTFS and FAT32 Mounter
* Extra Fonts
* Acrobat Reader
* Google Earth
* Google Picasa
* Opera Browser

So, I assumed Debian must need Automatix2.

With Automatix2 I installed some cool programs like Brasero and Skype.
But was unable to install the Multimedia Codecs and that's basically what I wanted.

I got errors when installing "Multimedia Codecs" and "Swiftfox Plugins".
I got same errors when trying to install only "Multimedia Codecs".
I got same errors when trying to install only "Swiftfox Plugins".
I got same errors when trying to install only "Swiftfox Browser".

The errors:
[02/17/2008 - 07:13.13] - !!SCRIPT OUTPUT START!!

!!SCRIPT OUTPUT END!!
[02/17/2008 - 07:13.14] - ERRORS OR WARNINGS WHERE REPORTED
[02/17/2008 - 07:13.14] - FATAL - Multimedia Codecs - An apt-based error occurred and installation was unsuccessful
[02/17/2008 - 07:13.14] - FATAL - Swiftfox Plugins - Automatix cannot detect a Swiftfox installation in the standard location set by Automatix. Please install Swiftfox from Automatix before attempting to install its plugins
[02/17/2008 - 07:14.21] - !!SCRIPT OUTPUT START!!
Reading package lists... Done
Building dependency tree... Done
totem-xine is already the newest version.
libxvidcore4 is already the newest version.
ffmpeg is already the newest version.
gstreamer0.10-ffmpeg is already the newest version.
gstreamer0.10-plugins-base is already the newest version.
gstreamer0.10-plugins-good is already the newest version.
gstreamer0.10-plugins-ugly is already the newest version.
alsa-oss is already the newest version.
The following extra packages will be installed:
libcurl3-gnutls libmjpegtools0 libmms0 libmp4v2-0 libquicktime0 libwavpack0
Suggested packages:
toolame mpeg2dec a52dec
The following packages will be REMOVED:
libesd0
The following NEW packages will be installed:
esound-clients faac faad gnome-audio gstreamer0.10-fluendo-mp3
gstreamer0.10-gnonlin gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly-dbg lame
libcurl3-gnutls libdivx0-binary libdivxdecore0-binary libdivxencore0-binary
libesd-alsa0 libmjpegtools0 libmms0 libmp4v2-0 libquicktime0 libwavpack0 mjpegtools
mpg321 sox vorbis-tools
0 upgraded, 23 newly installed, 1 to remove and 0 not upgraded.
Need to get 6048kB of archives.
After unpacking 15.3MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
libdivx0-binary libdivxdecore0-binary libdivxencore0-binary
E: There are problems and -y was used without --force-yes
Reading package lists... Done
Building dependency tree... Done
totem-xine is already the newest version.
libxvidcore4 is already the newest version.
ffmpeg is already the newest version.
gstreamer0.10-ffmpeg is already the newest version.
gstreamer0.10-plugins-base is already the newest version.
gstreamer0.10-plugins-good is already the newest version.
gstreamer0.10-plugins-ugly is already the newest version.
alsa-oss is already the newest version.
The following extra packages will be installed:
libcurl3-gnutls libmjpegtools0 libmms0 libmp4v2-0 libquicktime0 libwavpack0
Suggested packages:
toolame mpeg2dec a52dec
The following packages will be REMOVED:
libesd0
The following NEW packages will be installed:
esound-clients faac faad gnome-audio gstreamer0.10-fluendo-mp3
gstreamer0.10-gnonlin gstreamer0.10-plugins-bad gstreamer0.10-plugins-ugly-dbg lame
libcurl3-gnutls libdivx0-binary libdivxdecore0-binary libdivxencore0-binary
libesd-alsa0 libmjpegtools0 libmms0 libmp4v2-0 libquicktime0 libwavpack0 mjpegtools
mpg321 sox vorbis-tools
0 upgraded, 23 newly installed, 1 to remove and 0 not upgraded.
Need to get 6048kB of archives.
After unpacking 15.3MB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
libdivx0-binary libdivxdecore0-binary libdivxencore0-binary
E: There are problems and -y was used without --force-yes

!!SCRIPT OUTPUT END!!
[02/17/2008 - 07:14.22] - !!SCRIPT OUTPUT START!!

!!SCRIPT OUTPUT END!!
[02/17/2008 - 07:14.22] - ERRORS OR WARNINGS WHERE REPORTED
[02/17/2008 - 07:14.22] - FATAL - Multimedia Codecs - An apt-based error occurred and installation was unsuccessful
[02/17/2008 - 07:14.22] - FATAL - Swiftfox Plugins - Automatix cannot detect a Swiftfox installation in the standard location set by Automatix. Please install Swiftfox from Automatix before attempting to install its plugins

F) I'm going to uninstall automatix and comment out it's line in sources.list.

Thanks again for your help and time.


Brian
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Automatix on Debian Etch 4.0 r1 i386 cyberwiz HOWTO-Related Questions 2 12th August 2008 11:43


All times are GMT +2. The time now is 11:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.