#1  
Old 16th February 2008, 00:11
Buzzen Buzzen is offline
Member
 
Join Date: Mar 2007
Posts: 31
Thanks: 4
Thanked 0 Times in 0 Posts
Exclamation Change FTP port in Backup.

In admin backup function, a user must enter the Ftp-Server, Path, Username and Password but there is no option to modify the port.

I want to backup to a server on a private port.

I have tried many formats but only receive this error "The name of the FTP server contains invalid characters."

Question is, how do I change the default port in the backup function to connect to the port our secure server is listening on??
__________________
Debian Lenny Perfect Install - ISPConfig 3.0.1.6
******************************
Dell Poweredge 1950
2 x 3.73Ghz DualCore Xeon 2x2MB
16GB DDR2 667 ECC REG
2 x 2TB (raid 1)
Reply With Quote
Sponsored Links
  #2  
Old 16th February 2008, 09:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,672
Thanks: 819
Thanked 5,317 Times in 4,170 Posts
Default

You will have to change it in the source code of the file /home/admispconfig/ispconfig/web/tools/tools/backup/backup.php

by changing the line 168 from:

$conn_id = @ftp_connect("$ftp_server");

to

$conn_id = @ftp_connect("$ftp_server",1234);

were 1234 is the number of the port.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Buzzen (16th February 2008)
  #3  
Old 16th February 2008, 09:39
Buzzen Buzzen is offline
Member
 
Join Date: Mar 2007
Posts: 31
Thanks: 4
Thanked 0 Times in 0 Posts
 
Default

Thanks very much Till (Y)
__________________
Debian Lenny Perfect Install - ISPConfig 3.0.1.6
******************************
Dell Poweredge 1950
2 x 3.73Ghz DualCore Xeon 2x2MB
16GB DDR2 667 ECC REG
2 x 2TB (raid 1)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
FTP Error joshabts Installation/Configuration 3 4th November 2006 16:19
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40
WEB UI FTP not working gimhan90 Installation/Configuration 2 16th March 2006 08:03
Website users? ctroyp General 25 6th January 2006 18:02


All times are GMT +2. The time now is 19:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.