Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th February 2008, 19:56
jag7720 jag7720 is offline
Member
 
Join Date: Nov 2007
Location: Kansas City, MO
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default multiple IPs and Vhosts_ispconfig.conf

My server has 6 IPs. All bound to one NIC eth0 thru eth0:4

All ping and respond and are usable.

I was only using one IP for all virtual hosts when I first installed SIPConfig.

I added the rest of the IPs to the server IP List and set one of the sites to use one of the additional IPs. When I try to access that site it goes to a "shared IP" page (/var/www/sharedip)

Here is the top of my Vhosts_ispconfig.conf with the additional IPs in it

Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 66.xxx.xxx.82:80
<VirtualHost 66.xxx.xxx.82:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 66.xxx.xxx.83:80
<VirtualHost 66.xxx.xxx.83:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 66.xxx.xxx.84:80
<VirtualHost 66.xxx.xxx.84:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 66.xxx.xxx.85:80
<VirtualHost 66.xxx.xxx.85:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 66.xxx.xxx.86:80
<VirtualHost 66.xxx.xxx.86:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 66.xxx.xxx.87:80
<VirtualHost 66.xxx.xxx.87:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
All the sites set to use the main IP 66.xxx.xxx.82 work. But the one site that is set to use an additional IP 66.xxx.xxx.83 only goes to the shared ip page.

What is ISPConfig doing/not doing to make this not happen? Should ISPConfig do something to make this work? or is this a manual edit?

Here is the vhost that is not working... ISPConfig did this

Code:
######################################
# Vhost: www.domain.com:80
######################################
#
#
<VirtualHost 66.xxx.xxx.83:80>
ServerName www.domain.com:80
ServerAdmin webmaster@domain.com
DocumentRoot /var/www/web10/web
ServerAlias domain.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm

etc...
DNS is functioning as it should.

Can someone help me figure this out?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2008, 11:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,405
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
 
Default

The setup and config files are all fine. Please double check that www.domain.com points really to the IP that you selected for the vhost.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 05:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.