#1  
Old 13th February 2008, 16:10
Aloa Aloa is offline
Junior Member
 
Join Date: Feb 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default php4 problem after update

Hi guys
I have Suse 10.0 ispconfig 2.2.19 and php4 for cgi use and php5 for apache_mod
I have sites working in php4 ana in php5 ..
after update to 2.2.20 .. sites used php4 brings errors ..
Code:
.............
Warning: Unexpected character in input: ' in /web/web4/cgi-bin/php on line 2130
Warning: Unexpected character in input: ' in /web/web4/cgi-bin/php on line 2130
Parse error: parse error, unexpected T_STRING in /web/web4/cgi-bin/php on line 2130
...............
i check Ispconfig site and see 2.2.20 .. make update
and again .. sites used php5 work fine .. but php4 give errors ..
Code:
.............
Warning: Unexpected character in input: ' in /web/web4/cgi-bin/php on line 2130
Warning: Unexpected character in input: ' in /web/web4/cgi-bin/php on line 2130
Parse error: parse error, unexpected T_STRING in /web/web4/cgi-bin/php on line 2130
...............
i switch php in apache directives ..
AddHandler php-script .php
Action php-script /cgi-bin/php

Any ideas .. where i check the problem ?

Thanks in advance Aloa
Reply With Quote
Sponsored Links
  #2  
Old 14th February 2008, 12:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,613 Times in 4,424 Posts
Default

What's in line 2130 of the file /web/web4/cgi-bin/php ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th February 2008, 13:23
Aloa Aloa is offline
Junior Member
 
Join Date: Feb 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

this is php executable file .. same as /usr/bin/php .. core php ..
cant see line 2130 ..
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
How To Install MySQL 4.1 And PHP4 On Debian Etch Problem djc_2008 HOWTO-Related Questions 1 13th February 2008 19:04
Problem with the new update (.19) galphanet Installation/Configuration 1 9th January 2008 20:08
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 06:19


All times are GMT +2. The time now is 04:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.