#1  
Old 12th February 2008, 21:41
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Question Remoting problem

Hi All,

I've problem with remote plugin, after two post on this post (http://www.howtoforge.com/forums/showthread.php?t=14766) with no help. I decided to create new topic on this subforum.

I use autosignup script with ISPConfig 2.2.20 on debian etch updated. ISPConfig is compile with xml support (https://cronos.espace4you.org:81/phpinfo.php). Curl is install on client support script (http://www.espace4you.org/phpinfo.php). ISPConfig_kunde.lib.php is install. When I test the script it work correctly with no error, but after I go on ISPConfig interface and user, domain and website are not created.

If anyone can help me, please ?

Thanks in advance.

PS : I joined my script
Attached Files
File Type: zip test.zip (5.6 KB, 155 views)
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's

Last edited by Gimly; 13th February 2008 at 13:43.
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2008, 10:43
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Did you create a remoting user in ISPConfig and used this user in your script to connect to the ispconfig server?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th February 2008, 11:34
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

Hi Till,

Yes, I added user e4yremote with the password on ispconfig. I selected options create user, create web, etc ... But it doesn't work. Remoting support ssl (https://) ?

Thanks for your answer
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #4  
Old 13th February 2008, 22:20
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

I tested with remoting_example, I have the same problem. Remoting are support on ISConfig 2.2.21 ?
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #5  
Old 14th February 2008, 11:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please try this:

http://www.howtoforge.com/forums/showthread.php?t=17281
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 14th February 2008, 13:48
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

I try it, but I've the same problem ... There are full tutorial about remoting install ? I could made errors during installing.
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #7  
Old 14th February 2008, 19:07
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

This is the result on ssl_request_log of ispconfig :

Quote:
[14/Feb/2008:18:56:07 +0100] 91.121.78.119 TLSv1 DHE-RSA-AES256-SHA "POST /remote/index.php HTTP/1.0" 2051
[14/Feb/2008:18:56:07 +0100] 91.121.78.119 TLSv1 DHE-RSA-AES256-SHA "POST /remote/index.php HTTP/1.0" 198
[14/Feb/2008:18:56:07 +0100] 91.121.78.119 TLSv1 DHE-RSA-AES256-SHA "POST /remote/index.php HTTP/1.0" 198
[14/Feb/2008:18:56:07 +0100] 91.121.78.119 TLSv1 DHE-RSA-AES256-SHA "POST /remote/index.php HTTP/1.0" 198
[14/Feb/2008:18:56:07 +0100] 91.121.78.119 TLSv1 DHE-RSA-AES256-SHA "POST /remote/index.php HTTP/1.0" 1846
and here the result of ssl_engine_log :

Quote:
[14/Feb/2008 18:56:07 16459] [info] Connection: Client IP: 91.121.78.119, Protocol: TLSv1, Cipher: DHE-RSA-AES256-SHA (256/256 bits)
[14/Feb/2008 18:56:07 16459] [info] Initial (No.1) HTTPS request received for child 1 (server cronos.espace4you.org:81)
[14/Feb/2008 18:56:07 16459] [info] Connection to child 1 closed with standard shutdown (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 15987] [info] Connection to child 0 established (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 15987] [info] Seeding PRNG with 1160 bytes of entropy
[14/Feb/2008 18:56:07 15987] [info] Connection: Client IP: 91.121.78.119, Protocol: TLSv1, Cipher: DHE-RSA-AES256-SHA (256/256 bits)
[14/Feb/2008 18:56:07 15987] [info] Initial (No.1) HTTPS request received for child 0 (server cronos.espace4you.org:81)
[14/Feb/2008 18:56:07 15987] [info] Connection to child 0 closed with standard shutdown (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 16459] [info] Connection to child 1 established (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 16459] [info] Seeding PRNG with 1160 bytes of entropy
[14/Feb/2008 18:56:07 16459] [info] Connection: Client IP: 91.121.78.119, Protocol: TLSv1, Cipher: DHE-RSA-AES256-SHA (256/256 bits)
[14/Feb/2008 18:56:07 16459] [info] Initial (No.1) HTTPS request received for child 1 (server cronos.espace4you.org:81)
[14/Feb/2008 18:56:07 16459] [info] Connection to child 1 closed with standard shutdown (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 15987] [info] Connection to child 0 established (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 15987] [info] Seeding PRNG with 1160 bytes of entropy
[14/Feb/2008 18:56:07 15987] [info] Connection: Client IP: 91.121.78.119, Protocol: TLSv1, Cipher: DHE-RSA-AES256-SHA (256/256 bits)
[14/Feb/2008 18:56:07 15987] [info] Initial (No.1) HTTPS request received for child 0 (server cronos.espace4you.org:81)
[14/Feb/2008 18:56:07 15987] [info] Connection to child 0 closed with standard shutdown (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 16459] [info] Connection to child 1 established (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:07 16459] [info] Seeding PRNG with 1160 bytes of entropy
[14/Feb/2008 18:56:07 16459] [info] Connection: Client IP: 91.121.78.119, Protocol: TLSv1, Cipher: DHE-RSA-AES256-SHA (256/256 bits)
[14/Feb/2008 18:56:07 16459] [info] Initial (No.1) HTTPS request received for child 1 (server cronos.espace4you.org:81)
[14/Feb/2008 18:56:07 16459] [info] Connection to child 1 closed with standard shutdown (server cronos.espace4you.org:81, client 91.121.78.119)
[14/Feb/2008 18:56:10 15987] [info] Connection to child 0 established (server cronos.espace4you.org:81, client 86.221.55.97)
[14/Feb/2008 18:56:10 15987] [info] Seeding PRNG with 1160 bytes of entropy
if the result can help you ?
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #8  
Old 14th February 2008, 22:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Quote:
Originally Posted by Gimly
I try it, but I've the same problem ... There are full tutorial about remoting install ? I could made errors during installing.
We dont have a tutorial for this. But I installed the remoting framework for a client on 2.2.19 and it worked and as far as I know, there are no changes in 2.2.21 related to the remoting framework.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 15th February 2008, 08:06
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
Default

Ok, I retest again. Thank you till for your help
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
  #10  
Old 17th February 2008, 16:59
Gimly Gimly is offline
HowtoForge Supporter
 
Join Date: Mar 2007
Location: France
Posts: 144
Thanks: 26
Thanked 4 Times in 4 Posts
 
Default

I load the remoting_example script from the ISPConfig website and done all the configuration.
1-Install the remoting extension in ISPConfig.
2- Add a new remoting user in my ISPConfig.
Then check all checkboxes for functions that shall be
available for the user.
3- Copy the php scripts to a php enabled Webserver.
4- Edit the test.php script with my remote user and uncomment client list function => It work.
5- Edit test.php with adding client function => "script end ...". Doesn't work

If anyone have an idea ?

Thank you for your help.
__________________
4 virtual machines with Debian Lenny updated on proxmox (openvz) with ISPConfig 3.0.1.6

ns1 : http(s), ftp(s), DNS Master, ISPConfig
sql : MySQL database users
mail : All mail system
ns2 : DNS Slave

ISPConfig.be Admin's
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Problem with Remoting Framework gilogo13 Installation/Configuration 6 23rd April 2008 09:18
Remoting framework 2.2.17 Script end (no data) problem wojtek Installation/Configuration 1 14th October 2007 12:42
remoting framework problem with 2.2.14 mumbly Installation/Configuration 27 11th July 2007 20:17


All times are GMT +2. The time now is 22:03.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.