Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th February 2008, 12:01
DCGWS DCGWS is offline
Junior Member
 
Join Date: Dec 2007
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default Problems after server transfer!!!

After reading a tutorial here on transfering a server from one box to another, I have several nuisances which are driving me mad.

Let me say 1st that my server is working, ISPConfig is working and Apache2 is working, correctly servering pages.

Background:

1st server was Fedora Core 8.

2nd server Debian Etch

When dumping the sql dump using command line, it included the mysql database from the first server. I didn't notice this and I imported this dump file using phpmyadmin on the debian box. Well, as you can imgaine, I have issues concerning this.

Here is what I am getting:

Access denied for user 'debian-sys-maint'@'localhost' (using password: YES) -- This I have been able to fix inserting the user into the new mysql.user table.

Now when I try to fix the root user, I get a duplicate key issue.

This is my error message:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'

2nd issue:

When I upload files to my webs, they are issued www-data www-data as file ownership.

Can someone please help me fix this? Also, I cannot start/stop/restart services from ISPConfig control panel anymore.

NOTE: I have approximately 62 websites on this new box and they are all functioning, so reinstalling the OS/server isn't an option for me.
Reply With Quote
Sponsored Links
  #2  
Old 8th February 2008, 18:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by DCGWS
Now when I try to fix the root user, I get a duplicate key issue.

This is my error message:
mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'
Take a look here: http://www.howtoforge.com/forums/sho...orgot+password

Quote:
Originally Posted by DCGWS
2nd issue:

When I upload files to my webs, they are issued www-data www-data as file ownership.

Can someone please help me fix this? Also, I cannot start/stop/restart services from ISPConfig control panel anymore.
How do you upload the files? With an FTP client?
Can you start/stop/restart the services on the command line?
I think the problem might be that the isp_server table contains values for Fedora, but your new system is Debian, so you might have to adjust these values.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 8th February 2008, 19:06
DCGWS DCGWS is offline
Junior Member
 
Join Date: Dec 2007
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default Mysql Error

Thanks, Falko for responding.

I checked the isp_server table and there were a couple of problems there.

I still have the error when starting mysql, yet I can login to mysql using my root password. I think the problem is with the /etc/password and/or /etc/shadow.
Reply With Quote
  #4  
Old 9th February 2008, 19:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by DCGWS
I still have the error when starting mysql,
What's the exact error message?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th February 2008, 20:09
DCGWS DCGWS is offline
Junior Member
 
Join Date: Dec 2007
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default

mysqladmin: connect to server at 'localhost' failed
error: 'Access denied for user 'root'@'localhost' (using password: YES)'
Reply With Quote
  #6  
Old 10th February 2008, 18:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's the output of
Code:
ls -l /etc/mysql
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 12th February 2008, 19:07
DCGWS DCGWS is offline
Junior Member
 
Join Date: Dec 2007
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default

drwxr-xr-x 2 mysql mysql 4096 2008-02-08 12:02 conf.d
-rw------- 1 root root 298 2008-02-06 13:14 debian.cnf
-rwxr-xr-x 1 mysql mysql 1102 2008-01-16 03:57 debian-start
-rw-r--r-- 1 mysql mysql 3571 2008-02-06 13:17 my.cnf
-rw-r--r-- 1 mysql mysql 3571 2008-01-16 16:51 my.cnf_old
Reply With Quote
  #8  
Old 13th February 2008, 19:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's in the debian.cnf and the debian-start files?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 13th February 2008, 19:32
DCGWS DCGWS is offline
Junior Member
 
Join Date: Dec 2007
Posts: 17
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Here is my /etc/mysql/debian-start

Code:
#!/bin/bash
#
# This script is executed by "/etc/init.d/mysql" on every (re)start.
# 
# Changes to this file will be preserved when updating the Debian package.
#

source /usr/share/mysql/debian-start.inc.sh

MYADMIN="/usr/bin/mysqladmin --defaults-file=/etc/mysql/my.cnf"
MYUPGRADE="/usr/bin/mysql_upgrade --defaults-extra-file=/etc/mysql/my.cnf"
MYCHECK="/usr/bin/mysqlcheck --defaults-file=/etc/mysql/my.cnf"
MYCHECK_SUBJECT="WARNING: mysqlcheck has found corrupt tables"
MYCHECK_PARAMS="--all-databases --fast --silent"
MYCHECK_RCPT="root"

# The following commands should be run when the server is up but in background
# where they do not block the server start and in one shell instance so that
# they run sequentially. They are supposed not to echo anything to stdout.
# If you want to disable the check for crashed tables comment
# "check_for_crashed_tables" out.  
# (There may be no output to stdout inside the background process!)
echo "Checking for corrupt, not cleanly closed and upgrade needing tables."
(
  upgrade_system_tables_if_necessary;
  check_for_crashed_tables;
) >&2 &

exit 0
And this is my /etc/mysql/debian.cnf

Code:
# Automatically generated for Debian scripts. DO NOT TOUCH!
[client]
host     = localhost
user     = debian-sys-maint
password = xxxxxxxxx
socket   = /var/run/mysqld/mysqld.sock
[mysql_upgrade]
user     = debian-sys-maint
password = xxxxxxxxx
socket   = /var/run/mysqld/mysqld.sock
basedir  = /usr
Falko--

I should note here that I was having problems with debian-sys-maint user before this particular error. I fixed it by adding a new debian-sys-maint user to the mysql user table.
Reply With Quote
  #10  
Old 14th February 2008, 19:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

And the password for the debian-sys-maint user is now correct in /etc/mysql/debian.cnf?

Is the root password listed in my.cnf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LVS-NAT: Problems with PHP-SOAP server behind ldirectord andeas-2008 HOWTO-Related Questions 2 23rd April 2008 19:12
cacti problem - graphs have huge gaps Chip Installation/Configuration 7 8th February 2008 00:24
VMWare Server for Ubuntu Edgy Eft - Problems AEngineer Installation/Configuration 10 8th November 2007 08:46
Server Not Autorative for Domain Error drbista Installation/Configuration 10 20th December 2005 17:41
problems with ftp server webstergd Installation/Configuration 5 13th December 2005 12:13


All times are GMT +2. The time now is 16:58.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.