Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th January 2006, 06:23
jason_worthen jason_worthen is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix... "unknown user" error

i have followed the Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV) to a tee (geez, ive gone over it 5 times -- i sure hope i have). i had to update my .cf files because i am running postfix 2.2.4 but still am receiving an "unknown user" error.

i am not sure what all info would be necessary to troubleshoot this but i am including my mysql-virtual_mailboxes.cf file as a starting point:

Code:
user = mail_admin
password = p0stf1x_#dm!n
dbname = mail
query = SELECT CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/') FROM users WHERE email='%s'
hosts = 127.0.0.1
error in /var/log/mail.log

Code:
Jan 11 22:10:44 plink postfix/local[19703]: 254F8E4270: to=<jason@plink.worthen.org>, relay=local, delay=0, status=bounced (unknown user: "jason")
additionally, here is a select from MySQL:

Code:
+-------------------------+---------------+----------+
| email                   | password      | quota    |
+-------------------------+---------------+----------+
| jason@plink.worthen.org | ZBAdWFDgD4AbM | 10485760 |
+-------------------------+---------------+----------+
Code:
+-------------------+
| domain            |
+-------------------+
| plink.worthen.org |
+-------------------+

Last edited by jason_worthen; 12th January 2006 at 07:54.
Reply With Quote
Sponsored Links
  #2  
Old 12th January 2006, 13:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Do you use Debian Sarge? Because the Postfix version on Debian Sarge is 2.1.5, that's the version used in the tutorial.

For Postfix 2.2, the format has changed a little bit: http://www.howtoforge.com/forums/sho...?t=1149&page=4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th January 2006, 16:59
jason_worthen jason_worthen is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I use Ubuntu 5.10. I did see something in my log that I didn't catch last night...

Code:
postfix/smtpd[19702]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
No clue how to debug that yet...
Reply With Quote
  #4  
Old 12th January 2006, 23:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Have a look at this thread: http://www.howtoforge.com/forums/showthread.php?t=861, especially the last post which is related to the file /etc/pam.d/smtp. So you should check the content of that file again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th January 2006, 05:33
jason_worthen jason_worthen is offline
Junior Member
 
Join Date: Jan 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default good to go!

I was able to send email and receive email now. Thanks!

Interestingly, I still am receiving an error in the auth.log:

Code:
Jan 12 21:28:12 plink postfix/smtpd[7712]: sql_select option missing
Jan 12 21:28:12 plink postfix/smtpd[7712]: auxpropfunc error no mechanism available
Jan 12 21:28:12 plink postfix/smtpd[7712]: _sasl_plugin_load failed on sasl_auxprop_plug_init for plugin: sql
it does not appear to effect the working of the configuration, however.

thanks again!!
Reply With Quote
  #6  
Old 14th January 2006, 00:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

I'd compare your configuration files with the ones from the tutorial. Maybe you made a typo somewhere. Please take care about the format of the configuration files, especially Courier is very finicky about whitespaces, tabs and so on.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 25th June 2006, 01:52
triple5 triple5 is offline
Junior Member
 
Join Date: Jun 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default please give some information

Quote:
Originally Posted by jason_worthen
I was able to send email and receive email now. Thanks!
Please say what the problem was... what did you do? This way you could help me, because I have a similar problem...

I get the following in my /var/log/mail.info:
Code:
Jun 25 01:07:21 localhost amavis[8960]: (08960-05) mail_via_smtp: 450 4.4.1 Can't connect to 127.0.0.1 port 10025, Bad file descriptor at /usr/sbin/amavisd-new line 2912, <GEN17> line 467., id=08960-05
I have been following (Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV)) howto
using debian sarge and postfix 2.1.5

this line (2912)reads:
Code:
       defined($smtp_handle)
and this is a few lines above
Code:
$smtp_handle = Net::SMTP->new("$relayhost:$relayhost_port",
            Hello => $localhost_name, ExactAddresses => 1,
            Timeout => max(60, min(5*60,$remaining_time)), # for each operation
I get this error in /var/log/mail.info
Code:
Jun 25 01:30:52 localhost dccproc[19496]: socket(UDP): Address family not supported by protocol
Jun 25 01:30:53 localhost postfix/smtpd[19497]: fatal: unexpected command-line argument: permit_mynetworks,
Jun 25 01:30:54 localhost amavis[8960]: (08960-06) mail_via_smtp: 450 4.4.1 Can't connect to 127.0.0.1 port 10025, Bad file descriptor at /usr/sbin/amavisd-new line 2912, <GEN17> line 560., id=08960-06
Jun 25 01:30:54 localhost postfix/master[19475]: warning: process /usr/lib/postfix/smtpd pid 19497 exit status 1
Jun 25 01:30:54 localhost postfix/master[19475]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Jun 25 01:30:54 localhost amavis[8960]: (08960-06) Not-Delivered,  ..........................................................................................
I don't get where my mistake is...
I was never able to use the smtp to send mail via thunderbird. The Webserver that I have running on there could once deliver mail only to those virtual mailboxes which I could pickup by IMAP fine, but I couldn't use the same server for sending.

Also, if I had someone send mail to any other domain (e.g. via the online registration form for my website) it wouldn't send it.

Thanks for the help, though, I hope I can get some more.
(Yes I have checked the files again.) But I must have overlooked something somewhere...

Last edited by triple5; 25th June 2006 at 02:32. Reason: to correct and be more specific
Reply With Quote
  #8  
Old 25th June 2006, 06:39
triple5 triple5 is offline
Junior Member
 
Join Date: Jun 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default solved

I found the problem: it cannot be a space after the "=" and "permit_mynetworks"
it must be "=permit_mynetworks"

but this was not the only problem, i had to create the file
Code:
/etc/postfix/sasl_passwd
and do
Code:
postmap /etc/postfix/sasl_passwd
so that sasl works properly.

so far everything seems to be working...
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota... killfrog HOWTO-Related Questions 3 25th September 2009 22:45
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ruskicar HOWTO-Related Questions 26 20th July 2007 17:28
Virtual Users And Domains With Postfix, Courier And MySQL: POP/IMAP authentication SeanG HOWTO-Related Questions 3 1st January 2006 18:08
Error witch PatchVirtual Users And Domains With Postfix, Courier And MySQL pontifex HOWTO-Related Questions 3 31st December 2005 00:29
Virtual Users And Domains With Postfix, etc, problem with SMTP/Auth wrong password ggere HOWTO-Related Questions 15 14th November 2005 17:08


All times are GMT +2. The time now is 23:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.