#1  
Old 5th August 2005, 22:50
traxxdata traxxdata is offline
Junior Member
 
Join Date: Aug 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default normal HTTPD wont start

using fedora core 4
installed everything without a prob
when i want start httpd i get this eror in my /var/log/http/error_log
__begin past


unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d': Permission denied
Unable to open logs
[root@vac httpd]#

__end past


looked at ther permissions at those files..
__begin past
[root@vac httpd]# ls -al /root/ispconfig/cronolog
-rwxr-xr-x 1 root root 55866 aug 5 17:58 /root/ispconfig/cronolog
[root@vac httpd]#

[root@vac httpd]# ls -al /var/log/httpd/ispconfig_access_log_%Y_%m_%d
ls: /var/log/httpd/ispconfig_access_log_%Y_%m_%d: Onbekend bestand of map <dutch for unkown file>
[root@vac httpd]#

[root@vac httpd]# ls -al /var/log/httpd/ispconfig_access_log
-rw-r--r-- 1 root root 0 aug 5 17:58 /var/log/httpd/ispconfig_access_log
[root@vac httpd]#

--endpast

it seems to me the parameters %y %d %m are past to cornolog
but if i do cronolog --help %y for example doesnt show..

Even from the ispconfig console under services i am not able to start the normal httpd
https on port 81 runs perfect.

anyone might have an idea of what is wrong? <or what i doin/did wrong ??>
Reply With Quote
Sponsored Links
  #2  
Old 6th August 2005, 11:29
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Quote:
Originally Posted by traxxdata
using fedora core 4
installed everything without a prob
when i want start httpd i get this eror in my /var/log/http/error_log
__begin past


unable to start piped log program '/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d': Permission denied
Unable to open logs
[root@vac httpd]#

__end past


looked at ther permissions at those files..
__begin past
[root@vac httpd]# ls -al /root/ispconfig/cronolog
-rwxr-xr-x 1 root root 55866 aug 5 17:58 /root/ispconfig/cronolog
[root@vac httpd]#

[root@vac httpd]# ls -al /var/log/httpd/ispconfig_access_log_%Y_%m_%d
ls: /var/log/httpd/ispconfig_access_log_%Y_%m_%d: Onbekend bestand of map <dutch for unkown file>
[root@vac httpd]#

[root@vac httpd]# ls -al /var/log/httpd/ispconfig_access_log
-rw-r--r-- 1 root root 0 aug 5 17:58 /var/log/httpd/ispconfig_access_log
[root@vac httpd]#

--endpast

it seems to me the parameters %y %d %m are past to cornolog
but if i do cronolog --help %y for example doesnt show..

Even from the ispconfig console under services i am not able to start the normal httpd
https on port 81 runs perfect.

anyone might have an idea of what is wrong? <or what i doin/did wrong ??>

The cronolog line in httpd.conf is correct and the cronolog binary has the correct permissions.

Have you enabled somtehing like SE Linux or any apache directive that permits apache to start piped programs in the /root directory or that are not owned by the apache user?
Reply With Quote
  #3  
Old 7th August 2005, 17:21
traxxdata traxxdata is offline
Junior Member
 
Join Date: Aug 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

you where correct the problem was SE linux

i now have disabled the SELinux httpd deamon.

don know if that is a proper or correct way to do.
<SElinux is somehow new to me>

so im open for any ideas to work around this problem and still enable the selinux httpd deamon.

greetz TraXX
Reply With Quote
  #4  
Old 7th August 2005, 19:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,258 Times in 4,122 Posts
Default

Quote:
Originally Posted by traxxdata
you where correct the problem was SE linux

i now have disabled the SELinux httpd deamon.

don know if that is a proper or correct way to do.
<SElinux is somehow new to me>

so im open for any ideas to work around this problem and still enable the selinux httpd deamon.

greetz TraXX
Maybe it helps to chown the cronolog binary to the httpd user or put the cronolog binary in the location where SE linux allows it to be exectuted (I'am not familar with SE linux so i dint know where it expects binarys).
Reply With Quote
  #5  
Old 1st February 2008, 17:23
zetnsh zetnsh is offline
Senior Member
 
Join Date: Aug 2007
Posts: 111
Thanks: 8
Thanked 5 Times in 5 Posts
 
Default

If it helps anyone else (2 years on!) I've just discovered that there's more to disabling SELinux than just running system-config-securitylevel (that's assuming a Fedora variant). In one case that didn't, on it's own, disable SELinux.

See this post for details!

Thanks,

Neil
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HowTo start developing ISPConfig till Developers' Forum 18 25th April 2014 20:43


All times are GMT +2. The time now is 11:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.