Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 6th February 2008, 10:09
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,482
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

Please do not add addresses manually in the virtusertable. Remove the lines you added manually and create the email address in ISPConfig instead. Also make sure that the website www.plainmortgageadvice.co.uk has a co-domain plainmortgageadvice.co.uk with empty host field.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 6th February 2008, 11:21
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

We are getting there. Thanks, Till. My system uses Tinydns, ISPConfig uses Bind. So whilst I have been setting up the DNS records correctly by hand and ISPConfig has been finding where to get and send stuff from and to, the subdomains had not been set up in ISPConfig. madmucho, you were correct after all.

So, now for that user, I am getting messages to www-data. I want them to go to the user, not to me or the system. How do I make that happen, please?
Reply With Quote
  #23  
Old 6th February 2008, 11:59
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

I have set up the subdomain. I have checked in /etc/postfix/local-host-names and in /etc/postfix/virtusertable and the subdomain and alias have been added correctly.

Can anybody here tell me why mail for that subdomain is now going to www-data and not to that subdomain? Is it a simple matter of waiting for DNS to propagate? Do I need to restart ISPConfig? Is there something else I must do?

I restarted Postfix immediately upon adding the subdomain in ISPConfig.
Reply With Quote
  #24  
Old 6th February 2008, 13:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

What's in your mail log when you send a mail to that subdomain?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #25  
Old 6th February 2008, 13:49
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

Last attempt produced in mail.log:
Code:
Feb  6 11:24:16 sww postfix/pickup[29369]: 6E7D9219C6: uid=33 from=<www-data>
Feb  6 11:24:16 sww postfix/cleanup[32590]: 6E7D9219C6: message-id=<20080206112416.6E7D9219C6@stopwatchweb.co.uk>
Feb  6 11:24:16 sww postfix/qmgr[15243]: 6E7D9219C6: from=<www-data@sww.stopwatchweb.co.uk>, size=562, nrcpt=1 (queue active)
Feb  6 11:24:16 sww postfix/cleanup[32590]: AEAB321983: message-id=<20080206112416.6E7D9219C6@stopwatchweb.co.uk>
Feb  6 11:24:16 sww postfix/local[32592]: 6E7D9219C6: to=<web26_chrisg@sww.stopwatchweb.co.uk>, orig_to=<formresponse@plainmortgageadvice.co.uk>, relay=local, delay=0.47, delays=0.31/0.1/0/0.07, dsn=2.0.0, status=sent (forwarded as AEAB321983)
Feb  6 11:24:16 sww postfix/qmgr[15243]: 6E7D9219C6: removed
Feb  6 11:24:16 sww postfix/qmgr[15243]: AEAB321983: from=<www-data@sww.stopwatchweb.co.uk>, size=711, nrcpt=1 (queue active)
Reply With Quote
  #26  
Old 7th February 2008, 11:45
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

Is this sufficient information? Is there anything else I can do to help you help me?
Reply With Quote
  #27  
Old 7th February 2008, 12:32
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,482
Thanks: 835
Thanked 5,524 Times in 4,345 Posts
Default

is the domain:

sww.stopwatchweb.co.uk

listed in /etc/postfix/local-host-names ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #28  
Old 8th February 2008, 02:19
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

Yes, it is, but below the line. Put there some months ago by a developer in solving an earlier problem.

I don't know if this helps, but sww.stopwatchweb.co.uk is not specifically named as a sub-domain in the name servers. As I mentioned earlier, it is the Tinydns system. The entry for palinmortgageadvice.co.uk has:
@plainmortgageadvice.co.uk::www.stopwatchweb.co.uk:10 and for stopwatchweb.co.uk:
@stopwatchweb.co.uk::sww.stopwatchweb.co.uk:10

I don't understand this, but thought it may possibly have some relevance.

Apologies for taking so long to reply. I looked on the site this afternoon several times, but this is the first time the post has appeared although your post has a time of 10.32 on it. My browser must be cacheing horribly.
Reply With Quote
  #29  
Old 8th February 2008, 11:57
chancer chancer is offline
Member
 
Join Date: Sep 2007
Posts: 88
Thanks: 6
Thanked 1 Time in 1 Post
Default

Just been looking through other domains set up in ISPConfig on that server. Most have www.domainname.tld in the Basis screen and domainname.tld in the Co-Domains screen. But plainmortgageadvice.co.uk has both in the Co-Domains - www. was already there when I made the suggested addition.

Is this a cause for concern?
Reply With Quote
  #30  
Old 8th February 2008, 18:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Remove the www from the Co-Domains.
So the problem now is that mails for formresponse@plainmortgageadvice.co.uk are going to web26_chrisg@sww.stopwatchweb.co.uk when they shouldn't?
Is web26_chrisg@sww.stopwatchweb.co.uk a Catch-All account?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
client 'can not send email' reinier Server Operation 1 17th April 2007 12:38
Can't retrieve email from client cambo Installation/Configuration 13 23rd November 2006 05:08
Email problem freeborn Installation/Configuration 5 19th August 2006 14:42
got a problem with a email account paulley Server Operation 7 9th July 2006 14:11
Receiving Email and Username Problem dstme General 20 16th November 2005 10:33


All times are GMT +2. The time now is 14:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.