Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 13th January 2006, 05:46
mantasman mantasman is offline
Junior Member
 
Join Date: Jan 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, i followed.
and i'm unable to use PuTTY as i'm under Gentoo
will try today again.
Reply With Quote
Sponsored Links
  #12  
Old 13th January 2006, 11:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
Originally Posted by mantasman
and i'm unable to use PuTTY as i'm under Gentoo
OK, a kde or gnome shell console and the ssh command will be fine too
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 13th January 2006, 19:46
mantasman mantasman is offline
Junior Member
 
Join Date: Jan 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i know this very well

i'm not new to linux. but i'm total newbie in web servers managing (at the moment, setuping only )

finally emails are working. but only partiately.

i cant login to email and ftp (proftpd) both. as i see from logs, there's something wrong with authd. and i still finished near-complete perfect setuping :/

i see this error in mail logs:
Code:
authdaemond: Connection to server 'pgsql.example.com' userid 'admin' database 'template1' failed.
i think i cant login into ftp because of the same reason.
how can i fix that? please dont sugggest to reinstall everything again..... :'(
Reply With Quote
  #14  
Old 13th January 2006, 22:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Have you tried to set up virtual hosting with Postfix on top of the Fedora Core 4 tutorial? This doesn't work with ISPConfig! You have to follow only the "Perfect Setup" for FC4 ( http://www.howtoforge.com/perfect_setup_fedora_core_4 ), and at the end it should work. Don't try to configure Postfix and Proftpd to use MySQL databases.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 13th January 2006, 22:52
mantasman mantasman is offline
Junior Member
 
Join Date: Jan 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no, no.
after i uninstalled ISPconfig (which was working near perfectly at that moment) i tried to reconfigure everything by "install VHCS2 on fedora core" howto, founded on vhcs.net.
after that, i removed all the packages, list in "Perfect Setup" (except courier-sasl & courier-sasl-devel) and runned trough the whole howto once more.

i disabled postgreSQL and MySQL modules of authdaemond and now i get just "LOGIN FAILED" error in /var/log/maillog
Reply With Quote
  #16  
Old 14th January 2006, 00:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Maybe you should consider a clean re-install?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 14th January 2006, 00:21
mantasman mantasman is offline
Junior Member
 
Join Date: Jan 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

apt-get threatens to remove gnome and many system-config-* applications if i remove cyrus-sasl :/

anyway, why do i need X11 if server is thousands miles away from me

if this 'd fail, is there any ways to restore fedora core 4 to it's original state without inserting cds etc?
Reply With Quote
  #18  
Old 14th January 2006, 02:16
mantasman mantasman is offline
Junior Member
 
Join Date: Jan 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

spent the whole night for removing packages and reinstalling them......
and nothing!!!!!!!!!

i still get same authdaemond error that it tries to connect to pgsql.example.com

and i cant connect to ftp too :'(

i even removed all the config directories related to postfix and reinstalled em but nothing :/
Reply With Quote
  #19  
Old 15th January 2006, 11:55
mantasman mantasman is offline
Junior Member
 
Join Date: Jan 2006
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i found that sasl seems to be not working. for example:
with saslpasswd i add username "me" and password "me". then write saslauthd1-checkpass -u me -p me and it gives me such error:
Code:
NO: -13 (authentication failure)
sasldblistusers says:
Code:
user: me realm: thehostman.net mech: DIGEST-MD5
user: me realm: thehostman.net mech: CRAM-MD5
user: me realm: thehostman.net mech: PLAIN
wtf is here?
Reply With Quote
  #20  
Old 15th January 2006, 12:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
 
Default

ISPConfig does not use the saslpasswd mechanism at all. ISPConfig uses system users and /etc/passwd and /etc/shadow as source for sasl authentication.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get mail after applying the update 2.1.2 mphayesuk Installation/Configuration 2 31st December 2008 14:48
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Mail being delivered to wrong user Sinisfun Installation/Configuration 19 14th May 2007 16:45
Mail server jas_esp Server Operation 1 7th December 2005 18:17
Can't get MX for external mail server to work semmelbroesel Installation/Configuration 4 25th November 2005 17:48


All times are GMT +2. The time now is 00:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.