Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 16th June 2008, 01:14
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

Hi Hans,
I tried to install suPHP using the post you provide + these two tutorials (site1, site2).

I am now getting the internal 500 error message. In the log files I get the following output:

Code:
SoftException in Application.cpp:296: UID of script "/var/www/web7/web/index.php" is smaller than min_uid
This is probably something very small I'm missing but cannot seem to find it. The other posts that I have read do help resolve my problem.

Thanks for any ideas.
Reply With Quote
Sponsored Links
  #12  
Old 16th June 2008, 06:50
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

Some additional info as I had time to play a bit more:

I am able to view php documents when I type in the full address (ie. www.mysite.com/index.php). This works for my webmail install, Joomla, etc. Now if I just typed in www.mysite.com expecting it to load I'm now asked to download the file (I'm in Firefox). Firefox calls it an application/x-httpd-php. I don't get anything in my suphp.log file as it doesn't process anything. Interesting to note however when I run Safari I don't have any issues in viewing the files.

To help figure this out (as I'm lost) my vhost data is:

Code:
<VirtualHost 192.1.1.1:80>
ServerName webmail.mysite.com:80
ServerAdmin webmaster@ mysite.com
DocumentRoot /var/www/web8/web
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web8/log/error.log  
AddType application/x-httpd-php .php .php3 .php4 .php5
suPHP_Engine on
suPHP_UserGroup web8_admin web8
AddHandler x-httpd-php .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-php
Alias /error/ "/var/www/web8/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html   
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web8/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web8/user/$1/web/$3
</VirtualHost>
I still get the 500 internal error when I load files too. These may or may not be related. All I'm trying to do is finish installing Joomla 1.5.

Thanks again for the help.
Reply With Quote
  #13  
Old 16th June 2008, 07:31
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Do you see any related errors within your /var/www/webX/log/ ?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #14  
Old 16th June 2008, 07:48
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

The error I have in /var/www/webX/log/ is:

Code:
[Sun Jun 15 21:52:17 2008] [error] [client 192.1.1.1] SoftException in Application.cpp:296: UID of script "/var/www/web7/web/gallery/index.php" is smaller than min_uid
[Sun Jun 15 21:52:17 2008] [error] [client 192.1.1.1] Premature end of script headers: index.php
This is the same error I have in suphp.log.
Reply With Quote
  #15  
Old 16th June 2008, 09:34
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

I think it has something to do with permissions.
What's the output of the command ls -la /var/www/web7/web ?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #16  
Old 17th June 2008, 03:34
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
Default

Hi Hans,
You were right the permissions were not set correctly. I ran chown and now the error 500 no longer occurs. However, Firefox is still trying to download any and all php files unless i directly type in the actual php file.

Also, is it possible to run Gallery2 (user/codebase) with suPHP? If so I'll start another topic on this as suPHP's log has the main.php launching but nothing happens (just blank site).
Reply With Quote
  #17  
Old 17th June 2008, 05:50
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

Running Gallery2 with the user-part within your /var/www/web7/web and the codebase within /var/www/ will not work with suPHP, because the codebase is outside the web of the user.

For such a situation, you can use php5mod. At the end of my suPHP howto, you can see how to to that.

If yo have a blank screen, please check your log file at /var/www/web7/log/ to find related errors.
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #18  
Old 19th June 2008, 02:58
bluethunder82 bluethunder82 is offline
Member
 
Join Date: Sep 2006
Posts: 92
Thanks: 0
Thanked 9 Times in 5 Posts
 
Default

Hi Hans,
Ok I figured as much about needing to use php5mod for Gallery2. I have changed this and now Gallery2 is working.

Everything is basically working now expect some browsers are still trying to download the php file instead of displaying it. For example if I have index.php in the root and I just type the base domain name it tries to download index.php instead of displaying it.

1) User Permissions are set to that of the user (using suPHP)
2) There are no logs generated in /var/log/apache2/error.log or in the local website error.log file

I'm having difficulty still with Joomla but I'll start another thread as I'm unable to install new templates.

Thanks again for you help.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
Chroot SSH + ISPConfig Norman Installation/Configuration 27 26th March 2007 03:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
HotSaNIC domino Tips/Tricks/Mods 23 6th November 2006 05:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 02:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.