#1  
Old 31st January 2008, 00:56
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 79
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default Mailserver different server

Hi all, im little bit confused, i try solve problem with some of my domains i try slowly explain problem.

I have website for domainX on server1 and mailserver for this domain is exchange on server2

mailusers on server1.* try to send mail to domainX and there is problem
When try this another users from server3.* all is ok transport work as i want.

I search this forum for relative topics, i have set on all subdomains and domainX mailserver to external.
MX Checkbox in site is unchecked i try add mx record in dns manager server1 points to my server2 ip but when i send mail using webmail from server1.domainY addresed to user.domainX mail returns with this debug message

Action: failed
Status: 5.4.6
Diagnostic-Code: X-Postfix; mail for server1.domainX loops back to myself


Any idea how to set this correctly?
Reply With Quote
Sponsored Links
  #2  
Old 31st January 2008, 20:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please add server1.domainX at the end of /etc/postfix/local-host-names and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 31st January 2008, 21:08
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 79
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default

Thank you for reply,
When i do what you say, mailserver try deliver mail from server1 users localy, not to server2... i send mail from ssh as root to admin@server2 and this is delivered to local webadministration account for domain.
:-/

Last edited by madmucho; 31st January 2008 at 22:33.
Reply With Quote
  #4  
Old 31st January 2008, 22:28
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 79
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default heh

Maibe i find something that will help, i change ip in DNS Entry where Domain (SOA) hostname and ipaddress is to correct ip, when i have mx record mail.
4dprojekt.cz point to A record mail.4dprojekt.cz and this point to correct ip, telnet mail.4dprojekt.cz 25 point to exchange, but telnet 4dprojekt.cz 25 poing to local postfix, and that was problem, i change ip on this screen and now telnet to 25 port point to correct ip.
Reply With Quote
  #5  
Old 1st February 2008, 09:18
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

Please make sure that you set the website and co-domain in ispconfig to external mailserver.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 1st February 2008, 09:23
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 79
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default

Main site and all co-domains for this site is defined in listbox as external.
Reply With Quote
  #7  
Old 2nd February 2008, 18:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

So you want to deliver emails for the server's main domain to an external server? You can do this with transports. Take a look at
Code:
man 5 transport
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 2nd February 2008, 20:10
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 79
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
 
Default

Aha, that looks what i looking for. I try this on testing domain.

But now whit changed DNS that work perfectly.

But i dont understand why server want deliver mail localy, why dont use dns information from other dns servers.
For this site i have not specified mx record, MX reccord is specified at domain master, and that point to correct location.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Public and private network + High Availability Apache Cluster teleted HOWTO-Related Questions 11 28th January 2008 14:29
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 22:53
How set DNS entry for different server? SupuS Installation/Configuration 1 12th June 2006 09:48
server blocked/stopped by host Ovidiu Technical 11 14th February 2006 10:50


All times are GMT +2. The time now is 19:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.