Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st January 2008, 18:29
mfdeck mfdeck is offline
Junior Member
 
Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix "Connection timed out" error when trying to send

Have postfix running on Fedora 8 with ISPConfig... able to receive mail, but, not send it out. Can send locally, however. When trying to send externally I get "Connection timed out (port 25)" error in the log. I haven't been able to find much about this error anywhere... any ideas?

Also, when trying to send from Outlook mail client, I get a 554 5.7.1: Relay access denied... when sending from local webmail client, it says it sends fine, but, it gets deferred after a "Connection timed out" error in the log.

main.cf file is setup exactly like the "Perfect Server" setup for Fedora 8 & local-host-names are correct.

thanks!
Reply With Quote
Sponsored Links
  #2  
Old 31st January 2008, 18:50
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Quote:
Originally Posted by mfdeck
Have postfix running on Fedora 8 with ISPConfig... able to receive mail, but, not send it out. Can send locally, however. When trying to send externally I get "Connection timed out (port 25)" error in the log. I haven't been able to find much about this error anywhere... any ideas?

Also, when trying to send from Outlook mail client, I get a 554 5.7.1: Relay access denied... when sending from local webmail client, it says it sends fine, but, it gets deferred after a "Connection timed out" error in the log.

main.cf file is setup exactly like the "Perfect Server" setup for Fedora 8 & local-host-names are correct.

thanks!
First you are getting relaying denied because your network is not in "mynetworks" as for outbound email it seems like you cannot make connections outside to port 25. Test that you can connect to mail servers on the internet using this command
Code:
telnet a.mx.mail.yahoo.com 25
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 31st January 2008, 19:04
mfdeck mfdeck is offline
Junior Member
 
Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

No such luck... I am on a godaddy dedicated server... and from what I'm reading, they require a relayhost, which I believe is smtp.secureserver.net, but, this doesn't help, either.

Code:
Trying 209.191.118.103...
telnet: connect to address 209.191.118.103: Connection timed out
Thanks!
Reply With Quote
  #4  
Old 31st January 2008, 19:32
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Quote:
Originally Posted by mfdeck
No such luck... I am on a godaddy dedicated server... and from what I'm reading, they require a relayhost, which I believe is smtp.secureserver.net, but, this doesn't help, either.

Code:
Trying 209.191.118.103...
telnet: connect to address 209.191.118.103: Connection timed out
Thanks!
Then you need to setup postfix to use that as a smarthost
Code:
relayhost =  smtp.secureserver.net
but just test with telnet as well and see if you can connect to it on port 25 if not then your data center is blocking port 25 speak to them.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 31st January 2008, 20:07
mfdeck mfdeck is offline
Junior Member
 
Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

some success...

GoDaddy's relay server is k2smtpout.secureserver.net so, I set...

Code:
relayhost = k2smtpout.secureserver.net
am able to connect to this host with telnet then restarted postfix and now it does have some capacity to send, although quite slow, but at least its sending...

but, I am still getting this error... I think it has to do with mynetworks setting:

Code:
NOQUEUE: reject: RCPT from...: 554 5.7.1: Relay access denied.
my local IPs are 10.0.0.1-255 and I have mynetworks set to:

Code:
mynetworks = 127.0.0.0/8, 10.0.0.0/8

Last edited by mfdeck; 31st January 2008 at 20:13.
Reply With Quote
  #6  
Old 31st January 2008, 20:12
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

If the server is is at godaddys where is the 10.0.0.0/8 network ? Because your server at godaddy will not see your connection as coming from that range as it is not routable and will reject it

Have you tried sending the mail from the server itself ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #7  
Old 1st February 2008, 02:34
mfdeck mfdeck is offline
Junior Member
 
Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the local IPs on my server are 10.0.0.1, 10.0.0.2 and 10.0.0.3 on eth0

My public IPs are received by a hardware firewall then forwarded to the server on the above IPs. I'm not sure if 10.0.0.0/8 is the right configuration or not. If not, any idea what I need to put here?

Mail can be sent directly from the server to external email addresses and also using the webmail app, just not from an external mail client.
Reply With Quote
  #8  
Old 1st February 2008, 07:56
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

So are you getting relay denied when you are at home or else where ?

If so then just use smtp authentication and you will be able to relay.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #9  
Old 1st February 2008, 19:02
mfdeck mfdeck is offline
Junior Member
 
Join Date: Jan 2008
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I've had that set the whole time... still the same problem... tried it from different mail clients and from different connections...
Reply With Quote
  #10  
Old 1st February 2008, 19:35
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
 
Default

Quote:
Originally Posted by mfdeck
I've had that set the whole time... still the same problem... tried it from different mail clients and from different connections...
Are you being prompted for a password ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix - status=deferred; Connection timed out qwertybrg Server Operation 12 6th February 2009 19:02
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Postfix log messages - Connection timed out nibbles Server Operation 1 3rd March 2006 09:42


All times are GMT +2. The time now is 00:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.