Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st January 2008, 19:43
AlyK AlyK is offline
Junior Member
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Debian - Apache Cluster with Squirrelmail Help..

I recent followed the Debian (haproxy) HA cluster with Fail over and sessions support.. I am trying to get squirrelmail working over the cluster. The source is being read be either web server from a single NFS share on the mail server. each web server has a squirrelmail configuration (that points to the mail server) file and i am able to properly access and get to the login page, but once i supply my credentials and i attempt to login and the load balancer switches me to the other web server and it doesn't carry my session and gives me an error as expected stating "You must login to view this page". Also if i fail one web server, as expect again it works just fine.

Can anyone advise on a solution? or point me in the right direction. Also if I am not addressing the correct issue any help would be appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2008, 13:53
athlon_crazy athlon_crazy is offline
Junior Member
 
Join Date: Feb 2008
Location: Malaysia
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Yahoo to athlon_crazy
Default

Perhaps because your cluster file system is not cluster aware. Even it's point you to d other web server, you should get the session from the previous web server as well. Did you try doing it with drbd?
__________________
www.no-x.org
Reply With Quote
  #3  
Old 1st February 2008, 15:26
AlyK AlyK is offline
Junior Member
 
Join Date: Jan 2008
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

No i have not tried that, but that is a good thought.
I will try that and let you know. Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Public and private network + High Availability Apache Cluster teleted HOWTO-Related Questions 11 28th January 2008 14:29
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57
Loadbalanced Apache Cluster Help brianwebb01 Installation/Configuration 2 18th October 2006 17:01
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 00:45
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 14:42


All times are GMT +2. The time now is 15:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.