Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th January 2006, 12:35
sirmee2001 sirmee2001 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default mailuser access

I am having problems accessing mailuser from outside my network. Everything works OK within my LAN. When I connect to www.myweb.com:81/mailuser I see a connection being made to my local (internal) address and then the connection times out. Where should I change the IP address in order to get rid of this problem. Help!
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2006, 12:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Have you forwarded port 81 from your router to your server? is www.myweb.com an officially registered domain that points to your external IP adress?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 10th January 2006, 14:49
sirmee2001 sirmee2001 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks. I think I forwarded port 81. I will check when I get home.
Reply With Quote
  #4  
Old 10th January 2006, 20:14
sirmee2001 sirmee2001 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Port 81 is forwarded. Everything works including webmail. The only problem is access to the mailuser login page where users can change their passwords.
Reply With Quote
  #5  
Old 10th January 2006, 20:17
sirmee2001 sirmee2001 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My registered domain is igorg.hopto.org
Reply With Quote
  #6  
Old 10th January 2006, 22:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

If the domain igorg.hopto.org points to your external IP of your router and you forwarded port 81 to your internal server IP, you should be able to login. If this does not work, ask your ISP if port 81 is blocked.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 10th January 2006, 23:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

When I try to access http://igorg.hopto.org:81/mailuser the browser tells me that it tries to load something from 192.168.2.114 which cannot work because this is a local IP address from your network.

I guess you have 192.168.2.114 in /home/admispconfig/ispconfig/lib/config.inc.php. Try to replace it with igorg.hopto.org.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 10th January 2006, 23:56
sirmee2001 sirmee2001 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for your replies. I don't have that local address (192.168.2.114) anywhere in the file config.inc.php. The only place that I know of where I do have that IP is in "Server settings" where I also have the domain "igorg.hopto.org".
Reply With Quote
  #9  
Old 11th January 2006, 00:01
sirmee2001 sirmee2001 is offline
Junior Member
 
Join Date: Dec 2005
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Port 81 is not blocked because I am able to log in to my email accounts and check mail. The only problem is logging in to mailuser to change user passwords. I would like my users to be able to change their passwords. Besides that I am really happy with the whole set up thanks to all those who helped prepare the "perfect setup - Debian Sarge 3.1.".
Reply With Quote
  #10  
Old 11th January 2006, 00:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

I know that port 81 isn't blocked because I can access the ISPConfg login page.

Can you post your /home/admispconfig/ispconfig/lib/config.inc.php here? Please make sure to remove your MySQL details when you post it here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISP install problems Debian sarge 3.1 lerra Installation/Configuration 1 5th January 2006 17:37
Everything is working except Access denied page SeaWolf Installation/Configuration 2 10th December 2005 16:16
FTP access with Dreamweaver / FTPclient pjm2211 Installation/Configuration 17 2nd November 2005 00:31
FTP access problem... ctroyp General 7 12th October 2005 18:07
FTP access? ctroyp Installation/Configuration 14 29th September 2005 18:26


All times are GMT +2. The time now is 23:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.