#1  
Old 10th January 2006, 08:31
langer langer is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default BIND & Postfix refuse to start

Hi there. I cannot get BIND & Postfix to start after following the suse 10.0 setup. I find the instructions a little grey when it comes to the hostname/domain side of things...

I am a linux newbie, and so am quite certain that the hostname/domain config etc are foobar.

My linux box is part of a small network of 2-3 computers total, with my router acting as DHCP server. The SUSE server has a fixed IP on the subnet. There is no domain, and I would prefer to keep it this way unless it is required.

I want to be able to use it as a development server (in adition to it being my SAMBA server), and thought ISPConfig would be the way to go, but need help with configuring the DNS sides of things I think.

Can anyone please suggest the config required on the server, and with ISPConfig, to achieve my simple needs?

Thank you.

Nicholas
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2006, 08:51
langer langer is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OK. I got the pop3 service to start by setting runlevels manually and starting. Now for the DNS issues...
Reply With Quote
  #3  
Old 10th January 2006, 08:56
langer langer is offline
Junior Member
 
Join Date: Jan 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

here is teh error I'm getting:
Code:
Starting name server BIND /etc/named.d/forwarders.conf:7: '{' expected near ';'
..skipped
The file reads:
Code:
# Copyright (c) 2001-2004 SuSE Linux AG, Nuernberg, Germany.
# All rights reserved.
# Forwarders file for PPPD updates (only)
#
# /etc/named.d/forwarders.conf

forwarders ;
How should this be configured??
Reply With Quote
  #4  
Old 10th January 2006, 13:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

Quote:
Originally Posted by langer
here is teh error I'm getting:
Code:
Starting name server BIND /etc/named.d/forwarders.conf:7: '{' expected near ';'
..skipped
The file reads:
Code:
# Copyright (c) 2001-2004 SuSE Linux AG, Nuernberg, Germany.
# All rights reserved.
# Forwarders file for PPPD updates (only)
#
# /etc/named.d/forwarders.conf

forwarders ;
How should this be configured??
It should be something like this:

Code:
# The forwarders record contains a list of servers to
# which queries should be forwarded. Enable this line and
# modify the IP-address to your provider's name server.
# Up to three servers may be listed.
forwarders { 194.25.2.129; };
However, if you don't need it, comment it out:

Code:
#forwarders { 194.25.2.129; };
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix starts and stops why lhatle Installation/Configuration 2 21st December 2005 16:20
please help: postfix design and configuration jaguar Installation/Configuration 1 9th December 2005 12:46
postfix problem flourishing General 1 7th December 2005 18:39
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 15:42
Removed PostFix, Now MySql Problems!!! sapient Installation/Configuration 10 24th October 2005 08:11


All times are GMT +2. The time now is 01:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.