Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th December 2007, 19:48
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache / httpd restart / startup failed without errors

I don't want you bother with my problems so I searched for 2 hours over the web for a solution for what I'm experiencing now. My apache is broken, but throws no errors. That makes it impossible to resolve it for me. The only thing error_log states:

[Thu Dec 27 19:15:08 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Dec 27 19:15:23 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Dec 27 19:16:45 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Dec 27 19:19:13 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)

(SElinux is disabled as far as I know)

My apache was working well, till I needed to start ISP config again. That broke my server in some kind of way (really vague), httpd stopped. The server has been restarted, but that also restarted the ISP config server. The httpd server still didnt want to start (all other services do).

I uninstalled httpd and its dependencies and reinstalled them (using yum), using the new configs to test. No luck, still stopping w/o an error. There are no problems with modules as far as I can see. The error_log stays empty, debug level startup says nothing special, only messages log file says startup failed... (Dec 27 18:45:36 aerotronicvds httpd: httpd shutdown failed
Dec 27 18:52:10 aerotronicvds httpd: httpd startup failed)

The only value information for debugging this might be:
https://aerotronic.nl:81/stracehttpd.txt

I disabled the certificates by commenting those lines, it otherwise stopped at localhost.key or my website's certificate...

Thanks so much in advance for pointing me further!

I'm using CentOS 4.4, according to the perfect setup of this site.
Reply With Quote
Sponsored Links
  #2  
Old 27th December 2007, 20:04
chipsafts chipsafts is offline
Senior Member
 
Join Date: Nov 2007
Posts: 184
Thanks: 2
Thanked 6 Times in 6 Posts
Default

I'd give WebMin a shot at helping you debug the issue.
Reply With Quote
  #3  
Old 27th December 2007, 20:38
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for your reply, I directly liked Webmin better :-)

Anyways, it (of course) doesn't solve the problem httpd is having. Webmin can also not start apache.

I'll now disable ISPconfig, and ask to reboot the server.
Reply With Quote
  #4  
Old 27th December 2007, 21:24
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry for the double post. I rebooted the system w/o ISP config. Still no luck, httpd doesn't want to start...

After this part httpd didn't want to get alive anymore. So after the restart of named.

Dec 27 16:37:40 aerotronicvds httpd: httpd shutdown succeeded
Dec 27 16:37:40 aerotronicvds httpd: httpd startup succeeded
Dec 27 16:37:40 aerotronicvds named[19079]: shutting down: flushing changes
Dec 27 16:37:40 aerotronicvds named[19079]: stopping command channel on 127.0.0.1#953
Dec 27 16:37:40 aerotronicvds named[19079]: stopping command channel on ::1#953
Dec 27 16:37:40 aerotronicvds named[19079]: no longer listening on 127.0.0.1#53
Dec 27 16:37:40 aerotronicvds named[19079]: no longer listening on 87.249.105.146#53
Dec 27 16:37:40 aerotronicvds named[19079]: no longer listening on 87.249.105.147#53
Dec 27 16:37:40 aerotronicvds named[19079]: exiting
Dec 27 16:37:40 aerotronicvds named: succeeded
Dec 27 16:37:42 aerotronicvds named[19990]: starting BIND 9.2.4 -u named -t /var/named/chroot
Dec 27 16:37:42 aerotronicvds named[19990]: using 1 CPU
Dec 27 16:37:42 aerotronicvds named[19990]: loading configuration from '/etc/named.conf'
Dec 27 16:37:42 aerotronicvds named[19990]: listening on IPv4 interface lo, 127.0.0.1#53
Dec 27 16:37:42 aerotronicvds named[19990]: listening on IPv4 interface eth0, 87.249.105.146#53
Dec 27 16:37:42 aerotronicvds named[19990]: listening on IPv4 interface eth0:0, 87.249.105.147#53
Dec 27 16:37:42 aerotronicvds named[19990]: command channel listening on 127.0.0.1#953
Dec 27 16:37:42 aerotronicvds named[19990]: command channel listening on ::1#953
Dec 27 16:37:42 aerotronicvds named[19990]: zone 0.0.127.in-addr.arpa/IN: loaded serial 1
Dec 27 16:37:42 aerotronicvds named[19990]: zone 105.249.87.in-addr.arpa/IN: loaded serial 2007111101
Dec 27 16:37:43 aerotronicvds named[19990]: zone aerotronic.nl/IN: loaded serial 2007122701
Dec 27 16:37:43 aerotronicvds named[19990]: running
Dec 27 16:37:43 aerotronicvds named: named startup succeeded
Dec 27 16:39:08 aerotronicvds httpd: httpd shutdown succeeded
Dec 27 16:39:08 aerotronicvds httpd: httpd startup failed
Dec 27 16:39:08 aerotronicvds httpd: httpd shutdown failed
Dec 27 16:39:08 aerotronicvds httpd: httpd startup failed

Last edited by Aldert; 27th December 2007 at 21:50.
Reply With Quote
  #5  
Old 28th December 2007, 18:09
chipsafts chipsafts is offline
Senior Member
 
Join Date: Nov 2007
Posts: 184
Thanks: 2
Thanked 6 Times in 6 Posts
Default

There isn't a directory called httpd
in your log directory?
Try 'locate access_log' , in the same directory should be error_log .
Reply With Quote
  #6  
Old 28th December 2007, 21:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

What's the output of
Code:
netstat -tap
,
Code:
httpd -t
, and
Code:
df -h
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 30th December 2007, 12:09
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

There should have been no problem with the logs. Or the would have been deleted by restarting ISP config server.

I have removed httpd and dependencies, rebooted server, installed httpd etc. again and rebooted the server, still httpd did not want to start. So I removed httpd again.

I then compiled apache by hand, instead of using yum. It was installed into /usr/lib/httpd. Now I installed httpd via yum again. A miracle must have hapened, I could start httpd again. It might be caused by compiling apache manually... But now two apache's are configured, while yum install httpd overrode some of the manual install I think. To restore the old situation, I would have to decompile apache, then yum install httpd again. I wonder if it still would have problems, but I'm not going to investigate such.

There was enough disk space, about 500 M available. Also the syntaxis of the configs was OK.

Thanks for all help, I decided to start a new server with chooted lighttpd this time :-) (it just looks like I'm searching for trouble ;-))

In any case I now use webmin instead of ISP Config, webmin is more convenient imho.
Reply With Quote
  #8  
Old 30th December 2007, 12:11
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
Default

There should have been no problem with the logs. Or the would have been deleted by restarting ISP config server.

I have removed httpd and dependencies, rebooted server, installed httpd etc. again and rebooted the server, still httpd did not want to start. So I removed httpd again.

I then compiled apache by hand, instead of using yum. It was installed into /usr/lib/httpd. Now I installed httpd via yum again. A miracle must have hapened, I could start httpd again. It might be caused by compiling apache manually... But now two apache's are configured, while yum install httpd overrode some of the manual install I think. To restore the old situation, I would have to decompile apache, then yum install httpd again. I wonder if it still would have problems, but I'm not going to investigate such.

There was enough disk space, about 500 M available. Also the syntaxis of the configs was OK.

Thanks for all help, I decided to start a new server with chooted lighttpd this time :-) (it just looks like I'm searching for trouble ;-))

In any case I now use webmin instead of ISP Config, webmin is more convenient imho.

P.S. @ forum admin, you really should look at the problem when being logged out while writing a reply, I have to log in again, but then it says invalid thread specified. Fortunately FireFox had the text saved.
Reply With Quote
  #9  
Old 31st December 2007, 18:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by Aldert
P.S. @ forum admin, you really should look at the problem when being logged out while writing a reply, I have to log in again, but then it says invalid thread specified. Fortunately FireFox had the text saved.
You don't have such problems if you check the "Remember me" box when you log in.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 3rd January 2008, 23:07
Aldert Aldert is offline
Junior Member
 
Join Date: Jul 2007
Posts: 20
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Thanks.

Ok, I finally know what the problem was. I did yum install mod_ssl for testing purposes on the old server. Again httpd was not able to start again!

Also I have to say to that people that also consider lighttpd: be sure you will be able to configure it, mod_expires is less configureable and sadly enough the errordocument handling is very bad. But we also have the advantages of chroot and other configuration options :-)

Anyways. If you encounter problems with your apache (without errors), first try to disable the modules one by one and see if it comes up ;-)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17
MaxClients set to appropriate level, but ISPconfig is crashing from it (I think) bpmee Server Operation 6 11th January 2007 19:29
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
How to install BFD (Brute Force Detection) domino Tips/Tricks/Mods 9 31st March 2006 22:40


All times are GMT +2. The time now is 06:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.