Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd January 2008, 15:46
Intraweb Intraweb is offline
Junior Member
 
Join Date: Aug 2007
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
Default Apache2 on a Multiuser-System

I have the following problem:

I have 3 webadmins (non-root) on a Debian-System with Apache2 and PHP5.
So I've created the group "web" with these 3 users in it.

I changed the group of /var/www to "web" and set the "setgid" bit, so that all new files and directories have the "web"-group.

So far so good.

The problem now is, that every new file has the right group, but the wrong permissions. The group members are only allowed to read, but not to write.

Is there another way than change the umask of every user (and apache!), i.e. set the umask just for that specific directory? ex. setfacl?

I hope I am not barking on the wrong tree here.
If there is better way than umask fell free to write.

Thanks in Advance
Intra

Last edited by Intraweb; 23rd January 2008 at 16:18.
Reply With Quote
Sponsored Links
  #2  
Old 23rd January 2008, 17:07
Intraweb Intraweb is offline
Junior Member
 
Join Date: Aug 2007
Posts: 21
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

We are trying now to solve the Problem with setfacl.

aptitude install acl
then you need to mount the partition with acl support.

Complicated but it seems to be the only solution :-|
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
ispconfig on a system with a desktop koekbr General 31 18th December 2007 17:25
Network problem moving system disk from development system to production system Brian Donahue Installation/Configuration 2 30th November 2007 16:28
Installing Debian Etch From a Windows System - Error bluegrass Installation/Configuration 2 24th October 2007 07:28
ISPConfig takes forever to load b00gz Installation/Configuration 5 12th April 2007 22:00


All times are GMT +2. The time now is 15:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.