#1  
Old 10th January 2006, 15:08
doddel doddel is offline
Junior Member
 
Join Date: Dec 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default ftpusers / proftp

Configuration: ISPConfig on virtual private server with Fedora core 2.
Problem: after populating ISPConfig with clients, sites, and mailusers and a manual creation of /etc/virtuser.db (fails to be done automatically) the websites and mail work fine.
But FTP, although enabled in the user menus, doesn't function. Had a look at /etc/proftpd.conf which allows FTP for users that belong to the 'ftpusers' group.
In /etc/groups the group ftpuser exists but it is not populated. All mailusers feature in the 'users' group.
Have i forgotten a setting somewhere ? Searched in /root/ispconfig for the string 'ftpusers' but none of the php scripts seem to contain this word. How is this group supposed to get populated ? Should proftpd allow the 'users' group instead ? But ftpusers are a subgroup of users I guess.

rgds
martin
Reply With Quote
Sponsored Links
  #2  
Old 10th January 2006, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Although this thread is for Fedora 4, it might help you:
http://www.howtoforge.com/forums/showthread.php?t=196 and especially http://www.howtoforge.com/forums/sho...7&postcount=11
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th January 2006, 23:16
doddel doddel is offline
Junior Member
 
Join Date: Dec 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dear Falko,

thanks for the suggestion but it did not work.
Although I have no clue why, got it to work with following three steps of measures and editing:
1) created a //etc/ftpuser populated with list
root
bin
daemon
adm
lp
sync
shutdown
halt
mail
news
uucp
operator
games
nobody

(copied this from my previous virtual server with Fedora; perhaps not necessary)

2) added in //etc/group after ftpusers:x:501: the web{n}_username list of site administrators

3) changed in passwd for these users the shell from /dev/null into /bin/false

Then FTP works ..... ??????
Reply With Quote
  #4  
Old 11th January 2006, 00:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by doddel
3) changed in passwd for these users the shell from /dev/null into /bin/false
Have you checked the FTP checkbox in ISPConfig for the web site of the users in question? Because then their shell shouldn't be /dev/null...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th January 2006, 15:09
doddel doddel is offline
Junior Member
 
Join Date: Dec 2005
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Dear Falko,

there is no FTP checkbox entry under 'User&Email', or under individual users in the list of users. The checkbox at the site level is checked for FTP access, and unchecked for anonymous access. So I am really puzzled how this is supposed to work.
Any user with a web_user site should have FTP access to that site. The user with admin rights should have ftp to all web_user sites.
The client should have ftp access to web site + all web_user sites.

Now looking at passwd, group, ftpusers, and virtusertable, what should show where ?

rgds
Reply With Quote
  #6  
Old 11th January 2006, 15:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by doddel
Dear Falko,

there is no FTP checkbox entry under 'User&Email', or under individual users in the list of users. The checkbox at the site level is checked for FTP access, and unchecked for anonymous access. So I am really puzzled how this is supposed to work.
That's the checkbox I meant (on the "Basis" tab).
If this one is checked, then all the users of the web site (under "User & Email") should have a shell different from /dev/null which means they can login using FTP.
If your users have /dev/null as shell, then something went wrong. You can have a look at the ISPConfig log /home/admispconfig/ispconfig/ispconfig.log.

Quote:
Originally Posted by doddel
The client should have ftp access to web site + all web_user sites.
A client cannot login because a client is something that exists only in ISPConfig, i.e., a client is no real system user. He can only login to ISPConfig!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ProFTP Problem mrjeff Installation/Configuration 6 29th December 2005 23:51


All times are GMT +2. The time now is 14:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.