#21  
Old 15th September 2005, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Can you open a new thread for that problem? Otherwise the current thread would handle two completely different problems. Thanks!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #22  
Old 29th December 2005, 07:32
tmerrill tmerrill is offline
Junior Member
 
Join Date: Dec 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default I still can't login

I have followed the Fedora Core 4 setup. I am just trying to ftp using root / "my root password". I have created the /etc/pam.d/ftp file and I am still having no luck. What am I missing. Firewall and everything seems to be ok. My machine is listening for ftp. Please help I have looked everywhere for an answer.
Reply With Quote
  #23  
Old 29th December 2005, 09:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,457
Thanks: 813
Thanked 5,230 Times in 4,099 Posts
Default

Root login with FTP is forbidden in FC4 because the FTP protocol transfers password in clear text. Use an SCP client like WinSCP for windows instead.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #24  
Old 23rd February 2006, 10:38
asiatype asiatype is offline
Junior Member
 
Join Date: Feb 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi all ... pls someone help me . I install proftpd in FC4 box. proftpd works i think because i can log in with the user i created 'useradd -g <group> -d </home/directory> <new user> '. The problem is i cant create a directoy and it says '550 <user>permission denied' thnx :d
Reply With Quote
  #25  
Old 23rd February 2006, 16:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

In which directory is the user when he logs in using FTP?
Please post your /etc/proftpd.conf here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #26  
Old 23rd February 2006, 20:21
pine pine is offline
Junior Member
 
Join Date: Feb 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by nsworld
I too have a problem with remote ftp access from users.
using Fedora 4, I create the domain activate ftp and then add users.
I can use the browser ftp ( https://192.168.55.4:81/index.php?s=ae....etc ) but not cuteftp with the same credentials.

any ideas , ftp server is running according to the services menu
I've have the same problem with a mahine running under FC 4 installed in the standard fashion (not the Perfect Setup). I can, however, test the access to my ftp server successfully through the Netmonitor site (http://www.netmonitor.org/). I can't see any directory or file myself so I don't know how good the connection was.

It appears that I can connect to my server only through the local IP, not external IP or the external host name. Can someone test my theory by connecting to my server (ftp.yoons.org) with a login name of "tester, 1234abcd"? Please let me know what happend?
Reply With Quote
  #27  
Old 23rd February 2006, 22:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by pine
pears that I can connect to my server only through the local IP, not external IP or the external host name. Can someone test my theory by connecting to my server (ftp.yoons.org) with a login name of "tester, 1234abcd"? Please let me know what happend?
It's working for me, I could log in. Maybe it'S a firewall issue with your client PC.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #28  
Old 24th February 2006, 13:12
pine pine is offline
Junior Member
 
Join Date: Feb 2006
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
It's working for me, I could log in. Maybe it'S a firewall issue with your client PC.
You were able to log in and gain access to the files, were you not? I get the same problem with a client running under FC 4 and WindowsXP. The firewall built into the DSL router may cause my problem.

Thank you.
Reply With Quote
  #29  
Old 24th February 2006, 15:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by pine
You were able to log in and gain access to the files, were you not?
Yes, I could log in and see all files.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #30  
Old 5th March 2006, 23:03
brainz brainz is offline
Senior Member
 
Join Date: Feb 2006
Location: Sydney, Australia
Posts: 165
Thanks: 9
Thanked 3 Times in 1 Post
 
Default

Hi all

Im still having the same problem with proftp and its PAM authentication

here is the log file
Quote:
Mar 5 23:30:28 name proftpd[26144]: name.server.com (127.0.0.1[127.0.0.1]) - PAM(web1_name): Authentication failure.
Mar 5 23:30:28 ramjet proftpd[26144]: name.server.com (127.0.0.1[127.0.0.1]) - FTP session closed.
Mar 5 23:30:28 ramjet proftpd[26154]: name.server.com (127.0.0.1[127.0.0.1]) - FTP session opened.
Mar 5 23:30:28 name proftpd(pam_unix)[26154]: authentication failure; logname= uid=0 euid=0 tty= ruser= rhost=127.0.0.1 user=web1_name
Mar 5 23:30:31 name proftpd[26154]: name.server.com (127.0.0.1[127.0.0.1]) - PAM(web1_name): Authentication failure.
Mar 5 23:30:31 name proftpd[26154]: name.server.com (127.0.0.1[127.0.0.1]) - FTP session closed.
Mar 5 23:30:39 name proftpd[26159]: 192.168.*.* (*.*.*.*[*.*.*.*]) - FTP session opened.
Mar 5 23:30:39 name ftp(pam_unix)[26159]: session opened for user web1_name by (uid=0)
Mar 5 23:35:42 name proftpd[26159]: 192.168.*.* (*.*.*.*[*.*.*.*]) - FTP no transfer timeout, disconnected
Mar 5 23:35:42 name proftpd[26159]: 192.168.*.* (*.*.*.*[*.*.*.*]) - PAM(setcred): System error
Mar 5 23:35:42 name proftpd[26159]: 192.168.*.* (*.*.*.*[*.*.*.*]) - PAM(close_session): System error
Mar 5 23:35:42 name proftpd[26159]: 192.168.*.* (*.*.*.*[*.*.*.*]) - FTP session closed.
Im wondering if you guys can help with this.....

I have also included a FTP in the /etc/pam.d/ftp with the following in it...

Quote:
#%PAM-1.0
auth required pam_unix.so nullok
account required pam_unix.so
session required pam_unix.so
and it still has no effect at all i can login with a client i use smartftp but it doesnt let me login from the web ftp and the account has anonymous and ftp login rights activated.

Any help wpuld be apreciated...

Regards
brainz
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 21:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.