Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 23rd August 2008, 15:46
sangamc sangamc is offline
Junior Member
 
Join Date: Jun 2008
Posts: 11
Thanks: 0
Thanked 2 Times in 2 Posts
Default

i clicked on your link to the howto, but the page couldnot be found. any ways it looks like you are missing the samba admin account in your ldap directory. if you post a new link then i can look at the how to and see where you may have missed something
Reply With Quote
Sponsored Links
  #22  
Old 24th August 2008, 09:38
mperreault mperreault is offline
Junior Member
 
Join Date: Dec 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
Smile OpenLDAP + Samba Domain on Ubuntu 7.10 (Version 2)

I found version 2 of this same tutorial over on ubuntu forums... It seems to have solved the majority of my problems!

http://ubuntuforums.org/showthread.php?t=640760

it is also available on the authors personal site

http://www.rrcomputerconsulting.com/...p?article_id=3

Thanks Ricky!
Reply With Quote
  #23  
Old 24th August 2008, 12:15
mperreault mperreault is offline
Junior Member
 
Join Date: Dec 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
Default

When I log onto the XP machine I ALWAYS get 2 errors with regards to roaming profiles... The XP machine then creates a new temporary profile each time the user logs in. Which is slow...

Error Message 1
Quote:
Windows cannot locate the server copy of your roaming profile and is attempting to log you on with your local profile. Changes to the profile will not be copied to the server when you logoff. Possible causes of this error include network problems or insufficient security rights. If this problem persists, contact your network administrator.

DETAIL - The network name cannot be found.
The part about the network name cannot be found is concerning... So I pinged dc01-ubuntu and it worked however when I ping dc01-ubuntu.example.local it doesn't work...

Error Message 2
Quote:
Windows cannot find the local profile and is logging you on with a temporary profile. Changes you make to this profile will be lost when you log off.
The allusers.bat script seems to run however I had to change any instances of \\dc01-ubuntu.example.local to \\dc01-ubuntu.

I don't want roaming profiles, but I also don't want error messages each time I log in. And I need those scripts to run.. Any suggestions?

I'm following this updated tutorial..
http://ubuntuforums.org/showthread.php?t=640760

Here is a link to the Virtual Machine I've created to try to get this working.. You might have to change the static IP address etc to make this work for you? Let me know if you've solved my problem and how. I created this using VMWare Fusion for Mac but I assume it should run in the VMWare player for any other OS..
http://webcitr.us/ubuntu7.10_SAMBA_OPENLDAP.rar
Attached Images
  

Last edited by mperreault; 24th August 2008 at 14:37.
Reply With Quote
  #24  
Old 25th August 2008, 23:05
mperreault mperreault is offline
Junior Member
 
Join Date: Dec 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
Default

I've solved the problem! In the samba.conf file i had

"login path =" instead of "logon path ="

No more errors while logging into windows! Now I'm going to figure out how to write a login script to do exactly what I need!
Reply With Quote
  #25  
Old 4th September 2008, 15:52
mperreault mperreault is offline
Junior Member
 
Join Date: Dec 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
Default OpenLDAP + Samba Domain with OS X Client?

Hello, does anyone know how I can get an OS X 10.5 client to authenticate with this particular setup? I have my windows machines working very well.. However it would be nice to have the server handle the user authentication for the Mac as well...
Reply With Quote
  #26  
Old 28th September 2008, 12:17
yatinbhatt yatinbhatt is offline
Junior Member
 
Join Date: Sep 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mperreault View Post
I've been trying to follow this http://www.howtoforge.com/openldap-s...r-ubuntu7.10-p Tutorial on and off for the past 2 months. I work in a school and as we have run out of CAL's for the Windows 2003 SBS I would rather replace the domain controller with something free as we can't afford to buy the CAL's...

Anyway I've reached the point where I get the XP machine to join the domain. I type "root" as the username and "12345" as the password and I get..

The following error occurred attempting to join the domain "example":

The user name could not be found.


I've tried using sysadmin for the user. and it also doesn't work...

Any ideas?
Is there any solution for this issue ?? I also have the same problem.
Reply With Quote
  #27  
Old 28th September 2008, 13:18
mperreault mperreault is offline
Junior Member
 
Join Date: Dec 2007
Posts: 12
Thanks: 3
Thanked 0 Times in 0 Posts
 
Smile

Quote:
Originally Posted by yatinbhatt View Post
Is there any solution for this issue ?? I also have the same problem.
I ended up starting over and it worked... The server has been up and running for the past 4 weeks now with a full load of students logging on and off all day... I havn't had any issues! Good luck with it!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenLDAP + Samba Domain Controller On Ubuntu 7.10 agarcia71 HOWTO-Related Questions 19 18th July 2008 16:41
OpenLDAP + Samba Domain yakkeh HOWTO-Related Questions 1 10th January 2008 17:09
Ubuntu 7.10 LDAP Samba question netwerkdude HOWTO-Related Questions 0 6th January 2008 23:35
samba domain controller - ubuntu eoij1 HOWTO-Related Questions 3 6th October 2006 15:35
Ubuntu Samba -- 'Unknown User' error in Win2k? chewtoy Server Operation 2 5th September 2006 16:21


All times are GMT +2. The time now is 05:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.