Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th December 2005, 20:35
justjim justjim is offline
Member
 
Join Date: Dec 2005
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Question Can't seem to figure this out...

Hello,
I'm having a problem that I've seen posted elsewhere here, but can't seem to find an answer that works! Here are all of the details:

I have installed Ubuntu Breezy Badger 5.10 and followed the HowToForge documents. The install went well.

Problem: When I try to access my site, I receive the Apache "Index of /" screen instead of my website main page.

Notes: My Internet Provider blocks port 80. Therefore, I am doing a forward from my domain registar. I am forwarding all requests for my site to be forwarded to my external IP:Port 5555

I'm sure that this is a DNS issue of some type, but I'm not sure how to troubleshoot and resolve. Here are my questions:

1. Do I need to make changes on the Domain Registar side, or locally from within ISPConfig? If so, what changes should I make?

2. Since my Domain registar is forwarding all requests for my domain to my specific IP:Port, does Apache know which site to hand the request to? In other words, if I add more sites onto my server, can Apache handle these with only the IP and Port information? Or, is my Domain Registar also sending the site information too?

3. Anything else I need to know about to make this work?

Thanks in advance!

- Jim
Reply With Quote
Sponsored Links
  #2  
Old 4th December 2005, 20:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,419
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
Default

Have you forwarded your external port 5555 to port 80 or port 5555 of your linux server?
Reply With Quote
  #3  
Old 4th December 2005, 20:58
justjim justjim is offline
Member
 
Join Date: Dec 2005
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have requests for the domain forwarded from my registar to my external IPort 5555. Then all requests for that port are allowed through my router/firewall and go to my server (192.168.1.103ort 5555).
Reply With Quote
  #4  
Old 4th December 2005, 23:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by justjim
I have requests for the domain forwarded from my registar to my external IPort 5555. Then all requests for that port are allowed through my router/firewall and go to my server (192.168.1.103ort 5555).
But your Apache is running on port 80, isn't it? Then you must forward requests to your router on port 5555 to port 80 on 192.168.1.103.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 5th December 2005, 00:19
justjim justjim is offline
Member
 
Join Date: Dec 2005
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have Apache listening on port 5555 and port 443.
Reply With Quote
  #6  
Old 5th December 2005, 10:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by justjim
I have Apache listening on port 5555 and port 443.
Ok, but ISPConfig is using port 80 for the Vhosts. So you have to change the function make_vhost() in /root/ispconfig/scripts/lib/config.lib.php.

http://www.howtoforge.com/forums/sho...?t=1423&page=2
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th December 2005, 22:04
justjim justjim is offline
Member
 
Join Date: Dec 2005
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks! That seemed to get me one step further in the process.

However, now I'm getting the page that says there are multiple sites hosted on the server and to enter the domain name instead of the IP address.

Does this mean that my domain host does not pass this information when they
do forwarding....or is there something I can do locally to make this work? Maybe in the DNS settings area???

Thanks again!
Reply With Quote
  #8  
Old 9th December 2005, 02:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Quote:
Originally Posted by justjim
However, now I'm getting the page that says there are multiple sites hosted on the server and to enter the domain name instead of the IP address.
What page do you see then? Did you use the IP address?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 9th December 2005, 03:11
justjim justjim is offline
Member
 
Join Date: Dec 2005
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

My Internet Provider blocks port 80. Therefore, I am doing a forward from my domain registar. They are forwarding all requests for my site (www.greatgolfswing.com) to be forwarded to my external IP:Port (70.187.21.206:5555).

When I type in my URL, I'm forwarded to a page that says:
This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.

Is there any way to resolve this? Or can you make recommendations for a better way to do what I am attempting?

Thanks again!

Jim
Reply With Quote
  #10  
Old 9th December 2005, 09:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,419
Thanks: 812
Thanked 5,205 Times in 4,081 Posts
 
Default

Have you changed the ISPConfig sources like falko suggested above? Without that change you cant see the vhosts because they are on port 80 and not port 5555.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to figure out the correct IP Address(es) during installation? scgrif32 HOWTO-Related Questions 1 3rd December 2005 13:05
Can't figure out how to use subdomain for mail. SkIRmiS Installation/Configuration 1 20th September 2005 21:31


All times are GMT +2. The time now is 19:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.