Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 6th January 2006, 18:26
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default

I'll have a dig in the database and check nothing has gotten corrupted.

In the meantime here you go ... just a few personal sites on there at the mo.

Code:
[root@emily home]# ls -la /home
total 96
drwxr-xr-x  18 root         root         4096 Jan  6 16:25 .
drwxr-xr-x  23 root         root         4096 Nov 29 23:03 ..
drwxr-xr-x   3 root         root         4096 Sep 14 00:30 127.0.0.1
drwxr-xr-x   4 admispconfig admispconfig 4096 Sep  3 15:27 admispconfig
lrwxrwxrwx   1 root         root           11 Sep 30 22:07 beardface.nqb-w.net -> /home/web11
lrwxrwxrwx   1 root         root           11 Dec 21 22:06 blackfleet.zoon.me.uk -> /home/web18
lrwxrwxrwx   1 root         root           11 Jan  6 15:42 emily.laxton.me.uk -> /home/web19
lrwxrwxrwx   1 root         root           11 Jan  6 15:26 ffs.zoon.me.uk -> /home/web6/
lrwxrwxrwx   1 root         root           11 Nov 28 21:38 lb.zoon.me.uk -> /home/web16
drwxr-xr-x   3 root         root         4096 Jan  6 15:28 localhost
lrwxrwxrwx   1 root         root           10 Sep 24 12:16 princessc.zoon.me.uk -> /home/web8
drwxr-xr-x   7 rich         rich         4096 Jan  6 16:25 rich
lrwxrwxrwx   1 root         root           11 Dec 21 19:26 ts.zoon.me.uk -> /home/web17
drwxr-xr-x   8 apache       web11        4096 Oct  1 04:00 web11
drwxr-xr-x   9 apache       web12        4096 Oct 17 04:00 web12
drwxr-xr-x   8 apache       web14        4096 Oct 17 04:00 web14
drwxr-xr-x   8 apache       web16        4096 Nov 29 22:28 web16
drwxr-xr-x   9 apache       web17        4096 Dec 22 04:00 web17
drwxr-xr-x   8 apache       web18        4096 Dec 22 04:00 web18
drwxr-xr-x   8 apache       web19        4096 Jan  6 15:41 web19
drwxr-xr-x   9 web4_richard web4         4096 Jan  5 23:24 web4
drwxr-xr-x   8 web6_zoon    web6         4096 Jan  5 23:24 web6
drwxr-xr-x   8 web7_richard web7         4096 Jan  5 23:24 web7
drwxr-xr-x   8 apache              10008 4096 Sep 25 04:00 web8
drwxr-xr-x   8 apache       web9         4096 Oct  1 04:00 web9
lrwxrwxrwx   1 root         root           10 Sep 14 20:23 www.laxton.me.uk -> /home/web7
lrwxrwxrwx   1 root         root           10 Sep 30 19:06 www.totalmodding.co.uk -> /home/web9
lrwxrwxrwx   1 root         root           11 Oct 16 21:13 www.zerofanzone.co.uk -> /home/web12
lrwxrwxrwx   1 root         root           11 Oct 16 21:15 www.zfzforums.co.uk -> /home/web14
lrwxrwxrwx   1 root         root           10 Sep  3 18:10 www.zoon.me.uk -> /home/web4
Reply With Quote
Sponsored Links
  #12  
Old 6th January 2006, 18:42
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default

The database looks OK so I wonder if the links aren't set up right.

Code:
mysql> select web_host, web_domain from isp_isp_web;
+------------+--------------------+
| web_host   | web_domain         |
+------------+--------------------+
| www        | zoon.me.uk         |
| princessc  | zoon.me.uk         |
| ffs        | zoon.me.uk         |
| www        | laxton.me.uk       |
| www        | totalmodding.co.uk |
| beardface  | nqb-w.net          |
| www        | zerofanzone.co.uk  |
| www        | zfzforums.co.uk    |
| lb         | zoon.me.uk         |
| ts         | zoon.me.uk         |
| blackfleet | zoon.me.uk         |
| emily      | laxton.me.uk       |
+------------+--------------------+
12 rows in set (0.00 sec)

Last edited by Zoon; 6th January 2006 at 18:49.
Reply With Quote
  #13  
Old 6th January 2006, 19:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Can you put
PHP Code:
echo "$webroot/$virtual_host"."\n";
echo 
readlink("$webroot/$virtual_host")."\n"
(and remove the other echo statement)
into the logs.php script before line 125 and run it again? What's the output?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 7th January 2006, 13:55
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default

Here you go ...

Code:
[root@emily ~]# /root/ispconfig/php/php -cli /root/ispconfig/scripts/shell/logs.php
/home/ffs.zoon.me.uk
/home/web6/
/home/www.zerofanzone.co.uk
/home/web12
/home/emily.laxton.me.uk
/home/web19
/home/localhost

Warning: readlink(): Invalid argument in /root/ispconfig/scripts/shell/logs.php on line 126


Warning: readlink(): Invalid argument in /root/ispconfig/scripts/shell/logs.php on line 127
/home/www.zoon.me.uk
/home/web4
Reply With Quote
  #15  
Old 7th January 2006, 16:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Ok, the warnings are related to /home/localhost which wasn't created by ISPConfig and is not a link to another directory. You can ignore it.

After you run
Code:
/root/ispconfig/php/php /root/ispconfig/scripts/shell/logs.php
, please also run
Code:
/root/ispconfig/php/php /root/ispconfig/scripts/shell/webalizer.php
Are the statistics generated then?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 7th January 2006, 23:25
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yes they are ... the error message is still thrown as before but this time at least they run.

I guess the symbolic links were broken and recreating them fixed it

Thanks for your help and your prompt replies
Reply With Quote
  #17  
Old 26th February 2006, 01:16
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

I've had the same error, and the log files grow and grow: the script does not trim them down to size each night.

I've asked about this a few times, but never got to the bottom of the problem, so I have to manually delete the logs every few days.

I wonder what there is about your setup and mine that causes the problem for us, but not for most people.
Reply With Quote
  #18  
Old 27th February 2006, 00:52
Zoon Zoon is offline
Member
 
Join Date: Sep 2005
Posts: 30
Thanks: 0
Thanked 1 Time in 1 Post
Default

I never had to delete the log files, and its been working OK since. Its probably related to having large log files, one of the sites that stopped working was a 75,000 hit website so that could have something to do with it.
Reply With Quote
  #19  
Old 27th February 2006, 01:43
hairydog2 hairydog2 is offline
Senior Member
 
Join Date: Oct 2005
Posts: 196
Thanks: 9
Thanked 3 Times in 2 Posts
Default

My problem was the logs from a busy site: about 350,000 pages a month at present - webalyzer reports 1754058 hits in Jan 2006.

Maybe the scripts time out before they have processed the log.
Reply With Quote
  #20  
Old 27th February 2006, 10:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Lightbulb

Ah... Then you might have to increase PHP's memory limit in /root/ispconfig/php/php.ini. If you have very large log files, then it's likely that PHP will run out of memory unless you increase the memory limit.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webalizer doesn't work :( DarkBen Installation/Configuration 22 13th January 2008 15:04
Zone files are not updated after deletion from web JAYDEE.U Installation/Configuration 1 1st January 2007 11:09
Webalizer tab files matheron Server Operation 4 11th December 2005 14:26
webalizer and logrotate damaskinos Server Operation 4 25th November 2005 00:16
web.log and webalizer Lobanak Installation/Configuration 4 11th September 2005 20:24


All times are GMT +2. The time now is 23:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.