Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th January 2006, 10:11
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs

Hy everyone.

I have a question. If i don't want to use quota in postfix (becuse only i use my server and i don't need no quota), can i simply skip the point that describes how to apply quota patch to postfix and quota exceedance notifications?

Thankyou, Bye,
Drejc
Reply With Quote
Sponsored Links
  #2  
Old 6th January 2006, 11:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

I think so. You might also have to modify the Postfix configuration files.
On the other hand, it doesn't really hurt if your Postfix supports quota.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 6th January 2006, 22:18
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hy.

Well, I set up everything that is described in Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAssassin, ClamAV) howto.
And everything works great, except one thing:
I can't connect to my mailserver with for example mozilla thunderbird mail client from any another computer. It says that password is wrong, and even courierpop3login says:
Jan 6 22:10:07 lintvern courierpop3login: LOGIN FAILED, ip=[::ffff:193.77.177.132]

But I have the right password, I am pretty sure about that.

Is there anything else I should enable?

Regards, Drejc
Reply With Quote
  #4  
Old 6th January 2006, 22:44
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Even if I start:
# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.com.
Escape character is '^]'.
+OK Hello there.
user ruskicar
+OK Password required.
pass ######

It says Login Failed
But I can check mail with mutt and there is no problem.

What if I install Qpopper?
Will everything work all-right then?

Regards, RuskiCar
Reply With Quote
  #5  
Old 7th January 2006, 00:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by ruskicar
Even if I start:
# telnet localhost 110
Trying 127.0.0.1...
Connected to localhost.com.
Escape character is '^]'.
+OK Hello there.
user ruskicar
+OK Password required.
pass ######

It says Login Failed
But I can check mail with mutt and there is no problem.
Please check the format of /etc/courier/authmysqlrc (spaces, tabs, etc.). Courier is very finicky about the format.

Quote:
Originally Posted by ruskicar
What if I install Qpopper?
Will everything work all-right then?
Don't install Qpopper! It won't work!
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 7th January 2006, 11:02
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hy.

I have done the check of authmysqlrc, and everything is ok (no spaces or brackets). I've restarted all /etc/init.d/courier* and postfix, but still pop3 login doesn't work.

Is it ok, that MYSQL_SERVER in localhost, or should it be sth. else? What about ownership of authmysqlrc and authdaemonrc? I have them set to daemon:daemon. Is this ok?

Is there anything else to check or replace?

Hope to hearing from you soon,
RuskiCar
Reply With Quote
  #7  
Old 7th January 2006, 11:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Is there anything else than
Quote:
Jan 6 22:10:07 lintvern courierpop3login: LOGIN FAILED, ip=[::ffff:193.77.177.132]
in the mail log?
Are you sure you're using the correct username (must be an email address) and password?
Did you follow the tutorial to the letter? Maybe you made a typo somewhere?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 7th January 2006, 11:56
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default

OHMYGOD

Sorry...I've completely forgot to use login username as username@hostname.com

But now my syslog says:
Jan 7 11:54:57 lintvern courierpop3login: Connection, ip=[::ffff:193.77.17.199]
Jan 7 11:54:57 lintvern courierpop3login: chdir "home/vmail": No such file or directory

Anyway, I have another question. What if someone sends e-mail to root or some other users from /etc/aliases. Should I put all users from /etc/aliases to forwardings table?

Bye
Reply With Quote
  #9  
Old 7th January 2006, 12:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by ruskicar
OHMYGOD

Sorry...I've completely forgot to use login username as username@hostname.com

But now my syslog says:
Jan 7 11:54:57 lintvern courierpop3login: Connection, ip=[::ffff:193.77.17.199]
Jan 7 11:54:57 lintvern courierpop3login: chdir "home/vmail": No such file or directory
I guess you didn't follow the tutorial to the letter because on http://www.howtoforge.com/virtual_po...ota_courier_p2 it says:

Code:
groupadd -g 5000 vmail
useradd -g vmail -u 5000 vmail -d /home/vmail -m
which means /home/vmail is created if it doesn't exist.

Quote:
Originally Posted by ruskicar
Anyway, I have another question. What if someone sends e-mail to root or some other users from /etc/aliases. Should I put all users from /etc/aliases to forwardings table?

Bye
No, don't put real system users into the database!
If someone sends mails to users from /etc/aliases, these mails will get delivered as described in /etc/aliases. Postfix can distinguish between system users and virtual users.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 7th January 2006, 12:48
ruskicar ruskicar is offline
Junior Member
 
Join Date: Jan 2006
Location: Slovenia
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I've even tried to send e-mail from telnet:
telnet localhost 25
ehlo localhost
250-lintvern.net
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
mail from:<ruskicar@lintvern.net>
250 Ok
rcpt to:<jammz@lintvern.net>
250 Ok
data
354 End data with <CR><LF>.<CR><LF>
Testing blabla.
.
250 Ok: queued as 5BC8A2EB7D
quit
221 Bye

And /var/log/mail.log says:

Jan 7 12:37:32 lintvern postfix/smtpd[12139]: connect from localhost.localdomain[127.0.0.1]

Jan 7 12:38:41 lintvern postfix/smtpd[12139]: BA2582EB71: client=localhost.localdomain[127.0.0.1]

Jan 7 12:39:01 lintvern postfix/cleanup[12146]: BA2582EB71: message-id=<20060107114457.5BC8A2EB7D@lintvern.net>

Jan 7 12:39:01 lintvern postfix/qmgr[11946]: BA2582EB71: from=<ruskicar@lintvern.net>, size=367, nrcpt=1 (queue active)

Jan 7 12:39:02 lintvern amavis[2552]: (02552-03) lookup_sql: 2006, MySQL server has gone away

Jan 7 12:39:02 lintvern amavis[2552]: (02552-03) NOTICE: Disconnected from SQL server

Jan 7 12:39:02 lintvern amavis[2552]: (02552-03) TROUBLE in check_mail: creating_partsdir FAILED: DBD::mysql::st execute failed: MySQL server has gone away at (eval 38) line 238, <GEN17> line 8481.

Jan 7 12:39:02 lintvern amavis[2552]: (02552-03) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20060106T215628-02552

Jan 7 12:39:02 lintvern postfix/smtp[12147]: BA2582EB71: to=<jammz@lintvern.net>, relay=127.0.0.1[127.0.0.1], delay=51,
status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=02552-03, creating_partsdir FAILED: DBD::mysql::st execute failed: MySQL server has gone away at (eval 38) line 238, <GEN17> line 8481. (in reply to end of DATA command))

Jan 7 12:39:06 lintvern postfix/smtpd[12139]: disconnect from localhost.localdomain[127.0.0.1]

Hope this will help in any kind of way.
Regards,
Drejc
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota... killfrog HOWTO-Related Questions 3 25th September 2009 21:45
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs amilcar HOWTO-Related Questions 1 1st January 2006 17:12
Virtual Users And Domains With Postfix, Courier And MySQL: POP/IMAP authentication SeanG HOWTO-Related Questions 3 1st January 2006 17:08
Virtual Users And Domains With Postfix, Courier And MySQL ariek HOWTO-Related Questions 3 12th December 2005 22:14
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54


All times are GMT +2. The time now is 17:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.