Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th March 2006, 08:13
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default quota and ispcfg related question

hi guys,

I am just curious as to how "good" ispcfg works with quota.
as an example I have a site with a quota of 5000MB, when I go into ispcfg => sites => thissite => STATISTICS I see:
below this I see:

Storage Space: 5000MB
used: 11011.74k
DB::MySQL 11011.7k


I never had ispcfg showing me more correct data, I thought its just not working...
But quota is implemented right because I got an email about this site exceeding its quota just several minutes ago, saying.

Group: web2
Used Storage Space: 5081.53 MB
Allocated Storage Space: 5000.00 MB

so quota is indeed working. I wanted to see where these 5GBs are located so I tried:

h5810:/var/www# du -s -c -h web2/
3,9G web2/
3,9G insgesamt

so where would the rest of 5081 GB be ? how can I locate that?
I set their logsize to 10% in ispcfg and now watch this:

h5810:/var/www/web2# du -s -c -h log/
768M log/
768M insgesamt

how can that be? 768 >>> 500 (=10% of 5000)

I really hope somebody can help clarify these..
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2006, 08:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,976
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

I guess you have not configured ISPConfig to use the du command with sudo:

http://www.howtoforge.com/forums/showthread.php?t=2064

Otherwise the admispconfig user is not able to get the correct size of the website directory. You can verify this by logging in as root, run du for a special website directory, then run "su admispconfig" t switch to the ispconfig user and run the same du command.

I also recommend to have a look at your /tmp directory and /home/admispconfig/ispconfig/temp directory if there are any files from this user or group.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th March 2006, 08:57
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

I followed the advice given in that link, still I did not find anything from this group (web2) inside /tmp nor inside /home/admispconfig/ispconfig/temp ...

is there a command to find everything belonging to a certain group?
Reply With Quote
  #4  
Old 13th March 2007, 20:57
goldstift goldstift is offline
Junior Member
 
Join Date: Feb 2007
Location: Hilden, Germany
Posts: 16
Thanks: 3
Thanked 3 Times in 3 Posts
Default

Hi Tenaka,

you can find all files belonging to a group with
> find / -group web2

I used this for exactly the same problem.

Greets,
Alex
Reply With Quote
  #5  
Old 13th March 2007, 21:37
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,262
Thanks: 78
Thanked 24 Times in 20 Posts
Default

thx :-) although this is a year old post, your info is still useful and welcome.
Reply With Quote
The Following User Says Thank You to Ovidiu For This Useful Post:
goldstift (10th January 2008)
  #6  
Old 10th January 2008, 14:24
goldstift goldstift is offline
Junior Member
 
Join Date: Feb 2007
Location: Hilden, Germany
Posts: 16
Thanks: 3
Thanked 3 Times in 3 Posts
 
Default

Hi there,

for your interest:
In Fedora Core 6 there is by default a special setting in the sudo config file. This switch has to be changed if you want to use sudo in php scripts.

type "visudo" and search for
Code:
    Defaults requiretty
I commented this out (with a #) and everything worked fine.


Apparenly Fedora Core 6 is the only OS that has the setting and it's very hard to find/ guess good search terms to find any info about this switch. That's why i'd like to add some more key words here for others experiencing the same problem:
Code:
- $go_info["server"]["sudo_du_enabled"] = true;
- /root/ispconfig/httpd/logs/error_log
- sudo: sorry, you must have a tty to run sudo
- FC6 Fedora 6
Greets,
Alex

Last edited by goldstift; 18th January 2008 at 00:03.
Reply With Quote
The Following User Says Thank You to goldstift For This Useful Post:
Tenaka (11th January 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.