#1  
Old 1st January 2008, 18:59
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
Default Which php.ini

I installed xcache with the command apt-get install php5-xcache, however I am unsure if it is actually working, so I went to review my php.ini and discovered that there are 4 of them:
Quote:
/root/ispconfig/php/php.ini
/usr/share/doc/php5-xcache/examples/php.ini
/etc/php5/cli/php.ini
/etc/php5/apache2/php.ini
1. Should /etc/php5/cli/php.ini and /etc/php5/apache2/php.ini be the same?
2. do I need to copy the contents of /usr/share/doc/php5-xcache/examples/php.ini to one of the other php.ini's to make it work?
3. Does this have anything to do with the message "PHP Warning: Module 'json' already loaded in Unknown on line 0" because the extension json.so is specified in both the .../cli/php.ini and .../apache2/php.ini

I feel really ignorant asking these questions, but most of my experience is on a Fedora box which is a little bit different.

-John

Ubuntu Server 7.04 - The Perfect Setup
ISP Config
Reply With Quote
Sponsored Links
  #2  
Old 1st January 2008, 20:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

If you want to check if xcache is working, create php file with the content:

Code:
<?php
phpinfo();
?>
Then call the file in the browser and check if xcache is listed there.

The php.ini for your apache webserver is:

/etc/php5/apache2/php.ini

but the xcache extensions does not nescessarily be enabled there if there are other include directories for sub ini files.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st January 2008, 23:11
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
Default

It does not look like xcache is being loaded:

Quote:
additional .ini files parsed /etc/php5/apache2/conf.d/curl.ini, /etc/php5/apache2/conf.d/gd.ini, /etc/php5/apache2/conf.d/mhash.ini, /etc/php5/apache2/conf.d/ming.ini, /etc/php5/apache2/conf.d/mysql.ini, /etc/php5/apache2/conf.d/mysqli.ini,
/etc/php5/apache2/conf.d/pdo.ini, /etc/php5/apache2/conf.d/pdo_mysql.ini, /etc/php5/apache2/conf.d/pdo_sqlite.ini, /etc/php5/apache2
/conf.d/ps.ini, /etc/php5/apache2/conf.d/pspell.ini, /etc/php5/apache2/conf.d/recode.ini, /etc/php5/apache2/conf.d/snmp.ini, /etc/php5
/apache2/conf.d/sqlite.ini, /etc/php5/apache2/conf.d/tidy.ini, /etc/php5/apache2/conf.d/xmlrpc.ini, /etc/php5/apache2/conf.d/xsl.ini
Reply With Quote
  #4  
Old 2nd January 2008, 11:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

Did you search the complete site for the word "xcache" with the search function of the webbrowser?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd January 2008, 15:57
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
Default

Yes, and I looked at all of the paths suggested by the phpinfo reporr too.


-J
Reply With Quote
  #6  
Old 3rd January 2008, 11:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,256 Times in 4,121 Posts
Default

I recommend that you try to search for xcache on your server and if the .so file for xcahe is installed, add it to your php.ini manually.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 6th January 2008, 03:31
unsichtbare unsichtbare is offline
Senior Member
 
Join Date: Sep 2007
Posts: 111
Thanks: 18
Thanked 7 Times in 6 Posts
 
Default

I added it to the correct php.ini and now it shows when I run phpinfo, but not much impact on performance
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
need to change toggle settings of php.ini file in SSH bpstyle Installation/Configuration 4 13th February 2007 11:33
FATAL ERROR: register_globals is disabled in php.ini, please enable it wvsailor Installation/Configuration 4 20th September 2006 19:45
php.ini ?!! gabykh Installation/Configuration 3 28th July 2006 20:15
PHP.INI File Location lukefuller Installation/Configuration 4 21st May 2006 13:56
Wrong php.ini? roadrunner Programming/Scripts 1 26th April 2005 15:29


All times are GMT +2. The time now is 03:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.