Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 4th January 2008, 17:11
Rockdrala Rockdrala is offline
Senior Member
 
Join Date: Dec 2007
Posts: 140
Thanks: 7
Thanked 2 Times in 2 Posts
Default

lol















...

I guess that fixed it for him.
Reply With Quote
Sponsored Links
  #12  
Old 4th January 2008, 23:24
chua_jose chua_jose is offline
Member
 
Join Date: Nov 2007
Posts: 70
Thanks: 6
Thanked 2 Times in 2 Posts
Default

Quote:
Originally Posted by till
Have you created a DNS A-Record for pop.xxxxxxxxxx.com that points to your server? If not, you will have to create this dns A-Record or use the IP address as pop3 and smtp server address instead.
If I write in the server pop:
xxxxxxxx.com
yes it works, but if I write
pop.xxxxxxxxx.com
does not work.
If I create an entry DNS A Record, yes it works
There is some way of doing it automatic for all the domains that are given of discharge?
and doing it automatic for ftp too?


Now already I can send and receive mail ok


I checked in ISP-domain:
Create DNS and Create DNS-MX
and check in management - server -settings -dns
Default MX

Quote:
[root@SD1111100130 named]# dig mx xxxxxxxxxxxx.com

; <<>> DiG 9.3.3rc2 <<>> mx xxxxxxxxxxx.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 34704
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 2, ADDITIONAL: 1

;; QUESTION SECTION:
;xxxxxxxxxxxxx.com. IN MX

;; ANSWER SECTION:
xxxxxxxxxxxxxx.com. 85325 IN MX 10 www.xxxxxxxxxxxxxx.com.

;; AUTHORITY SECTION:
xxxxxxxxxxxxxxx.com. 68010 IN NS ns1.xxxxxxxxxx.com.
xxxxxxxxxxxxxxx.com. 68010 IN NS ns2.xxxxxxxxxx.com.

;; ADDITIONAL SECTION:
www.xxxxxxxxxxxxxx.com. 68010 IN A 213.60.254.125

;; Query time: 2 msec
;; SERVER: 212.51.33.73#53(212.51.33.73)
;; WHEN: Sat Jan 5 14:09:12 2008
;; MSG SIZE rcvd: 106
How change ANSWER SECTION MX www.xxxxxxxxxxxxxx.com to xxxxxxxxxxxxxx.com

Thanks for all

Last edited by chua_jose; 5th January 2008 at 15:14.
Reply With Quote
  #13  
Old 9th August 2010, 00:33
dongsky dongsky is offline
Junior Member
 
Join Date: Mar 2010
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Default regarding the email notification in nagios

can somebody here had already solve this issue?

here's the maillog..

click this link: http://www.glowfoto.com/static_image.../img6/glowfoto
Reply With Quote
  #14  
Old 9th August 2010, 14:47
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

The link doesn't work. Can you post your maillog here directly?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 5th January 2011, 05:04
mrthangvn mrthangvn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have the same problem when i try:
[root@localhost ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
Connection closed by foreign host.
Nothing happen.

Here's my main.cf

Quote:
queue_directory = /var/spool/postfix


command_directory = /usr/sbin


daemon_directory = /usr/libexec/postfix

mail_owner = postfix

myhostname = nlsi.gov.vn

mydomain = nlsi.gov.vn

myorigin = $mydomain


inet_interfaces = all

inet_interfaces = localhost


mydestination = $myhostname, localhost.$mydomain, localhost , $mydomain

unknown_local_recipient_reject_code = 550


mynetworks = 168.100.189.0/28, 127.0.0.0/8, 192.168.1.0/24, 10.0.0.0/24


alias_maps = hash:/etc/aliases

home_mailbox = Maildir/

header_checks = regexp:/etc/postfix/header_checks
body_checks = regexp:/etc/postfix/body_checks


smtpd_banner = $myhostname ESMTP

debug_peer_level = 2

debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5


sendmail_path = /usr/sbin/sendmail.postfix


mailq_path = /usr/bin/mailq.postfix


setgid_group = postdrop


html_directory = no


manpage_directory = /usr/share/man


sample_directory = /usr/share/doc/postfix-2.3.3/samples


readme_directory = /usr/share/doc/postfix-2.3.3/README_FILES
#limit an email size 5M
message_size_limi = 5242880
#limi mailbox 100M
mailbox_size_limit = 104857680
#for SMTP-Auth setting
broken_sasl_auth_clients = yes
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth-client
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
smtpd_client_restrictions = permit_mynetworks,permit_auth_destination,permit_s asl_authenticate
smtpd_auth_tls_only = no
smtpd_use_tls =yes
smtpd_note_starttls_offer = yes
smtpd_tls_cert_file = /etc/pki/tls/certs/server.crt
smtpd_tls_key_file = /etc/pki/tls/certs/server.key
smtpd_tls_session_cache_database = btree:/etc/postfix/smtpd_scache
and log:
Quote:
Jan 5 09:12:36 localhost postfix/smtpd[6261]: connect from localhost.localdomain[127.0.0.1]
Jan 5 09:12:38 localhost postfix/smtpd[6261]: SSL_accept error from localhost.localdomain[127.0.0.1]: -1
Jan 5 09:12:38 localhost postfix/smtpd[6261]: warning: TLS library problem: 6261:error:140760FC:SSL routines:SSL23_GET_CLIENT_HELLO:unknown protocol:s23_srvr.c:562:
Jan 5 09:12:38 localhost postfix/smtpd[6261]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Jan 5 09:12:38 localhost postfix/smtpd[6261]: disconnect from localhost.localdomain[127.0.0.1]
Reply With Quote
  #16  
Old 5th January 2011, 15:05
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
inet_interfaces = all

inet_interfaces = localhost
Please remove inet_interfaces = localhost from your main.cf and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
mrthangvn (7th January 2011)
  #17  
Old 7th January 2011, 07:36
mrthangvn mrthangvn is offline
Junior Member
 
Join Date: Jan 2011
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Please remove inet_interfaces = localhost from your main.cf and restart Postfix.
Thanks, but it still doesnt works
Reply With Quote
  #18  
Old 8th January 2011, 13:20
falko falko is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

What's the output of
Code:
netstat -tap
? Are there any other errors in your mail log?

Can you post your main.cf again?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.