#51  
Old 29th January 2006, 13:06
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

This is what is in htaccess.txt

##
# @version $Id: htaccess.txt,v 1.5 2005/01/22 23:00:27 spacemonkey Exp $
# @package Mambo
# @copyright (C) 2000 - 2005 Miro International Pty Ltd
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Mambo is Free Software
##

#
# mod_rewrite in use
#

RewriteEngine On

# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update YourMamboDirectory (just / for root)

# RewriteBase /YourMamboDirectory

#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php

and these are the warnings i get when i change the name to .htaccess

[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_extcalendar_minical.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_extcalendar_minical.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_artbanners1.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_artbanners1.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_artbanners1.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_artbanners1.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2(/srv/www/web9/web/modules/mod_bookmarkus.php) [<a href='function.module2'>function.module2</a>]: failed to open stream: No such file or directory in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] PHP Warning: modules_html::module2() [<a href='function.include'>function.include</a>]: Failed opening '/srv/www/web9/web/modules/mod_bookmarkus.php' for inclusion (include_path='.:') in /srv/www/web9/web/includes/frontend.html.php on line 264, referer: http://www.englandshirt.com/installation/install4.php
[Sat Jan 28 22:36:16 2006] [error] [client 192.168.1.100] File does not exist: /srv/www/web9/web/images/owen, referer: http://www.englandshirt.com/index.php

There are no additional errors written to the log.

Now I try to create a file called .htaccess because i cannot see the file that i have renamed, I recieve FILE ALREADY EXISTS, but where is it?
I also recieved a crash error from Konqueror The application Konqueror crashed and caused the signal 11(SIGSEGV)

This appears when i try to access my site .

Forbidden

You don't have permission to access /index.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.53 (Linux/SUSE) Server at www.englandshirt.com Port 80

OH and by the way I am local at the moment on my Linux server.

shajazzi
Reply With Quote
Sponsored Links
  #52  
Old 29th January 2006, 13:11
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Sorry Falko, I just refreshed the error log and these are the additional errors:

[Sun Jan 29 11:00:18 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/index.php
[Sun Jan 29 11:00:18 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html
[Sun Jan 29 11:00:19 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/favicon.ico
[Sun Jan 29 11:00:19 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html
[Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/, referer: http://www.howtoforge.com/forums/showthread.php?p=13507
[Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html, referer: http://www.howtoforge.com/forums/showthread.php?p=13507
[Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/favicon.ico
[Sun Jan 29 11:06:34 2006] [error] [client 192.168.1.100] Options FollowSymLinks or SymLinksIfOwnerMatch is off which implies that RewriteRule directive is forbidden: /srv/www/web9/web/error/forbidden.html

shajazzi
Reply With Quote
  #53  
Old 29th January 2006, 19:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Have a look at these two threads. They are for Drupal, but Drupal's .htaccess file looks exactly like yours.

http://www.howtoforge.com/forums/showthread.php?t=38
http://www.howtoforge.com/forums/showthread.php?t=788
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #54  
Old 30th January 2006, 02:54
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Thanks falko,
I had a look at the threads you mentioned and no luck i`m afraid.
My problem is i cannot edit the .htaccess file because i haven`t one.
The closest i can get is to create a file and name it htaccess but this is not going to work so I change the file from htaccess to .htaccess and the file disappears so then i cannot edit it.
I do not know whats going on. I`ve come this far, all I want is frendly URLS.

Last edited by shajazzi; 30th January 2006 at 03:04.
Reply With Quote
  #55  
Old 30th January 2006, 09:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
Originally Posted by shajazzi
The closest i can get is to create a file and name it htaccess but this is not going to work so I change the file from htaccess to .htaccess and the file disappears so then i cannot edit it.
Thats normal, files that begin with a dot are hidden files in linux.

You can either edit it on the commandline, to get a file listing use "ls -la" command or you use a program like winSCP to connect from a windows workstation and edit the file.

If you want to see the file in FTP, you will have to modify the LsDefaultOption in your ftp server configuration.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #56  
Old 30th January 2006, 10:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Till's right. I guess you use FTP to manage your .htaccess file which normally doesn't work unless you configure your FTP server in a different way (see Till's post above).

I recommend to manage that file on the command line. You can use an editor like vi to edit the file on the command line. Read here to learn how to use vi: http://www.howtoforge.com/faq/12_15_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #57  
Old 4th February 2006, 17:31
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Thanks falko and till,
you`ve been a great help but i still cannot get .htaccess to work.
I tried this to see if .htaccess override is allowed:

I deleted everything from my .htaccess and replaced it with this
Redirect /google.html http://www.google.com
then i pionted the browser to http://www.englandshirt.com/google.html and this works fine.
When replace Redirect /google.html http://www.google.com with the following



mod_gzip_on Yes

<Files .htaccess>
order allow,deny
deny from all
</Files>

ErrorDocument 404 /errordocs/error404.php
ErrorDocument 400 /errordocs/error404.php

DirectoryIndex index.htm

Options +FollowSymlinks +MultiViews


##
# @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
# @package Mambo_4.5
# @copyright (C) 2000 - 2004 Miro International Pty Ltd
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Mambo is Free Software
##

#


# mod_rewrite in use
#
DirectoryIndex index.php

RewriteEngine On

# for apache on windows you might need to uncomment
# this Options line
#Options +SymlinksIfOwnerMatch

# Uncomment following line if your webserver's URL
# is not directly related to physival file paths.
# Update YourMamboDirectory (just / for root)

RewriteBase /
#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)/ index.php

and enable SEO in mambo back end i can only see my homepage.

When I click on a link i get errors like this one:

Not Found

The requested URL /component/option,com_contact/Itemid,3/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.53 (Linux/SUSE) Server at www.englandshirt.com Port 80


If I disable SEO in mambo backend, now I can see all the links again but they are no search engine friendly.

Last edited by shajazzi; 4th February 2006 at 17:38.
Reply With Quote
  #58  
Old 4th February 2006, 20:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Can you try this instead?

Code:
mod_gzip_on Yes

<Files .htaccess>
order allow,deny
deny from all
</Files>

ErrorDocument 404 /errordocs/error404.php
ErrorDocument 400 /errordocs/error404.php

DirectoryIndex index.htm

Options +FollowSymlinks +MultiViews


##
# @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
# @package Mambo_4.5
# @copyright (C) 2000 - 2004 Miro International Pty Ltd
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Mambo is Free Software
##

#


# mod_rewrite in use
#
DirectoryIndex index.php

RewriteEngine On

# for apache on windows you might need to uncomment
# this Options line
#Options +SymlinksIfOwnerMatch

# Uncomment following line if your webserver's URL
# is not directly related to physival file paths.
# Update YourMamboDirectory (just / for root)

RewriteBase /
#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) index.php
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #59  
Old 4th February 2006, 21:37
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 3 Times in 3 Posts
Default

Thanks falko,
I tried as you suggested but recieve this error.

Not Found

The requested URL /Contact-Us/ was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.53 (Linux/SUSE) Server at www.englandshirt.com Port 80

In the address I get this

http://www.englandshirt.com/Contact-Us/

I copied the .htaccess that is running on my Windows server but still no joy. I also tried different versions of SEF .I tried about all versions of .htaccess code that I`ve found in the mambo forums but get just slight variations of the same error.

shajazzi
Reply With Quote
  #60  
Old 5th February 2006, 12:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
 
Default

Can you try these?

Code:
mod_gzip_on Yes

<Files .htaccess>
order allow,deny
deny from all
</Files>

ErrorDocument 404 /errordocs/error404.php
ErrorDocument 400 /errordocs/error404.php

DirectoryIndex index.htm

Options +FollowSymlinks +MultiViews


##
# @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
# @package Mambo_4.5
# @copyright (C) 2000 - 2004 Miro International Pty Ltd
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Mambo is Free Software
##

#


# mod_rewrite in use
#
DirectoryIndex index.php

RewriteEngine On

# for apache on windows you might need to uncomment
# this Options line
#Options +SymlinksIfOwnerMatch

# Uncomment following line if your webserver's URL
# is not directly related to physival file paths.
# Update YourMamboDirectory (just / for root)

#RewriteBase /
#
# Rules
#

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*) /index.php



Code:
mod_gzip_on Yes

<Files .htaccess>
order allow,deny
deny from all
</Files>

ErrorDocument 404 /errordocs/error404.php
ErrorDocument 400 /errordocs/error404.php

DirectoryIndex index.htm

Options +FollowSymlinks +MultiViews


##
# @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
# @package Mambo_4.5
# @copyright (C) 2000 - 2004 Miro International Pty Ltd
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Mambo is Free Software
##

#


# mod_rewrite in use
#
DirectoryIndex index.php

# for apache on windows you might need to uncomment
# this Options line
#Options +SymlinksIfOwnerMatch

# Uncomment following line if your webserver's URL
# is not directly related to physival file paths.
# Update YourMamboDirectory (just / for root)

<IfModule mod_rewrite.c>
 RewriteEngine on
 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteCond %{REQUEST_FILENAME} !-d
 RewriteRule ^(.*)$ /index.php?q=$1 [L,QSA]
</IfModule>
Code:
mod_gzip_on Yes

<Files .htaccess>
order allow,deny
deny from all
</Files>

ErrorDocument 404 /errordocs/error404.php
ErrorDocument 400 /errordocs/error404.php

DirectoryIndex index.htm

Options +FollowSymlinks +MultiViews


##
# @version $Id: readme.inc,v 1.3 2005/02/13 18:03:41 marlboroman_2k Exp $
# @package Mambo_4.5
# @copyright (C) 2000 - 2004 Miro International Pty Ltd
# @license http://www.gnu.org/copyleft/gpl.html GNU/GPL
# Mambo is Free Software
##

#


# mod_rewrite in use
#
DirectoryIndex index.php

# for apache on windows you might need to uncomment
# this Options line
#Options +SymlinksIfOwnerMatch

# Uncomment following line if your webserver's URL
# is not directly related to physival file paths.
# Update YourMamboDirectory (just / for root)

<IfModule mod_rewrite.c>
 RewriteEngine on
 RewriteBase /
 RewriteCond %{REQUEST_FILENAME} !-f
 RewriteCond %{REQUEST_FILENAME} !-d
 RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]
</IfModule>
Is your Mambo installation in the top-level directory of your web site, or is it in a subdirectory?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sitebuilder Mahir General 8 10th November 2005 10:19
ispconfig error misterm Installation/Configuration 2 6th September 2005 21:36


All times are GMT +2. The time now is 21:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.