#31  
Old 9th January 2006, 00:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

What's in uid.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #32  
Old 9th January 2006, 00:28
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 2 Times in 2 Posts
Default

User wwwrun
Group www

shajazzi
Reply With Quote
  #33  
Old 9th January 2006, 01:51
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 2 Times in 2 Posts
Red face

I installed another version of Mambo and these are the results of the following:
ls -la /srv/www/web17/web/
ls -la /srv/www/web17/web/administrator/
ls -la /srv/www/web17/web/images/

ls -la /srv/www/web17/web/
total 118
drwxrwxrwx 15 root web17 864 Jan 9 00:37 .
drwxr-xr-x 8 root web17 192 Jan 9 00:29 ..
-rw-rw-rw- 1 root root 32817 Dec 31 19:35 CHANGELOG.php
-rw-rw-rw- 1 root root 4064 Dec 16 19:04 INSTALL.php
-rw-rw-rw- 1 root root 17977 Dec 16 19:04 LICENSE
-rw-rw-rw- 1 root root 454 Dec 16 19:04 README
drwxrwxrwx 9 root root 360 Jan 9 00:30 administrator
drwxrwxrwx 2 root root 80 Jan 9 00:30 cache
drwxrwxrwx 16 root root 504 Jan 9 00:30 components
-rw-r--r-- 1 wwwrun www 2317 Jan 9 00:41 configuration.php
-rw-rw-rw- 1 root root 3725 Dec 16 19:04 configuration.php-dist
drwxrwxrwx 2 root root 272 Jan 9 00:30 editor
drwxrwxrwx 2 root web17 576 Jan 9 00:29 error
-rw-rw-rw- 1 root root 1386 Dec 19 04:23 globals.php
drwxrwxrwx 3 root root 2848 Jan 9 00:30 help
-rw-rw-rw- 1 root root 578 Dec 16 19:04 htaccess.txt
drwxrwxrwx 6 root root 384 Jan 9 00:30 images
drwxrwxrwx 10 root root 1104 Jan 9 00:30 includes
-rw-rw-rw- 1 root web17 1212 Jan 9 00:29 index.html
-rw-rw-rw- 1 root root 6094 Dec 21 21:28 index.php
-rw-rw-rw- 1 root root 3923 Dec 21 21:28 index2.php
drwxrwxrwx 2 root root 184 Jan 9 00:30 language
-rw-rw-rw- 1 root root 453 Dec 16 19:04 mainbody.php
drwxrwxrwx 6 root root 184 Jan 9 00:30 mambots
drwxrwxrwx 2 root root 112 Jan 9 00:42 media
drwxrwxrwx 2 root root 1296 Jan 9 00:30 modules
-rw-rw-rw- 1 root root 2005 Dec 16 19:04 offline.php
-rw-rw-rw- 1 root root 451 Dec 16 19:04 pathway.php
-rw-rw-rw- 1 root root 286 Dec 16 19:04 robots.txt
drwxrwxrwx 4 root root 144 Jan 9 00:30 templates

ls -la /srv/www/web17/web/administrator
total 33
drwxrwxrwx 9 root root 360 Jan 9 00:30 .
drwxrwxrwx 15 root web17 864 Jan 9 00:37 ..
drwxrwxrwx 2 root root 80 Jan 9 00:30 backups
drwxrwxrwx 31 root root 1000 Jan 9 00:30 components
drwxrwxrwx 2 root root 2920 Jan 9 00:30 images
drwxrwxrwx 4 root root 288 Jan 9 00:30 includes
-rw-rw-rw- 1 root root 4144 Dec 16 19:03 index.php
-rw-rw-rw- 1 root root 4155 Dec 16 19:03 index2.php
-rw-rw-rw- 1 root root 5046 Dec 16 19:03 index3.php
-rw-rw-rw- 1 root root 1576 Dec 16 19:03 logout.php
drwxrwxrwx 2 root root 608 Jan 9 00:30 modules
drwxrwxrwx 2 root root 216 Jan 9 00:30 popups
drwxrwxrwx 4 root root 144 Jan 9 00:30 templates


ls -la /srv/www/web17/web/images/
total 38
drwxrwxrwx 6 root root 384 Jan 9 00:30 .
drwxrwxrwx 15 root web17 864 Jan 9 00:37 ..
drwxrwxrwx 2 root root 1080 Jan 9 00:30 M_images
drwxrwxrwx 2 root root 240 Jan 9 00:30 banners
-rw-rw-rw- 1 root root 151 Dec 16 19:04 blank.png
-rw-rw-rw- 1 root root 564 Dec 16 19:04 cancel.png
-rw-rw-rw- 1 root root 1457 Dec 16 19:04 cancel_f2.png
-rw-rw-rw- 1 root root 1406 Dec 16 19:04 favicon.ico
-rw-rw-rw- 1 root root 44 Dec 16 19:04 index.html
-rw-rw-rw- 1 root root 7274 Dec 16 19:04 logo.png
-rw-rw-rw- 1 root root 698 Dec 16 19:04 save.png
-rw-rw-rw- 1 root root 1822 Dec 16 19:04 save_f2.png
drwxrwxrwx 2 root root 256 Jan 9 00:30 smilies
drwxrwxrwx 2 root root 336 Jan 9 00:30 stories

But I still cannot install components or modules

shajazzi
Reply With Quote
  #34  
Old 9th January 2006, 10:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

Please try this:
Code:
chown -R wwwrun:www /srv/www/web17/web
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #35  
Old 9th January 2006, 19:42
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Thanks Falko,
That did the trick OK.
I would like to know what was causing the problem and why chown -R wwwrun:www /srv/www/web17/web fixed it? Just for future reference.

Thanks again and I appreiate your time

Regards
shajazzi
Reply With Quote
  #36  
Old 9th January 2006, 22:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
Default

It was a permissions problem. Apache is running as user wwwrun, and if all directories and files belong to wwwrun instead of root and wwwrun has write permissions (which the owner usually has), then everything is fine.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #37  
Old 18th January 2006, 09:08
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 2 Times in 2 Posts
Default

I have installed modules and components and everything is OK until I try to install phpshop. I checked the Mambo forums and their seems to be a lot of others having a similar problem because of PHP safe mode. I tried many times to install PHP shop manually but it still will not work. Is there a work around for this problem?

shajazzi

Last edited by shajazzi; 5th February 2006 at 23:58.
Reply With Quote
  #38  
Old 18th January 2006, 12:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,414
Thanks: 812
Thanked 5,204 Times in 4,080 Posts
Default

This are known problems with mambo. The only known workaround is disabling PHPSafeMode. But thats a security risk if you host not only your own sites on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #39  
Old 18th January 2006, 22:56
shajazzi shajazzi is offline
Senior Member
 
Join Date: Dec 2005
Posts: 125
Thanks: 2
Thanked 2 Times in 2 Posts
Default

Thanks Till,
When I searched for a php safe mode patch I came across a suggestion that you might be able to install mambo including phpshop onto a windows server and then copy everything to a Linux server therefore avoiding the php safe mode issue.
I am using windows XP Pro with phpMyAdmin 2.5.6 with a couple of sites using phpshop and no problems. On the Linux server i am using Suse 9.3, ISPConfig and under tools PHPmyadmin2.6.4.
I`ve looked at Web-ftp to upload everything from windows to Linux but it looks as if you can only upload one file at a time.I am not familiar with ftp, maybe i am missing something here.

These are my questions:

1. Do I need to downgrade to phpmyadmin 2.6.4 from 2.5.6 in Linux?

2. Can I Zip the windows xp pro web and the phpmyadmin folders to a disc and then just paste them into the Linux folders?

3. If no to question 2 how do I ftp Folders from windows to Linux?


shajazzi
Reply With Quote
  #40  
Old 19th January 2006, 07:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,721 Times in 2,562 Posts
 
Default

Quote:
Originally Posted by shajazzi
Thanks Till,
When I searched for a php safe mode patch I came across a suggestion that you might be able to install mambo including phpshop onto a windows server and then copy everything to a Linux server therefore avoiding the php safe mode issue.
I can't imagine how this is supposed to work...


Quote:
Originally Posted by shajazzi
1. Do I need to downgrade to phpmyadmin 2.6.4 from 2.5.6 in Linux?
I don't think phpMyAdmin has anything to do with your problem...

Quote:
Originally Posted by shajazzi
2. Can I Zip the windows xp pro web and the phpmyadmin folders to a disc and then just paste them into the Linux folders?
Yes. You can also transfer the zip file to your server using FTP (or WinSCP) and then unzip it there again.

Quote:
Originally Posted by shajazzi
3. If no to question 2 how do I ftp Folders from windows to Linux?
Why don't you use a "real" FTP client like WS_FTP or SmartFTP? Then you can transfer directories, multiple files, etc. And you don't need to copy your files to a disc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sitebuilder Mahir General 8 10th November 2005 09:19
ispconfig error misterm Installation/Configuration 2 6th September 2005 20:36


All times are GMT +2. The time now is 10:24.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.