Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd January 2008, 10:38
dimitar dimitar is offline
Member
 
Join Date: Mar 2007
Posts: 64
Thanks: 1
Thanked 0 Times in 0 Posts
Unhappy httpd syntax seems to contain errors, reloading with old configuration

Hi all,

happy new 2008!

i have a little problem here on 1 of my servers running debian etch 32bit and ispconfig 2.2.18

on the server there are more than 300 sites, but lastly after i added a new domain i got shared IP page when trying to access it via web (the domain points to the server).

in the ispconfig log i found these disturbing lines:
Code:
02.01.2008 - 10:20:39 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2447: WARNING: could not httpd -t  &> /dev/null
02.01.2008 - 10:20:39 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2458: httpd syntax seems to contain errors, reloading with old configuration
... but after running httpd -t manually there is no error, only warning:
Code:
[Wed Jan 02 10:35:11 2008] [warn] VirtualHost 192.168.0.110:80 overlaps with VirtualHost 192.168.0.110:80, the first has precedence, perhaps you need a NameVirtualHost directive
Syntax OK
... running /root/ispconfig/php/php -q /root/ispconfig/scripts/writeconf.php gives back:
Code:
start
ende
do you have any suggestions?

Thanks!

best regards
Reply With Quote
Sponsored Links
  #2  
Old 2nd January 2008, 11:18
madmucho madmucho is offline
Senior Member
 
Join Date: Oct 2006
Location: Czech republic, Karlovy Vary
Posts: 158
Thanks: 78
Thanked 11 Times in 11 Posts
Send a message via ICQ to madmucho
Default

Thats looks like you have same virtual domain twice.
Try to parase saved configuration vhost....ispconfig saves changes to separate file before reload last working configuration..
Reply With Quote
  #3  
Old 2nd January 2008, 11:29
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

You will have to rename the vhost configuration file before you run httpd -t as described here:

http://www.howtoforge.com/forums/showthread.php?t=13596
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 2nd January 2008, 11:54
dimitar dimitar is offline
Member
 
Join Date: Mar 2007
Posts: 64
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Thanks,

i have used the post you pasted and followed it.
The problem was that i had an apache optional directive with typo error.

Regards
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache / httpd restart / startup failed without errors Aldert Server Operation 11 30th January 2008 17:11
Beyrl and Ubuntu 7.04 Toriacht Desktop Operation 17 23rd June 2007 21:40
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 03:38
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 21:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.