Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th December 2005, 15:57
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Unhappy SSH Remote Login Not Working Anymore!

For several months, I was able to login to my ssh account without any problems. I changed the default port to xxxx (do not want to reveal this port for security reasons).

Anyways, a couple days ago, I restarted my server, and now, I am unable to login to the SSH server. I am 100% sure I am connecting to the right port and ip address. I am also sure that the port is open to connections. I know this because I can go to to a port scanning site and it says that the ssh port is open.

I checked the sshd_config settings and the correct port is open.

What other settings should I check?
Reply With Quote
Sponsored Links
  #2  
Old 29th December 2005, 16:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

If you run "netsat -tap", is your sshd daemon listed there, listening on your custom port?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th December 2005, 16:22
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

it shows the following:

tcp 0 0 *:xxxx <--this is my custom port *:* LISTEN 1928/sshd

Is that right?
Quote:
Originally Posted by till
If you run "netsat -tap", is your sshd daemon listed there, listening on your custom port?
Reply With Quote
  #4  
Old 29th December 2005, 16:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Does your firewall maybe block that port?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 29th December 2005, 16:56
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

To the best of my knowledge, it looks like the port is open and there is no firewall that is blocking that port.

Is there a way for me to verify this?

Quote:
Originally Posted by falko
Does your firewall maybe block that port?
Reply With Quote
  #6  
Old 29th December 2005, 18:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by kisong
To the best of my knowledge, it looks like the port is open and there is no firewall that is blocking that port.

Is there a way for me to verify this?
Please post the output of
Code:
iptables -L
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 30th December 2005, 21:45
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Default

PAROLE tcp --anywhere anywhere tcp dpt:ssh


That's not the whole output, but I think this should suffice.

Quote:
Originally Posted by falko
Please post the output of
Code:
iptables -L
Reply With Quote
  #8  
Old 30th December 2005, 21:54
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
Talking Solved!!

SOLVED. I added the xxxx SSH port to be opened within ISPConfig.

How did this setting get changed? Removed? Destroyed?

Does this happen every time the server is restarted?

Quote:
Originally Posted by kisong
PAROLE tcp --anywhere anywhere tcp dpt:ssh


That's not the whole output, but I think this should suffice.
Reply With Quote
  #9  
Old 31st December 2005, 00:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by kisong
SOLVED. I added the xxxx SSH port to be opened within ISPConfig.

How did this setting get changed? Removed? Destroyed?
What do you mean with that? You changed the SSH port, but you cannot expect the firewall to recognize that and adjust itself to the new port...

Quote:
Originally Posted by kisong
Does this happen every time the server is restarted?
If you've enabled the ISPConfig firewall, it will be started whenever the server boots (of course, with the settings you specified in the web interface). Just make sure that your system doesn't start a second firewall that interferes with the ISPConfig firewall.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 3rd January 2006, 16:34
kisong kisong is offline
Member
 
Join Date: Oct 2005
Posts: 63
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

The reason I said this is because prior to restarting the server, the port was set to xxxx and the firewall for ISPConfig was set to the same port (again, I'm hiding the actual port number for security reasons).

Before restarting the server, I was able to login with no problems.

The problem started when I restarted the server. Somehow, ISPConfig lost the firewall settings I set and replaced it with a default firewall setting.

Does that make sense?

Quote:
Originally Posted by falko
What do you mean with that? You changed the SSH port, but you cannot expect the firewall to recognize that and adjust itself to the new port...


If you've enabled the ISPConfig firewall, it will be started whenever the server boots (of course, with the settings you specified in the web interface). Just make sure that your system doesn't start a second firewall that interferes with the ISPConfig firewall.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot login via ssh after installation sone Installation/Configuration 40 2nd March 2007 18:29
Webconfig at port 81 not working anymore maxx Installation/Configuration 6 23rd October 2006 11:23
Sending mails to remote domains is not working. nandhu HOWTO-Related Questions 17 20th February 2006 21:27
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 19:11
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 00:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.