Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th December 2007, 20:44
Alam Alam is offline
Junior Member
 
Join Date: May 2006
Posts: 23
Thanks: 3
Thanked 0 Times in 0 Posts
Default Rewrite URL In apache2

Hello All,

I am using ISPConfig on ubuntu gusty with apache2,squirrelmail installed as an addon in ispconfig, I need some help please with URL rewrite. If I can I would like to avoid adding a co-domain in ispconfig no specific reason thats the way I want it to be.

At the minute to access my webmail I have to do this

https://www.abc.co.uk:81/squirrelmail and that redirects to https://www.abc.co.uk:81/src/login.php

but what i want it to redirect it to (through apache2)

https://www.abc.co.uk/webmail.

Also I want it done once, I do not want to it for every domain on my server, hence other customers if they want to access there webmail simply type https:// theredomain.name/webmail and through to there webmail from there.

I have read about it on different webites, forums including apache and this (seems quite an old thread here) but have not been able to solve the mystery.

I cannot understand how it is done it seems hard.

Any help on this with examples would be really appreciated.

Thank you very much in advance. Looking forward for positive response.
Reply With Quote
Sponsored Links
  #2  
Old 25th December 2007, 11:06
mccharlet mccharlet is offline
Senior Member
 
Join Date: Feb 2007
Posts: 261
Thanks: 63
Thanked 11 Times in 7 Posts
Default

I have redirected http://all_domain/webmail to https://domain:81/squirrelmail

I have add in the file /etc/apache2/sites-enabled/000-default

Redirect /webmail https://domain:81/squirrelmail/
__________________
Thanks
Cédric

Sorry for my english

Hosting : http://www.jheberge.ch
Reply With Quote
The Following User Says Thank You to mccharlet For This Useful Post:
Alam (25th December 2007)
  #3  
Old 25th December 2007, 13:32
Alam Alam is offline
Junior Member
 
Join Date: May 2006
Posts: 23
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by mccharlet
I have redirected http://all_domain/webmail to https://domain:81/squirrelmail

I have add in the file /etc/apache2/sites-enabled/000-default

Redirect /webmail https://domain:81/squirrelmail/
Hi

Thank you very much for the reply I tried but did'nt work, just a quick one did you add the line before virtual host or between virtual host also sorry if it sounds stupid do u replaced domain with real domain name
Reply With Quote
  #4  
Old 25th December 2007, 14:57
mccharlet mccharlet is offline
Senior Member
 
Join Date: Feb 2007
Posts: 261
Thanks: 63
Thanked 11 Times in 7 Posts
Default

are you restarted apache2?
__________________
Thanks
Cédric

Sorry for my english

Hosting : http://www.jheberge.ch
Reply With Quote
The Following User Says Thank You to mccharlet For This Useful Post:
Alam (25th December 2007)
  #5  
Old 25th December 2007, 18:11
Alam Alam is offline
Junior Member
 
Join Date: May 2006
Posts: 23
Thanks: 3
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by mccharlet
are you restarted apache2?
Hi

Thankyou very much for your support that worked for me. You are a star
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SSI with Apache2 on Debian jchaven Server Operation 7 25th August 2008 17:06
Apache2: German umlauts in URL? Pasco General 1 15th May 2007 11:08
Web server offline after php4 and apache2 upgrade dfriis Installation/Configuration 11 7th December 2006 16:14
Drupal and Apache Rewrite Rules andre Server Operation 10 4th May 2006 21:04
Big problem with apache2 on Ubuntu piratta Installation/Configuration 2 18th January 2006 17:29


All times are GMT +2. The time now is 17:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.