Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 31st December 2008, 12:11
runbuck runbuck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Default Dnydns.org URL Resolved To Shared IP Page

Greetings, trying to get an existing site that used to use a static URL to now work via timbauer.dnydns.org. Tried various things (tinkered with DNS Server entries in ISPConfig, added various website / co domain combinations) but it keeps coming back to the shared IP page instead of the website.

ifconfig shows this

Quote:
eth0 Link encap:Ethernet HWaddr 00:30:1b:ae:2a:81
inet addr:192.168.0.188 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::230:1bff:feae:2a81/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1011769 errors:0 dropped:0 overruns:0 frame:0
TX packets:1025874 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:211169126 (201.3 MB) TX bytes:282002656 (268.9 MB)
Interrupt:16 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1167189 errors:0 dropped:0 overruns:0 frame:0
TX packets:1167189 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:117707941 (112.2 MB) TX bytes:117707941 (112.2 MB)
my Vhosts_ispconfig.conf shows this (where dnydns.org is the entry of the site I am twiddling with in ISPConfig).

Quote:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 192.168.0.1:80
<VirtualHost 192.168.0.1:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 192.168.0.188:80
<VirtualHost 192.168.0.188:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.dnydns.org:80
######################################
#
#
<VirtualHost 192.168.0.188:80>
ServerName www.dnydns.org:80
ServerAdmin webmaster@dnydns.org
DocumentRoot /var/www/web1/web
ServerAlias dyndns.com timbauer.dnydns.org
DirectoryIndex index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
#
#
#
######################################
# Vhost: www.leveragency.com:80
######################################
#
#
<VirtualHost 192.168.0.188:80>
ServerName www.leveragency.com:80
ServerAdmin webmaster@leveragency.com
DocumentRoot /var/www/web10/web
ServerAlias leveragency.com
DirectoryIndex index.php
ErrorLog /var/www/web10/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/var/www/web10/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web10/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web10/user/$1/web/$3
</VirtualHost>
#
#
#
#
######################################
# Vhost: www.runbuck.com:80
######################################
#
#
<VirtualHost 192.168.0.188:80>
ServerName www.runbuck.com:80
ServerAdmin webmaster@runbuck.com
DocumentRoot /var/www/web9/web
ServerAlias www.runbuck.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /var/www/web9/log/error.log
Alias /error/ "/var/www/web9/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web9/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web9/user/$1/web/$3
</VirtualHost>
#
#
httpd -t gives this (note, per other posts on web, I made the change in apache.conf to hardcode to www-data to fix the httpd: bad user name ${APACHE_RUN_USER} error)

Quote:
Syntax OK
The tail of my apache2.conf (where my ISPConfig edits were outside of the error above) is as follows:

Quote:
# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
Include /etc/apache2/conf.d/

# Include the virtual host configurations:
Include /etc/apache2/vhosts/Vhosts_ispconfig.conf
Include /etc/apache2/sites-enabled/
Any thoughts?
Reply With Quote
Sponsored Links
  #2  
Old 31st December 2008, 12:37
runbuck runbuck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
Default Clarification

Note, the other sites defined in ISPConfig work fine (i.e. www.leveragency.com). I have also checked the DNS Server entries between the working site and the non-working site and they seem to be similar.

Is the redirect from dnydns.com doing an IP based redirect (in which case ISPconfig wouldn't have a URL to resolve to the proper site with?). I poked around but couldn't find a log from apache to show me the URL's requests coming in to see if it was a raw IP. I assume that isn't the case as I believe the URL comes as well.
Reply With Quote
  #3  
Old 31st December 2008, 13:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,373
Thanks: 833
Thanked 5,478 Times in 4,313 Posts
Default

Please make sure that you do not use a redirect at dyndns.org, you need a dns A-Record at dyndns.org. DNS Records from dyndns.org are working fine with ispconfig.

Also the domain for thw site is wrong. I'am pretty sure you do not won the domain www.dyndns.org. You will have to enter your dyndns subdomain instead of www.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 31st December 2008, 13:16
runbuck runbuck is offline
Junior Member
 
Join Date: Nov 2007
Posts: 16
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default My Bad

*** FIXED ****

I had a typo in the name ... DOH! dyndns.org NOT dnydns.org.

I nuked the DNS records as well. Set the hostname to 'timbauer' and domain to 'dyndns.org' per your comments.

Sorry.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
dovecot problem sojic Server Operation 21 23rd March 2008 18:22
Shared IP page tjadrian Installation/Configuration 8 20th January 2008 19:02
not seeing shared IP page andyreynolds Installation/Configuration 2 21st February 2007 23:24
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 12:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.