#11  
Old 8th January 2006, 14:28
senzapaura senzapaura is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks to Till and Falko for your help.

I do use the excellent howtos at howtoforge to install Suse 10 and Ispconfig. Without them I would be unable to begin learning the process for setting up an ISP. Most of my frustrations are caused by “operator error” and the fact I am in a learning phase.

My problem with the changing web site names is I am using Dreamweaver to program and implement the web site. In order to help me keep things straight, I setup a web1 (or webx) user to access the server for publishing and testing the site. Admittedly this is probably my problem, I must figure out a better way to coordinate these packages.

Unfortunately when I originally setup the certificate for the www.amg01.info domain I installed it with a passphrase. I will reissue the certificate when everything is working. My entering the passphrase when rebooting apache2 is not a major problem at this time. I was concerned that I entered the certificate correctly and the fact that apache2 recognizes it makes me think I did it correctly.

The Firefox alert message I get is: The operation timed out when attempting to contact www.amg01.info.

IE alert through Microsoft Word when trying to connect to the https side is: Unable to open https://www.amg01.info/ Cannot locate the Internet server or proxy server.

You should be able to access the site using: http://www.amg01.info and then try https://www.amg01.info and get the same error message.

Thanks again.
Reply With Quote
Sponsored Links
  #12  
Old 8th January 2006, 15:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,176
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Quote:
Originally Posted by senzapaura
My problem with the changing web site names is I am using Dreamweaver to program and implement the web site. In order to help me keep things straight, I setup a web1 (or webx) user to access the server for publishing and testing the site. Admittedly this is probably my problem, I must figure out a better way to coordinate these packages.
I'am using dreamweaver too for managing my sites. I do not enter a sitename at all in dreamweaver. Can you describe where you get the problems with using dreamweaver and i will try to help you.

Quote:
Unfortunately when I originally setup the certificate for the www.amg01.info domain I installed it with a passphrase. I will reissue the certificate when everything is working. My entering the passphrase when rebooting apache2 is not a major problem at this time. I was concerned that I entered the certificate correctly and the fact that apache2 recognizes it makes me think I did it correctly.

The Firefox alert message I get is: The operation timed out when attempting to contact www.amg01.info.

IE alert through Microsoft Word when trying to connect to the https side is: Unable to open https://www.amg01.info/ Cannot locate the Internet server or proxy server.

You should be able to access the site using: http://www.amg01.info and then try https://www.amg01.info and get the same error message.
If you want to add an SSL enabled site in ISPConfig, check the SSL checkbox on the basis tab. Then save the website. If you pen it again, ypu have a new SSL tab, where you can enter the details for thecertificate, there you can chose "Create certificate" and ISPConfig does all the steps nescessary for creating a valid cert for you.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 9th January 2006, 15:07
senzapaura senzapaura is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is what I think is happening for the Dreamweaver issue.

When I set-up a remote site for publishing my web application in Dreamweaver, I also setup a user. This user must have all the appropriate privileges for the particular site in order for me to publish and test (I also setup the server as a test server). Since I have multiple virtual sites on the web server, I use multiple users identified in Dreamweaver (and the operating system) as user web1, web2 and so forth. I set-up a user based on the virtual host directory, that is if my site in ISPConfig is web1 I have a web1 user, but if I reinstall (using ISPConfig) I may get the web site identified as web3 (because I made mistakes setting up the site). When this happens then the Dreamweaver interface will not connect to the server for publishing or as a test server unless I fix all permissions for the Dreamweaver user or create a new user. I setup multiple users to protect one user site from another based on the operating systems permissions. Theoretically each web site could be maintained by a different developer each one protected from the others. Maybe there is a better way to do this or maybe I do not understand things correctly.

This is what I think for the https issue.

After, I applied and received the certificate from the CA. I used the information to install from ISPConfig. Then I copied the .crt and .key files to the appropriate directory. I thought I read somewhere in this forum that was the procedure to use if you already had the .crt and .key files. If my .crt and .key files are in the correct directory and they are specified in the /etc/apache2/vhosts/Vhosts_ispconfig.conf shouldn’t I be able to access the virtual host?
Reply With Quote
  #14  
Old 9th January 2006, 19:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by senzapaura
This is what I think is happening for the Dreamweaver issue.

When I set-up a remote site for publishing my web application in Dreamweaver, I also setup a user. This user must have all the appropriate privileges for the particular site in order for me to publish and test (I also setup the server as a test server). Since I have multiple virtual sites on the web server, I use multiple users identified in Dreamweaver (and the operating system) as user web1, web2 and so forth. I set-up a user based on the virtual host directory, that is if my site in ISPConfig is web1 I have a web1 user, but if I reinstall (using ISPConfig) I may get the web site identified as web3 (because I made mistakes setting up the site). When this happens then the Dreamweaver interface will not connect to the server for publishing or as a test server unless I fix all permissions for the Dreamweaver user or create a new user. I setup multiple users to protect one user site from another based on the operating systems permissions. Theoretically each web site could be maintained by a different developer each one protected from the others. Maybe there is a better way to do this or maybe I do not understand things correctly.
For each web site you must create an admin user in ISPConfig, and then you can use this admin user in Dreamweaver to connect to the site with FTP. The web site IDs do not have to be the same on different ISPConfig installations, as you've already recognized.

Quote:
Originally Posted by senzapaura
This is what I think for the https issue.

After, I applied and received the certificate from the CA. I used the information to install from ISPConfig. Then I copied the .crt and .key files to the appropriate directory. I thought I read somewhere in this forum that was the procedure to use if you already had the .crt and .key files. If my .crt and .key files are in the correct directory and they are specified in the /etc/apache2/vhosts/Vhosts_ispconfig.conf shouldn’t I be able to access the virtual host?
Normally you check the SSL check box on a web site's "Basis" tab in ISPConfig, then you go to the SSL tab and create a new certificate. You copy the csr (certificate signing request) from the text box and send it to your CA which then sends you an official certificate which you copy into the certificate text box. You save that certificate, and you're finished.

However, I get the impression that your Apache isn't able to speak https because of missing modules. Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 9th January 2006, 22:30
senzapaura senzapaura is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am not sure, but it looks like apache2 is trying to speak https?
amgsrv1:~ # netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 4085/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 3801/portmap
tcp 0 0 *:hosts2-ns *:* LISTEN 3391/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 21272/proftpd: (acc
tcp 0 0 amgsrv1.anthem-g:domain *:* LISTEN 4076/named
tcp 0 0 localhost:domain *:* LISTEN 4076/named
tcp 0 0 *:smtp *:* LISTEN 29228/master
tcp 0 0 localhost:953 *:* LISTEN 4076/named
tcp 0 0 *:www-http *:* LISTEN 5754/httpd2-prefork
tcp 0 0 *:ssh *:* LISTEN 4008/sshd
tcp 0 0 *:smtp *:* LISTEN 29228/master
tcp 0 0 localhost:953 *:* LISTEN 4076/named
tcp 0 0 *:https *:* LISTEN 5754/httpd2-prefork
tcp 0 148 amgsrv1.anthem-grou:ssh 192.168.3.10:ttntspauto ESTABLISHED 2414/0
amgsrv1:~ #
Reply With Quote
  #16  
Old 9th January 2006, 23:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by senzapaura
I am not sure, but it looks like apache2 is trying to speak https?
Yes, looks like that... But it's possible that Apache is configured to listen on port 443, but without SSL support...
Which distribution are you using? Did you follow any of the "Perfect Setup" tutorials?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 10th January 2006, 13:47
senzapaura senzapaura is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I followed the perfect setup described in howtoforge for a Suse 10 implementation. I tried to setup apache2 and PHP5 as described starting on page 5 of this perfect setup.

Version Apache/2.0.54 (Linux/SUSE)s -

While checking to see how apache was running I executed the following commands, trying to make sure ssl was running. The results follow:

amgsrv1:~ # /etc/init.d/apache2 stop
Shutting down httpd2 (waiting for all children to terminate) done
amgsrv1:~ # /etc/init.d/apache2 startssl
Starting httpd2 (prefork) Apache/2.0.54 mod_ssl/2.0.54 (Pass Phrase Dialog)
Some of your private key files are encrypted for security reasons.
In order to read them you have to provide us with the pass phrases.

Server www.amg01.info:443 (RSA)
Enter pass phrase:

Ok: Pass Phrase Dialog successful.
done
amgsrv1:~ # /etc/init.d/apache2 configtest
Syntax OK

It looks OK to me but maybe you can see a problem. In fact it looks to me like it is supposed to be going to SSL for the server I am trying to reach via SSL.
I have tried looking at the SSL certificate using the openssl command. Maybe I have a mistake here?

Thanks for hanging in there and helping.
Reply With Quote
  #18  
Old 10th January 2006, 13:55
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,176
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Why have you created encrypted SSL certificates. Its not described in the howto and this is what stops your server. Remove the config part that that you added which is not described in the howto. ISPConfig will manage the SSL certs for you properly.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 13th January 2006, 02:33
senzapaura senzapaura is offline
Junior Member
 
Join Date: Nov 2005
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am sorry, I do not understand what you are asking me to do?
Reply With Quote
  #20  
Old 13th January 2006, 11:23
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,176
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
 
Default

Have you followed the SuSe 10 howto to the letter or did you do any additional configuration?

How have you added this SSL certificate?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 09:35
problems mysql rayit General 15 1st April 2006 04:57
2 Questions (1 SSL Related and 1 dns forward related) phamels Installation/Configuration 11 4th January 2006 01:33
Debian 3.1 Related problems! AdykOSu Installation/Configuration 1 21st December 2005 22:32
Problems getting through the installation klausagnoletti Installation/Configuration 4 26th September 2005 12:23


All times are GMT +2. The time now is 18:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.