Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th December 2007, 00:53
asymetrixs asymetrixs is offline
Junior Member
 
Join Date: Nov 2007
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy postfix+ mysql and /var/spool/postfix problem

hi,

first of all i used the follwing howto for my mailserver which did a really good job (using etch and postfix and so on...):
http://www.howtoforge.com/proftpd_my...ng_debian_etch

but i wondered about my mailserver, because it didn't send my system mails anymore since i configured postfix to use mysql for user and quota administration and to send the mails to an external address (my home address and not to the an system user in the debian system)

all system mails sent by the system itself or the administrator are stored in /var/spool/postfix, but this directory isn't mentioned in the actual config of postfix.

Code:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = **masked**.ath.cx
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/spool/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_reci$
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
and the /var/log/mail.err gives me the following:
Code:
postfix/postqueue[11574]: fatal: Queue report unavailable - mail system is down
so i think, that the following line is missing in the main.cf:
Code:
queue_directory = /var/spool/postfix
but if i add this line and restart postfix, it has no influence on the behaviour of the mailsystem.

the mailsystem itself works great with the user and quota settings stored in the mysql tables, but the system mailqueue seems to be ignored.

can someone help me please?

thank you all.
Reply With Quote
Sponsored Links
  #2  
Old 20th December 2007, 16:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Are there any other errors in your mail log?

You can check the settings that you see in the output of
Code:
postconf -d
These are the default settings that are unless something else is specified in /etc/postfix/main.cf.

If you want to forward system emails to an external email account, you can modify /etc/aliases, e.g.:
Code:
root: you@yourdomain.com
Run
Code:
newaliases
afterwards and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
Issues with Postfix using "Virtual Users And Domains With Postfix, Courier And MySQL" Kyse HOWTO-Related Questions 15 6th January 2007 15:35
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36
Postfix Problem rlhesson Installation/Configuration 2 9th August 2006 03:49
Postfix + Fedora Core 5 64Bit - Problem GrBase HOWTO-Related Questions 5 7th August 2006 13:41


All times are GMT +2. The time now is 16:57.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.