Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th December 2007, 11:36
dschmid dschmid is offline
Member
 
Join Date: Dec 2005
Posts: 52
Thanks: 1
Thanked 1 Time in 1 Post
Default converting vmware vmdk to xen - config problem

Hello, I've followed the instructions from perfect xen howto for etch on a pacifica platform. I expanded it to use sw raid5 and lvm on it. Creating multiple domUs using debootstrap isn't a problem. But I can't find out howto convert an existing etch vmware image to an domU xen lvm. I followed this http://ian.blenke.com/vmware/vmdk/xen/hvm/qemu
Howto and done:

1. vmware-vdiskmanager -r etch.vmdk -t 0 etch-flattened.vmdk

2. qemu-img convert etch-flattened.vmdk etch.img

3. lvcreate -L 8G -n etch-hda raid

4. dd if=etch.img of=/dev/raid/etch-hda bs=1M

5. cp /etch/xen/otherxen.mydomain.local.cfg /etch/xen/etch.mydomain.local.cfg

6. Then I changed in the new config file the this variables:

disk = [ 'phy:raid/etch-hda,sda1,w' ]

name = 'etch.mydomain.local'

vif = [ 'ip=192.168.1.110' ]


When I now try to start the domain with

xm create /etc/xen/etch.mydomain.local

the output is:

Code:
Using config file "/etc/xen/etch.mydomain.local.cfg".
Started domain etch.mydomain.local
But an
Code:
xm list
don't show up the domain and I can't connect to it using xm console ...

cat /var/log/xen/xend.log gives me some errors telling me the domain is already running - see atachment.

I hope somebody had succesfully converted an vmdk to xen. Because I can't find something usefull on google
Attached Files
File Type: txt xend.log.txt (12.8 KB, 396 views)
Reply With Quote
Sponsored Links
  #2  
Old 5th March 2008, 09:07
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 12 Times in 10 Posts
 
Default

I followed some link once on converting vmware using qemu.
I tried the trixbox vmware image and had issues getting the server started.

What i had to go to get it working was mount the image locally, then copy the kernel module version I wanted to use into the /lib/modules/kernel.x.x.x.xen/ and then chroot to the root filesystem of that image and then run mkinitrd to create a new initrd.

it worked when started it but I noticed is that it never worked from command line and only through virt-manager.. weird but there's some difference in the way 'xm create' and virt-manager start their domU's.

PHP Code:
kernel "/boot/vmlinuz-2.6.18-53.1.4.el5xen"
# new initrd
ramdisk "/boot/2.6.18-53.1.4.el5xen-trixbox.img"
uuid "7a9dbaa3-ad6c-bad3-b515-806bd0e37320"
memory 128
vif 
= [ "mac=00:16:29:36:e3:c4, bridge=xenbr0" ]
vfb = [ "type=vnc,vncdisplay=10,vncpasswd=trixbox" ]
root "/dev/sda1 ro"
disk = [ "file:/xen/trixbox/trixbox2.4.img,sda,w" ]
name "trixbox"
#bootloader="/usr/bin/pygrub"
on_poweroff "destroy"
on_reboot "restart"
on_crash "restart"
maxmem 256 
__________________
www.emperor-it.com for ISPConfig mods/hacks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
VMware Server install problem - Pls Help! joelee HOWTO-Related Questions 2 5th June 2007 11:43
Anyone figured out to integrate FuzzyOCR into ISPConfig on Ubuntu? friday Installation/Configuration 16 10th May 2007 16:25
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09
VMWare install on Ubuntu problem with the IP velonis HOWTO-Related Questions 10 21st September 2006 14:19


All times are GMT +2. The time now is 17:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.