Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st March 2006, 13:07
saul saul is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Default it didn't work in the end..

hi falco,

thanks for all your help and feedback

I'm giving this one up - I thought it would work to increase the open files allowance in the way I described above, but I'm still having lots of problems.. the same errors after the system runs for a while... so scratch that earlier advice!

I've re-installed my server with a 32bit system and I'm starting from scratch.

fingers crossed!

Cheers,

Saul.

Last edited by saul; 1st March 2006 at 13:09.
Reply With Quote
Sponsored Links
  #12  
Old 1st March 2006, 22:18
burtathis burtathis is offline
Junior Member
 
Join Date: Feb 2006
Location: Athis-Mons, France
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default same problem !

Hi,

I don't know if it's good news for you but i had exactly the sames problem.
The first one about quota, i solve it with recompiling the kernel with quota support.

the second one, the weird "forbidden" problem i just put the finger on it !

I have a mac mini 1.42Ghz and i used the ubuntu perfect setup howto.

I put it in the DMZ and i disabled the firewall with ispconfig interface.

Another problem is that i can access this ispconfig interface by the port 81 from outside, but the pages don't seems to open well : there is errors with downloading images in the central frame so the browser can't finish opening them.

I access the interface with ssl enabled.

I start my "forum crowler" night !

see you soon ...

Last edited by burtathis; 1st March 2006 at 22:22.
Reply With Quote
  #13  
Old 1st March 2006, 22:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Quote:
Originally Posted by burtathis
Hi,

I don't know if it's good news for you but i had exactly the sames problem.
The first one about quota, i solve it with recompiling the kernel with quota support.

the second one, the weird "forbidden" problem i just put the finger on it !

I have a mac mini 1.42Ghz and i used the ubuntu perfect setup howto.

I put it in the DMZ and i disabled the firewall with ispconfig interface.
Which browser do you use on your mac mini? Please try to connect with firefox or camino and check if the problems remain.

Quote:
Another problem is that i can access this ispconfig interface by the port 81 from outside, but the pages don't seems to open well : there is errors with downloading images in the central frame so the browser can't finish opening them.
I guess you have an URL to the controlpanel in the config.inc.php file that can be only resolved from inside your network? Try to change the url in config.inc.php to an URL that points to your external IP.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 1st March 2006, 23:35
burtathis burtathis is offline
Junior Member
 
Join Date: Feb 2006
Location: Athis-Mons, France
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Which browser do you use on your mac mini? Please try to connect with firefox or camino and check if the problems remain.
I use firefox and safari on two macs : one in the local network and one outside. always the same behavior : you can see the website quietly for a moment but at one time the forbidden message appear randomly.

you can check by yourself here :
http://gastfall.org or http://www.gastfall.org


It is a "healthy" solution to allow more files opened ?
What is the "by default" maximum ?

Quote:
Originally Posted by till
I guess you have an URL to the controlpanel in the config.inc.php file that can be only resolved from inside your network? Try to change the url in config.inc.php to an URL that points to your external IP.
You are wright !
I put the wan IP instead : one problem solved, thanks !

By the way, it didn't change the "forbidden" pb... i still digging!
Reply With Quote
  #15  
Old 2nd March 2006, 08:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,483
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
Default

Please check this file for errors:

/root/ispconfig/httpd/logs/error_log
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 2nd March 2006, 09:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by burtathis
you can check by yourself here :
http://gastfall.org or http://www.gastfall.org
I can't connect at all. Seems to be a DNS problem.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #17  
Old 2nd March 2006, 14:54
saul saul is offline
Junior Member
 
Join Date: Feb 2006
Posts: 9
Thanks: 3
Thanked 0 Times in 0 Posts
Default trying again with 64bit system

Well it was quite comical that at 6pm - on the day I posted that I was giving up running ispconfig on the 64bit system - then spending the whole day reinstalling debain3.1 for 32bit, installing Perfect Setup 3.1, re-installing ispconfig etc.. etc. I get a message that the new version of ispconfig is out - with 64bit support!

Anyway - since it's so easy to set up, and I'm getting good at it now! I'll test whether the problem with too many open files and random 403s (+ patchily loading images due to - I assume random 403s on each image as the system opened too many files - these were my symptoms). was to do with running a 64bit system.

It seems this problem is common to some macs and to the amd64 bit hardware I'm running it on - because the symptoms are identical. It looked, at first like dns or permissions issues to me too, but the givaway (which mentioned running out of open file quota) was in the individual site logs - not in the ispconfig main logs..

I've just re-installed debian and am half way through the perfect 3.1 install on a 64bit system. I'll let you know if I have the same problem as before with the new version of ispconfig.

I really hope not! I think I'll be tearing my hair out after the 3rd install in 3 days

Cheers,

Saul.
Reply With Quote
  #18  
Old 2nd March 2006, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by saul
I've just re-installed debian and am half way through the perfect 3.1 install on a 64bit system. I'll let you know if I have the same problem as before with the new version of ispconfig.
I tested ISPConfig 2.2.0 on Debian Sarge AMD64 and didn't have any problems.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 2nd March 2006, 16:42
burtathis burtathis is offline
Junior Member
 
Join Date: Feb 2006
Location: Athis-Mons, France
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi !
Because i passed too much time to adjust all this stuff like a blind man (i added more pb to my first one!), i'll ask one basic questions :
  • I bought a domain name "gastfall.org" at ovh.com :
    In there configuration pane i put 3 entries :
    .gastfall.org MX1 (ORT redirect)
    .gastfall.org A 82.227.0.130 (my external ip)
    www.gastfall.org A 82.227.0.130
  • I put in ispconfig interface in server, settings :
    server name=chocobox ; hostname=www ; domain=192.168.0.5 ; ip=192.168.0.5 ; netmask=255.255.255.0.
    And in DNS :
    Default Ns1: 82.227.0.130 ; Default Ns2: 82.227.0.130.
  • I made a new client and a new site in ispconfig interface (with 2 users) :
    -In basis, i put hostname=www ; domain=gastfall.org ; create DNS and DNS-MX.
    -In co-domains, i add an entry without hostname and domain=gastfall.org and create DNS and DNS-MX.

Please, tell me if i am wrong for all that adjustments ?

Saul, thanks in advance for digging the "forbidden pb" !
I have the idea that the two configurations ppc and 64bit needed to recompile the kernel to add quota support, so perhaps, the problem deals with quota ?

I'll tell everybody if i find something !
Reply With Quote
  #20  
Old 2nd March 2006, 17:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Quote:
Originally Posted by burtathis
.gastfall.org MX1 (ORT redirect)
Your mail will be handled by redirect.ovh.net - it is ok like that if you intend it like this.
Quote:
Originally Posted by burtathis
.gastfall.org A 82.227.0.130 (my external ip)
www.gastfall.org A 82.227.0.130
Ok.

Quote:
Originally Posted by burtathis
I put in ispconfig interface in server, settings :
server name=chocobox ; hostname=www ; domain=192.168.0.5 ; ip=192.168.0.5 ; netmask=255.255.255.0.
As domain you should use a domain, not an IP address.
Quote:
Originally Posted by burtathis
And in DNS :
Default Ns1: 82.227.0.130 ; Default Ns2: 82.227.0.130.
This is important only if you want your ISPConfig server to act as a nameserver. If you let ovh.com handle your DNS records, then it doesn't matter what you fill in here (btw, you should use FQDNs here instead of IP addresses).

Quote:
Originally Posted by burtathis
I made a new client and a new site in ispconfig interface (with 2 users) :
-In basis, i put hostname=www ; domain=gastfall.org ; create DNS and DNS-MX.
Ok, but you don't need "Create DNS" and "Create MX" because the DNS records are handled by ovh.com.
Quote:
Originally Posted by burtathis
-In co-domains, i add an entry without hostname and domain=gastfall.org and create DNS and DNS-MX.
Ok, but again same as above.

Did you forward port 80 from your router to your ISPConfig server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 14:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.