Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 10th May 2006, 19:08
KenKnight KenKnight is offline
Senior Member
 
Join Date: Nov 2005
Posts: 137
Thanks: 0
Thanked 3 Times in 2 Posts
Default Debian Sarge, Virutal Users-Domains

Hi all,

Fantastic tutorial!

I've got everything "almost" working. My problem lies in the Maildir area. The directories/files are not being created for any user I create in the mysql tables.

I manually created the technologynut.com directory and a user directory beneath it along with manually doing a chown vmail:vmail -R * on them.

below is the output of "ls -la /home/vmail/"
======================================

drwxr-xr-x 3 vmail vmail 4096 2006-05-10 10:59 .
drwxrwsr-x 7 root staff 4096 2006-05-10 11:23 ..
-rw-r--r-- 1 vmail vmail 567 2006-05-10 01:17 .bash_profile
-rw-r--r-- 1 vmail vmail 1834 2006-05-10 01:17 .bashrc
drwxr-xr-x 3 vmail vmail 4096 2006-05-10 10:59 technologynut.com


I'm not seeing any errors in the mail.log regarding directory permissions, failures etc.

What area to I need to investigate to get this working properly.

EDIT:
-----

Here's a problem i just noticed in the mail.log;

--------------------------------------------------
May 10 11:49:22 server1 amavis[1072]: (01072-01) TROUBLE in check_mail: creating_partsdir FAILED: DBD::mysql::st execute failed: Table 'mail.policy' doesn't exist at (eval 38) line 238, <GEN9> line 14.
May 10 11:49:22 server1 amavis[1072]: (01072-01) PRESERVING EVIDENCE in /var/lib/amavis/amavis-20060510T114921-01072
May 10 11:49:22 server1 amavis[1072]: (01072-01) TIMING [total 145 ms] - sql-prepare: 3 (2%), SMTP EHLO: 11 (7%), SMTP pre-MAIL: 1 (1%), mkdir tempdir: 1 (0%), create email.txt: 1 (1%), SMTP pre-DATA-flush: 6 (4%), SMTP DATA: 37 (26%), body hash: 1 (1%), mkdir parts: 1 (1%), sql-connect: 79 (55%), rundown: 5 (3%)
May 10 11:49:22 server1 postfix/smtp[1388]: 483A7244161: to=<kenknight@helpconsulting.net>, relay=127.0.0.1[127.0.0.1], delay=2900, status=deferred (host 127.0.0.1[127.0.0.1] said: 451 4.5.0 Error in processing, id=01072-01, creating_partsdir FAILED: DBD::mysql::st execute failed: Table 'mail.policy' doesn't exist at (eval 38) line 238, <GEN9> line 14. (in reply to end of DATA command))


Thanks,
Ken

Last edited by KenKnight; 10th May 2006 at 19:14.
Reply With Quote
Sponsored Links
  #2  
Old 10th May 2006, 22:39
KenKnight KenKnight is offline
Senior Member
 
Join Date: Nov 2005
Posts: 137
Thanks: 0
Thanked 3 Times in 2 Posts
 
Default

Well I decided to backup and punt.


I did the debian sarge install again and then followed the VHCS HowTo.

That is now functioning properly.

Thanks,
Ken
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual users, domains Postfix.. & Squirrelmail laser144 HOWTO-Related Questions 6 5th May 2006 00:23
Problem with Virtual Users And Domains With Postfix, Courier And MySQL Howto fenix Server Operation 4 11th March 2006 03:53
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 02:41
e-mail problem!!! Debian 3.1 maroonworks Installation/Configuration 18 6th December 2005 15:42
Debian Sarge RAID5 killfrog Installation/Configuration 2 23rd October 2005 22:43


All times are GMT +2. The time now is 11:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.