#1  
Old 1st December 2007, 04:11
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default Apache Forbidden Error

Hi All
When i try to browse my pages in apache it is giving forbidden error.

I am using lampp version : xampp-linux-1.5.5a.tar.gz


when i browse the url : http://192.10.10.96/anoop

Apache error log says like :

[Fri Nov 30 16:01:55 2007] [error] [client 192.10.10.21] Directory index forbidden by Options directive: /opt/lampp/htdocs/anoop/


In Mozilla web browser it says like :

Forbidden

You don't have permission to access /anoop/ on this server.
Apache/2.2.2 (Unix) DAV/2 mod_ssl/2.2.2 OpenSSL/0.9.8b SVN/1.4.4 PHP/5.1.4 mod_apreq2-20051231/2.5.7 mod_perl/2.0.2 Perl/v5.8.7 Server at 192.10.10.96 Port 80


But when i bowse the url : http://192.10.10.96/anoop/lunch

it is working fine.



That means only the folder directly inside the Document root is not accessible. sub folders are accessible.

I have given full permission to thte folder too. But still no use. even if i create a new folder under htdocs same error is comming.
What might be the problem. I would be greatful if anyone can help.

My document root is /opt/lampp/htdocs

Looking forward

Thanks and Regards
Nidhin
Reply With Quote
Sponsored Links
  #2  
Old 1st December 2007, 13:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,046
Thanks: 826
Thanked 5,385 Times in 4,231 Posts
Default

The folder itself is accessible, but the directory listing is denied. If you want the contents of the directory to be listed, when you access the directory, Change the Option directive in your apache configuration for the directory to:

+Indexes
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
nidhintomson (5th December 2007)
  #3  
Old 4th December 2007, 05:17
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Hi Till
Thanks for the reply. But i have already included the Indexs option for the Directories in httpd.conf. The line in my conf file is pasted below.


<Directory "/opt/lampp/htdocs">
Options Indexes FollowSymLinks MultiViews
</directory>


Is it not be like this ? or some thing lese too need to be done ? Looking forward to hear from you.

Thanks and Regards

Nidhin
Reply With Quote
  #4  
Old 5th December 2007, 14:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please remove the quotation marks:

Code:
<Directory /opt/lampp/htdocs>
Options Indexes FollowSymLinks MultiViews
</Directory>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 6th December 2007, 05:05
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please remove the quotation marks:

Code:
<Directory /opt/lampp/htdocs>
Options Indexes FollowSymLinks MultiViews
</Directory>

Hi Falko
Thanks for the reply . Itried the option you sid. But it didnt work. Even after i remove the quotes i am getting the same forbidden error. What else may the reason.

Looking forward to hear from you

Thanks in advance

Nidhin Tomson
Reply With Quote
  #6  
Old 7th December 2007, 14:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please try this:

Code:
<Directory /opt/lampp/htdocs>
Options +Indexes +FollowSymLinks +MultiViews
</Directory>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th December 2007, 04:20
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Please try this:

Code:
<Directory /opt/lampp/htdocs>
Options +Indexes +FollowSymLinks +MultiViews
</Directory>

Hi Falko

This also didnt work. I tried the Options directive with + symbol also. That too didnt work. I am getting the same forbidden error for the directories in the apache's root folder. The subfolders are working fine.

Looking forward to hear from you

Thanks and regards
Nidhin Tomson
Reply With Quote
  #8  
Old 8th December 2007, 04:38
DualFusion DualFusion is offline
Member
 
Join Date: Dec 2007
Posts: 67
Thanks: 4
Thanked 1 Time in 1 Post
Default Purge Cache?

Have you tried purging the browser cache (Ctrl + F5)?
Reply With Quote
  #9  
Old 8th December 2007, 05:03
nidhintomson nidhintomson is offline
Member
 
Join Date: Nov 2007
Posts: 41
Thanks: 3
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DualFusion
Have you tried purging the browser cache (Ctrl + F5)?
Hi Dual
Thanks for your reply.I have tried that option already. But in vane... Something else is the issue.

Looking forward to hear from you

Thanks and regards

Nidhin Tomson
Reply With Quote
  #10  
Old 9th December 2007, 13:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Can you post the complete vhost configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 03:38
Fresh Install on Debian cksrealm Installation/Configuration 12 22nd February 2006 16:14
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 20:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.