Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 22nd December 2005, 15:31
AdykOSu AdykOSu is offline
Junior Member
 
Join Date: Dec 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default editing network settings problem

i used
Code:
nano /etc/network/interfaces
to write my network setting ( just like in the PERFECT SETUP DEBIAN 3.1 SARGE HOW TO ) and now i want to return to the command promt and start configuring.but the main "problem" is that i don't know how to exit the nano editor. please help! p.s.: kinda embarising
thx in advance!
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2005, 15:45
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

press [ctrl] + x and then press y to safe the file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd December 2005, 18:22
AdykOSu AdykOSu is offline
Junior Member
 
Join Date: Dec 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
press [ctrl] + x and then press y to safe the file.
I did that..but there is another problem. the following message appears :
Code:
Could not open file for writing: Permission Denied
How can i make that file's permission writable?
Also when it asks me the name of the file to be saved ( in this case
Code:
/etc/network/interfaces
can i give it another name ( for example "eth0conf" and if so, how can i make that file to be seen as the default config file for my network ?
thx in advance!
Reply With Quote
  #4  
Old 22nd December 2005, 18:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by AdykOSu
I did that..but there is another problem. the following message appears :
Code:
Could not open file for writing: Permission Denied
How can i make that file's permission writable?
You have to be root to edit that file!

Quote:
Originally Posted by AdykOSu
Also when it asks me the name of the file to be saved ( in this case
Code:
/etc/network/interfaces
can i give it another name ( for example "eth0conf" and if so, how can i make that file to be seen as the default config file for my network ?
It makes no sense to rename that file to eth0conf, because that files contains also the configuration for other network interfaces like eth1, for example. So don't change the name.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 22nd December 2005, 18:47
AdykOSu AdykOSu is offline
Junior Member
 
Join Date: Dec 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

it works! thx for the quick replies falko & till!

now..after everything's configured... how do i verify the settings ?
I want everything to be done before i can start installing & configuring a FTP server!
thx in advance!
Reply With Quote
  #6  
Old 22nd December 2005, 18:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
Default

All steps in howto configuration has been done as root user!

After you restarted your network you can verify the settings with the command "ifconfig".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 22nd December 2005, 19:33
AdykOSu AdykOSu is offline
Junior Member
 
Join Date: Dec 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i did that! is shows me the settings i did input! thx again!

but i see in the HOW TO that a second IP is given to the same ethernet adapter, as shown here
Code:
If you want to add the IP address 192.168.0.101  to the interface eth0  you should change the file to look like this:# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
auto lo
iface lo inet loopback

# The first network card - this entry was created during the Debian installation
# (network, broadcast and gateway are optional)
auto eth0
iface eth0 inet static
        address 192.168.0.100
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1

auto eth0:0
iface eth0:0 inet static
        address 192.168.0.101
        netmask 255.255.255.0
        network 192.168.0.0
        broadcast 192.168.0.255
        gateway 192.168.0.1
i don't fully understand why!
and by the way.. i see
Code:
 network 192.168.0.0
        broadcast 192.168.0.255
in the configuration. does that mean the range of ips that can be applied to my network?
Reply With Quote
  #8  
Old 22nd December 2005, 19:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

http://www.howtoforge.com/forums/sho...p?t=130&page=2
http://www.howtoforge.com/forums/showthread.php?t=611
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 22nd December 2005, 21:29
AdykOSu AdykOSu is offline
Junior Member
 
Join Date: Dec 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i tried now to change my network settings ( gateway ) using
Code:
nano /etc/network/interfaces
. did so, saved file and tried to restart the network using
Code:
/etc/init.d/networking restart
and it replies back with the following message :
Code:
Setting up IP spoofing  protection: rp_filter
Reconfiguring network interfaces... ifup: interface already configured
SIOCADDRT: Network is unreachable
Failed to bring up eth0.
done
Reply With Quote
  #10  
Old 22nd December 2005, 21:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,596 Times in 4,407 Posts
 
Default

please post the content of /etc/network/interfaces
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with Webmail URL, uses local network and not internet danf.1979 General 8 24th December 2005 17:24
Can't access System config / Settings section Spektro Installation/Configuration 1 9th December 2005 16:31
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 02:56
Problem installing ISPConfig, then with MySQL... ctroyp Installation/Configuration 7 26th September 2005 17:37
Problem with webmail MyLinux General 10 17th September 2005 15:31


All times are GMT +2. The time now is 08:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.