#1  
Old 22nd December 2005, 08:40
snooopy snooopy is offline
Junior Member
 
Join Date: Dec 2005
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Proftpd Passive Mode Problem

I'm using proftpd v1.2.10rc1. The proftpd.conf is as follow:

ServerName "FTP Server"
ServerType standalone
DefaultServer on
DefaultTransferMode binary
ServerIdent on "Welcome to FTP Server"
DefaultRoot ~ !users
Port 21

AllowForeignAddress on

MaxLoginAttempts 2
MaxClientsPerHost 2

User nobody
Group nogroup

MaxInstances 10

ExtendedLog /usr/local/var/proftpd/access.log WRITE,READ write
ExtendedLog /usr/local/var/proftpd/auth.log AUTH auth
ScoreboardFile /usr/local/var/proftpd/proftpd

TimeoutLogin 60
TimeoutIdle 120
TimeoutNoTransfer 900

PathDenyFilter "(^|/)[-.]"

UseFtpUsers off
RootLogin off
PersistentPasswd off

AccessGrantMsg "%u is successful to log in"

TransferLog /usr/local/var/proftpd/xferlog
LogFormat default "%h %u %t \"%r\" %s %b"
LogFormat auth "%v [%P] %h %t \"%r\" %s"
LogFormat write "%h %u %t \"%r\" %s %b"

<Global>
Umask 022
RequireValidShell on
DirFakeGroup on
DirFakeUser on
DirFakeMode 0440
AllowRetrieveRestart on
</Global>

I've no configured passive mode and it should use Active Mode now. However, when I use FileZilla that I must select "Passive Mode" to see all files and directory. In addition, if I use "cmd" from Windows, the "ls" command cannot be used to list out files.

What happen and how can I solve it? In fact I would like to use Active Mode.
Reply With Quote
Sponsored Links
  #2  
Old 22nd December 2005, 09:49
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

I think it's a firewall problem. If you change your firewall rules then it should work.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56
ProFTPd Problems Logging in from outside network Ran2004 Server Operation 9 17th October 2005 00:56
Proftpd Access outside of network palkat Installation/Configuration 4 13th October 2005 18:50
proftpd problems Ovidiu Installation/Configuration 5 21st September 2005 10:47
ISPConfig ProFTPD changes? ProTrooper Installation/Configuration 3 9th September 2005 18:13


All times are GMT +2. The time now is 10:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.