Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th November 2007, 11:14
bobeq bobeq is offline
Junior Member
 
Join Date: Nov 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with keeping Apache alive

I have installed Debian on my new VPS. There is a little problem - few seconds after restart Apache is down. Interesting issue is when I restart its process, it works correctly... until the next reboot.

My error log:
Code:
[Tue Nov 27 06:26:51 2007] [notice] suEXEC mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue Nov 27 06:26:51 2007] [notice] FastCGI: wrapper mechanism enabled (wrapper: /usr/lib/apache2/suexec)
[Tue Nov 27 06:26:51 2007] [notice] FastCGI: process manager initialized (pid 20275)
[Tue Nov 27 06:26:52 2007] [warn] FastCGI: server "/var/www/fcgi/master/php5-fcgi-starter" (uid 2000, gid 2000) started (pid 20276)
[Tue Nov 27 06:26:52 2007] [notice] Apache configured -- resuming normal operations
[Tue Nov 27 06:27:06 2007] [notice] caught SIGTERM, shutting down
This is Debian Etch with ISP-control, I have installed: apache2, apache2-mpm-prefork, apache2.2-common, apache2-utils, libapache2-mod-fastcgi. Does anyone have an idea to solve my problem?

Thanks in advance and sorry for my english.

Last edited by bobeq; 27th November 2007 at 12:11.
Reply With Quote
Sponsored Links
  #2  
Old 28th November 2007, 16:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Are there any errors in the syslog when this happens?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 28th November 2007, 20:31
bobeq bobeq is offline
Junior Member
 
Join Date: Nov 2007
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

This is my syslog from reboot:

Code:
Nov 27 06:27:05 server shutdown[20392]: shutting down for system halt
Nov 27 06:27:05 server init: Switching to runlevel: 0
Nov 27 06:27:06 server postgrey[30310]: 2007/11/27-06:27:06 Server closing!
Nov 27 06:27:06 server authdaemond: stopping authdaemond children
Nov 27 06:27:07 server postfix/master[30420]: terminating on signal 15
Nov 27 06:27:08 server mysqld[30235]: 071127  6:27:08 [Note] /usr/sbin/mysqld: Normal shutdown
Nov 27 06:27:08 server mysqld[30235]:
Nov 27 06:27:08 server mysqld[30235]: 071127  6:27:08 [Note] /usr/sbin/mysqld: Shutdown complete
Nov 27 06:27:08 server mysqld[30235]:
Nov 27 06:27:08 server mysqld_safe[21589]: ended
Nov 27 06:27:09 server postfix/policyd-weight[21615]: Daemon terminated.
Nov 27 06:27:09 server ntpd[30474]: ntpd exiting on signal 15
Nov 27 06:27:10 server proftpd[30489]: server.dedicated.hosteurope.de - ProFTPD killed (signal 15)
Nov 27 06:27:10 server proftpd[30489]: server.dedicated.hosteurope.de - ProFTPD 1.3.0 standalone mode SHUTDOWN
Nov 27 06:27:10 server exiting on signal 15
Nov 27 06:27:23 server syslogd 1.4.1#18: restart.
Nov 27 06:27:24 server mysqld_safe[23600]: started
Nov 27 06:27:24 server mysqld[23603]: 071127  6:27:24 [Note] /usr/sbin/mysqld: ready for connections.
Nov 27 06:27:24 server mysqld[23603]: Version: '5.0.32-Debian_7etch3-log'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  Debian etch distribution
Nov 27 06:27:25 server /etc/mysql/debian-start[23643]: Upgrading MySQL tables if necessary.
Nov 27 06:27:26 server postfix/policyd-weight[23653]: policyd-weight 0.1.14 beta started and daemonized using default settings, $USER=polw, EUID: 107, UID: 107
Nov 27 06:27:26 server postfix/policyd-weight[23654]: cache spawned
Nov 27 06:27:26 server /etc/mysql/debian-start[23664]: Checking for crashed MySQL tables.
Nov 27 06:27:26 server postgrey[23669]: Process Backgrounded
Nov 27 06:27:26 server postgrey[23669]: 2007/11/27-06:27:26 postgrey (type Net::Server::Multiplex) starting! pid(23669)
Nov 27 06:27:26 server postgrey[23669]: Binding to TCP port 60000 on host 127.0.0.1  
Nov 27 06:27:27 server postgrey[23669]: Setting gid to "112 112"
Nov 27 06:27:27 server postgrey[23669]: Setting uid to "108"
Nov 27 06:27:27 server authdaemond: modules="authuserdb", daemons=5
Nov 27 06:27:27 server authdaemond: Installing libauthuserdb
Nov 27 06:27:27 server authdaemond: Installation complete: authuserdb
Nov 27 06:27:28 server postfix/master[23773]: daemon started -- version 2.3.8, configuration /etc/postfix
Nov 27 06:27:28 server ntpd[23838]: ntpd 4.2.2p4@1.1585-o Sun Mar  4 13:21:35 UTC 2007 (1)
Nov 27 06:27:28 server ntpd[23839]: precision = 5.000 usec
Nov 27 06:27:28 server ntpd[23839]: Listening on interface wildcard, 0.0.0.0#123 Disabled
Nov 27 06:27:28 server ntpd[23839]: Listening on interface lo, 127.0.0.1#123 Enabled
Nov 27 06:27:28 server ntpd[23839]: Listening on interface venet0, 127.0.0.1#123 Enabled
Nov 27 06:27:28 server ntpd[23839]: Listening on interface venet0:0, 87.230.80.240#123 Enabled
Nov 27 06:27:28 server ntpd[23839]: kernel time sync status 0040
Nov 27 06:27:29 server ntpd[23839]: frequency initialized 0.000 PPM from /var/lib/ntp/ntp.drift
Nov 27 06:27:29 server proftpd[23853]: server.dedicated.hosteurope.de - ProFTPD 1.3.0 (stable) (built mar gen 2 10:57:47 CET 2007) standalone mode STARTUP
Nov 27 06:27:29 server /usr/sbin/cron[23862]: (CRON) INFO (pidfile fd = 3)
Nov 27 06:27:29 server /usr/sbin/cron[23863]: (CRON) STARTUP (fork ok)
Nov 27 06:27:29 server /usr/sbin/cron[23863]: (CRON) INFO (Running @reboot jobs)
Nov 27 06:27:29 server ntpd[23839]: getaddrinfo: "::1" invalid host address, ignored
Nov 27 06:27:30 server ispcp_daemon[23951]: ispCP daemon v1.1 started!
Nov 27 06:27:30 server monit: monit: Cannot stat the SSL server PEM file '/etc/monit/monit.pem' -- No such file or directory
Nov 27 06:27:30 server monit: /etc/monit/monitrc:8: Error: SSL server PEM file has too loose permissions '/etc/monit/monit.pem'
Nov 27 06:27:30 server monit: /etc/monit/monitrc:58: Error: hostname did not resolve 'admin.hosting.example.com'
Nov 27 06:27:30 server init: no more processes left in this runlevel
Nov 27 06:27:36 server ntpd[23839]: synchronized to 131.234.137.23, stratum 1
Nov 27 06:27:36 server ntpd[23839]: kernel time sync enabled 0001
Nov 27 06:27:36 server ntpdate[22335]: step-systime: Operation not permitted
Nov 27 06:27:36 server ntpdate[22358]: step-systime: Operation not permitted
Maybe I don't know something, but I don't see there any problems..

Last edited by bobeq; 28th November 2007 at 20:34.
Reply With Quote
  #4  
Old 29th November 2007, 17:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

There's nothing Apache-related in there...

Maybe it has to do with your VPS having too low resources or something like that...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Gentoo Perfect Setup problem Apache PHP dschmid HOWTO-Related Questions 2 29th November 2007 17:27
apache ./configure problem zoffmann Server Operation 1 24th February 2007 11:57
Apache vhost problem! gral Server Operation 4 11th February 2007 15:44
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Problem with the installation of Dokeos (LMS) in ISPConfig jofranco General 4 28th April 2006 01:45


All times are GMT +2. The time now is 02:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.