#1  
Old 21st December 2005, 16:02
robd robd is offline
Member
 
Join Date: Dec 2005
Posts: 44
Thanks: 1
Thanked 1 Time in 1 Post
Default email delivery fails

Hello.
I'm using ISPConfig on FC4 (as a vm via xen). I have followed the Perfect Setup and all has worked fine e.g. web, sql, DNS etc

My users are able to login to POP mail OK too.

I have still a problem with Postfix. When I send an email to username@myserver.com to SMTP://mail.myserver.com postfix gives an error.

Dec 21 08:36:11 ns1 postfix/smtp[5466]: 5846A257AF: to=<web2_robdyke@85-234-137-244.poundhost.com>, orig_to=<rob@westhampstead.me.uk>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=85-234-137-244.poundhost.com type=A: Host not found)

my server is ns1.networkassociations.org.uk
my server is on 85.234.137.244
my virtual domain is westhampstead.me.uk
my virtual server is on 85.234.137.248

Is this due to reverse DNS lookups?
(I can post much config / setup files if needed)

does anyone have some pointers for further investigation for me?
Reply With Quote
Sponsored Links
  #2  
Old 21st December 2005, 16:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Quote:
Originally Posted by robd
Dec 21 08:36:11 ns1 postfix/smtp[5466]: 5846A257AF: to=<web2_robdyke@85-234-137-244.poundhost.com>, orig_to=<rob@westhampstead.me.uk>, relay=none, delay=0, status=bounced (Host or domain name not found. Name service error for name=85-234-137-244.poundhost.com type=A: Host not found)
Please post the output of
Code:
hostname
and
Code:
hostname -f
. What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 21st December 2005, 17:21
robd robd is offline
Member
 
Join Date: Dec 2005
Posts: 44
Thanks: 1
Thanked 1 Time in 1 Post
Default here's the output!

[root@ns1 ~]# hostname
ns1.networkassociations.org.uk
[root@ns1 ~]# hostname -f
ns1.networkassociations.org.uk

and, from the end of main.cf:
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

less: /etc/postfix/virtusertable
neil@www.neilnerva.org web1_neilnerva
web1_neilnerva@www.neilnerva.org web1_neilnerva
@www.neilnerva.org web1_neilnerva
neil@neilnerva.org web1_neilnerva
web1_neilnerva@neilnerva.org web1_neilnerva
@neilnerva.org web1_neilnerva
neil@mail.neilnerva.org web1_neilnerva
web1_neilnerva@mail.neilnerva.org web1_neilnerva
@mail.neilnerva.org web1_neilnerva
rob@www.westhampstead.me.uk web2_robdyke
web2_robdyke@www.westhampstead.me.uk web2_robdyke
rob@westhampstead.me.uk web2_robdyke
web2_robdyke@westhampstead.me.uk web2_robdyke
rob@mail.westhampstead.me.uk web2_robdyke
web2_robdyke@mail.westhampstead.me.uk web2_robdyke

less /etc/postfix/local-host-names
localhost
ns1.networkassociations.org.uk
localhost.ns1.networkassociations.org.uk
localhost.networkassociations.org.uk
www.neilnerva.org
www.westhampstead.me.uk
neilnerva.org
mail.neilnerva.org
westhampstead.me.uk
mail.westhampstead.me.uk
Reply With Quote
  #4  
Old 21st December 2005, 17:29
robd robd is offline
Member
 
Join Date: Dec 2005
Posts: 44
Thanks: 1
Thanked 1 Time in 1 Post
Default dns reports

http://www.dnsreport.com/tools/dnsre...=neilnerva.org

ERROR: I couldn't find any MX records for neilnerva.org. If you want to receive E-mail on this domain, you should have MX record(s). Without any MX records, mailservers should attempt to deliver mail to the A record for neilnerva.org. I can't continue in a case like this, so I'm assuming you don't receive mail on this domain.
Reply With Quote
  #5  
Old 21st December 2005, 18:13
robd robd is offline
Member
 
Join Date: Dec 2005
Posts: 44
Thanks: 1
Thanked 1 Time in 1 Post
Lightbulb this is what happens with another email delivery

I notice this in the /var/log/maillog, this must be some kinda report or otherwise being delivered to root.

Dec 21 11:00:02 ns1 postfix/smtpd[7919]: warning: 127.0.0.1: hostname localhost verification failed: Name or service not known
Dec 21 11:00:02 ns1 postfix/smtpd[7919]: connect from unknown[127.0.0.1]
Dec 21 11:00:02 ns1 postfix/smtpd[7919]: setting up TLS connection from unknown[127.0.0.1]
Dec 21 11:00:02 ns1 sendmail[7914]: STARTTLS=client, relay=[127.0.0.1], version=TLSv1/SSLv3, verify=FAIL, cipher=DHE-RSA-AES256-SHA, bits=256/256
Dec 21 11:00:02 ns1 postfix/smtpd[7919]: TLS connection established from unknown[127.0.0.1]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Dec 21 11:00:02 ns1 postfix/smtpd[7919]: F312C257AB: client=unknown[127.0.0.1], sasl_sender=root@ns1.networkassociations.org.uk
Dec 21 11:00:03 ns1 postfix/cleanup[7922]: F312C257AB: message-id=<200512211600.jBLG02bs007914@ns1.networkassocia tions.org.uk>
Dec 21 11:00:03 ns1 sendmail[7914]: jBLG02bs007914: to=root@localhost, ctladdr=root (0/0), delay=00:00:01, xdelay=00:00:01, mailer=relay, pri=30341, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as F312C257AB)
Dec 21 11:00:03 ns1 postfix/qmgr[4979]: F312C257AB: from=<root@ns1.networkassociations.org.uk>, size=1002, nrcpt=1 (queue active)
Dec 21 11:00:03 ns1 postfix/local[7923]: F312C257AB: to=<root@ns1.networkassociations.org.uk>, relay=local, delay=1, status=sent (delivered to mailbox)

so delivery to mailbox's is working?
Reply With Quote
  #6  
Old 21st December 2005, 18:26
robd robd is offline
Member
 
Join Date: Dec 2005
Posts: 44
Thanks: 1
Thanked 1 Time in 1 Post
 
Smile /etc/hosts

I didn't have an /etc/hosts file.
I have created one......

[root@ns1 ~]# cat /etc/hosts
# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
85.234.137.244 ns1.networkassociations.org.uk ns1
85.234.137.248 ns2.networkassociations.org.uk ns2

And now my email send and receive is working!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help forward root email to me domino Technical 10 2nd May 2006 16:01
Recreate email Felipe General 3 13th December 2005 22:45
Postfix or email server setup matrich Server Operation 3 24th November 2005 23:26
Email sent to domain being rejected Lil'Brudder Installation/Configuration 9 25th October 2005 12:17
UebiMiau webmail adding @localhostname to email address except first address. Kamran Shah Installation/Configuration 5 11th October 2005 18:01


All times are GMT +2. The time now is 15:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.