#1  
Old 20th December 2005, 20:22
tsw tsw is offline
Junior Member
 
Join Date: Dec 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question webmail login

Hi,

First I would like to say that ispconfig is really helpfull, I had inhouse written manager before, but it just wouldnt do anymore (if 3.0 has the options I have seen people saying it will be even better)

so to my problem.

in webmail login I can use "username@tld" and password just fine, but "username@" and password also workd so does "username@anytld" and password. bug? or a know option?

thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 20th December 2005, 21:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

You can use any email address that is assigned to the user. We have rewritten the Uebimiau login so that it does a lookup in the ISPConfig database to find out which user is behind the email address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 20th December 2005, 21:42
tsw tsw is offline
Junior Member
 
Join Date: Dec 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
You can use any email address that is assigned to the user. We have rewritten the Uebimiau login so that it does a lookup in the ISPConfig database to find out which user is behind the email address.
yes, but the problem is I can use any tld also (or no tld) like "user@" works.
Reply With Quote
  #4  
Old 20th December 2005, 23:39
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Quote:
Originally Posted by tsw
yes, but the problem is I can use any tld also (or no tld) like "user@" works.
What is the problem? As long the username / password combination works correct. UebiMiau connects to the localhost mailserver and usernames are unique on the server. By the way, UebiMiau is not part of ISPCOnfig, its an optional external package.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 21st December 2005, 02:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by tsw
yes, but the problem is I can use any tld also (or no tld) like "user@" works.
I've tried myself, and I can't reproduce the problem...

Maybe you can check yourself, the PHP code that does the mapping (email address <-> user name) is at the beginning of /home/admispconfig/ispconfig/web/webmail/msglist.php.

PHP Code:
//////////////////////// Map Alias to User Name (ISPConfig) ////////////////
include("/home/admispconfig/ispconfig/lib/config.inc.php");
$dbclass $go_info["server"]["classes_root"] . $go_info["server"]["dir_trenner"] ."ispconfig_db_".$go_info["server"]["db_type"].".lib.php";
include_once(
$dbclass);
$dbname 'db_'.$go_info["server"]["db_type"];
$db = new $dbname;
if(
$f_email){
  list(
$alias,$domain) = explode("@"$f_email);
  
$webs $db->queryAllRecords("SELECT * from isp_isp_web, isp_nodes where isp_isp_web.doc_id = isp_nodes.doc_id and isp_nodes.doctype_id = '1013' and isp_isp_web.server_id = '1' and isp_nodes.status = '1'");
  if(!empty(
$webs)){
    foreach(
$webs as $web){
      if(
$web["web_host"] != ""){
        
$domain_hosts[] = $web["web_host"].".".$web["web_domain"];
      } else {
        
$domain_hosts[] = $web["web_domain"];
      }
      
$codomains $db->queryAllRecords("SELECT isp_isp_domain.domain_domain, isp_isp_domain.domain_host from isp_dep,isp_isp_domain where isp_dep.child_doc_id = isp_isp_domain.doc_id and isp_dep.child_doctype_id ='1015' and isp_dep.parent_doctype_id = '1013' and isp_dep.parent_doc_id = '".$web["doc_id"]."' and isp_isp_domain.status != 'd'");
      if(!empty(
$codomains)){
        foreach(
$codomains as $codomain){
          if(
$codomain["domain_host"] != ""){
            
$domain_hosts[] = $codomain["domain_host"].".".$codomain["domain_domain"];
          } else {
            
$domain_hosts[] = $codomain["domain_domain"];
          }
        }
      }
      if(
in_array($domain$domain_hosts)){
        
$users $db->queryAllRecords("SELECT * FROM isp_nodes, isp_dep, isp_isp_user WHERE isp_dep.parent_doc_id = '".$web["doc_id"]."' AND isp_dep.parent_doctype_id = '1013' AND isp_dep.child_doc_id = isp_isp_user.doc_id AND isp_dep.child_doctype_id = '1014' AND isp_nodes.doc_id = isp_isp_user.doc_id AND isp_nodes.doctype_id = '1014' AND isp_nodes.status = '1'");
        if(!empty(
$users)){
          foreach(
$users as $user){
            
$aliasse explode("\n"str_replace("\r\n""\n"trim($user["user_emailalias"])));
            if(
trim($user["user_email"]) != ""$aliasse[] = trim($user["user_email"]);
            
$aliasse[] = trim($user["user_username"]);
            if(
in_array($alias$aliasse)) $f_email $user["user_username"]."@".$domain;
            unset(
$aliasse);
          }
        }
      }
      unset(
$domain_hosts);
    }
  }
}
//////////////////////// Map Alias to User Name (ISPConfig) ENDE //////////////// 
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 21st December 2005, 12:59
tsw tsw is offline
Junior Member
 
Join Date: Dec 2005
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It just seems strange that I can login with "username@right.domain.com" AND also with "username@domain.that.doesnt.exist" AND with "username@"

everything works fine on webmail with all usernames above (and the password of course

till: Yes, I know that UebiMiau is a seperate optional package

Falko: Looked at the code and cant find anything strange in it
Reply With Quote
  #7  
Old 21st December 2005, 16:51
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by tsw
Falko: Looked at the code and cant find anything strange in it
Maybe you can run some of the SQL queries in phpMyAdmin to find out what's going on.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 19:11
Can't login to webmail OnTheRun Installation/Configuration 7 1st December 2005 11:36
Webmail alias aethiolas HOWTO-Related Questions 2 21st November 2005 19:21
authdaemon LOGIN: REJECT dgradzik Tips/Tricks/Mods 2 22nd September 2005 01:09
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 15:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.