Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 19th November 2007, 18:21
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default Bunch of user Maildirs disappeared

I had an issue over the weekend that I believe are related to a dangerous mail admin user.

One of my customers has 14 mail accounts. Their service has been running fine for several weeks. I got a call this morning that they were unable to make POP or IMAP connections to check their e-mail. When I went into their top-level user dir (/its/isp/hosted/web371/user) I saw a user directory for only one user. All other user dirs were gone. The user whose dir was still present is NOT the admin user.

I logged in to ISPConfig and saw that all 14 mail users were still defined in the database. I was able to get the user back on the air by restoring their user dirs from a backup copy.

The e-mail admin for this account says he spent a couple hours trying to configure a new mail account over the weekend.

I have several questions:
1) Does anybody have any idea how this user could have wiped out all the mail accounts without removing the users from the database?
2) Till, I know you've posted before how to get ISPConfig to recreate appropriate user directories with the appropriate permissions and ownerships by setting a status bit in the database. Could you supply that info again? This time I'll make note of it where I won't lose it.

I also have quetion related to this having to do with Postfix behavior, but it's on a different enough topic that I'll put it in another thread.
Reply With Quote
Sponsored Links
  #2  
Old 20th November 2007, 09:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
 
Default

Please have a look here:

http://www.howtoforge.com/forums/showthread.php?t=17481
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Anything I can do against illegal login-requests? schmidtedv Installation/Configuration 17 7th November 2008 09:25
User Add/Delete and FTP login problem. clabrown Installation/Configuration 3 23rd August 2007 19:12
Can't get fail2ban to work. boast Server Operation 2 26th June 2007 00:55
log files cruz Technical 3 15th May 2007 14:35


All times are GMT +2. The time now is 17:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.