Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th November 2007, 23:38
smackYYZ smackYYZ is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default All seems well except email clients

Afternoon,

I've just completed building an installation of ISPconfig on Centos5. All has gone very smooth, thanks to the Centos5 HowTo.

My present issue is getting mail clients to be able to retrieve their email via pop3. Everyone can read/send email via the UebiMiau interface, but everyone email client's are failing to login.

example from /var/log/secure

dovecot-auth: pam_succeed_if(dovecot:auth): error retrieving information about user user@domain.com

and from /var/log/maillog
dovecot: pop3-login: Disconnected: user=<user@domain.com>, method=PLAIN, rip=::ffff:69.179.21.121, lip=::ffff:64.34.158.164

the domains and users are in the /etc/postfix/virtualusertable and /etc/postfix/localhostnames .

It's got to be something simple that I am missing.

Thanks,

Mike

Last edited by smackYYZ; 16th November 2007 at 00:13.
Reply With Quote
Sponsored Links
  #2  
Old 16th November 2007, 05:18
smackYYZ smackYYZ is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Exclamation Any ideas?

Any suggestions?

All of the clients ( Outlook and Thunderbird ) report server time out. Have tried connections: none, TLS & SSL using secure authenication and without. And, yes I have MailDir checked in the Mgmt->srvr->setting->Email checked!

Input would be appreciated.

Mike

Last edited by smackYYZ; 16th November 2007 at 06:32.
Reply With Quote
  #3  
Old 16th November 2007, 06:38
archerjd archerjd is offline
Member
 
Join Date: Dec 2006
Posts: 66
Thanks: 6
Thanked 6 Times in 6 Posts
Default

Have you tried telnet from another machine to 110 and 143?
Is there a posiblity you have a firewall up?
If telnet cannot connect try from a machine on the same network.
you should have at least some type of responce when running
Code:
telnet localhost 110
on the server.
Reply With Quote
  #4  
Old 16th November 2007, 10:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

You will have to use the username to login with a mail client by pop3 or imap and not the email address as used in uebimiau.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 16th November 2007, 15:50
smackYYZ smackYYZ is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default

yes telnet works from other machines.
-------------
> telnet 64.34.15.16 110
Trying 64.34.15.16...
Connected to host.domain.com (64.34.15.16).
Escape character is '^]'.
+OK Dovecot ready.
-----
So port is open.

I've got IMAP to work by logging in as webX_userID but not pop3.

I'm hoping I don't have to alter more then 100 pop3 mail clients. To prepend the webX_ to their logins. I've tried multiple formats for logins in using TLS and none have been successful. Formats attempted:
userid@domain.com
webX_userid
webX_userid@domain.com
webX_userid@host.domain.com

-------

Also these pop3 attempts are not appearing in any logs files that I can seem to find. Only failed attempts I can see appear to be imap attemtps.

Thoughts?
Reply With Quote
  #6  
Old 16th November 2007, 15:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

The login for pop3 is just web[ID]_user and not the email address or webX_userid@domain.com.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
smackYYZ (16th November 2007)
  #7  
Old 16th November 2007, 22:14
smackYYZ smackYYZ is offline
Junior Member
 
Join Date: Jan 2007
Posts: 8
Thanks: 1
Thanked 1 Time in 1 Post
Default

ok, seems all is under control.

But I have 30 domains to move onto the ISP Config server, and I don't want to have to contact all the users and deal with the mail changes.

Is there any way to alter, so that the pop3/imap and smtp logins are their full email address instead of the web[ID]_username only?
Reply With Quote
  #8  
Old 16th November 2007, 23:36
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
 
Default

Yes, thats possible. There are several methods described in the tipps & tricks forum. I recommend to replace courier with dovecot in your setup, as this is the easiest way and configure dovecot as described in the tipps & tricks forum.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Email Delivery Problem sedat1903 HOWTO-Related Questions 2 22nd December 2008 12:19
Salutatory Email for Clients and Phpmyadmin problem krishol Installation/Configuration 10 16th August 2007 07:00
CacheALL email problem no.2 Snowman General 2 2nd August 2007 10:45
Multiple MySQL Queries - with Postfix-mysql, courier-authmysql, maildrop-mysql... snowfly HOWTO-Related Questions 4 7th July 2006 05:19
email forwarding locally consumes all resources rdells General 20 1st May 2006 20:43


All times are GMT +2. The time now is 22:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.