Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th August 2006, 19:12
djcronos djcronos is offline
Junior Member
 
Join Date: Jun 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Recipient address rejected: User unknown in local recipient table

Hi all,

I used the Perfect Setup Ubuntu Dapper 6.06 howto install, and I'm having problems getting email to work on my machine. When following the install, I changed server1.example.com to foo.com (real domain name replaced with generic). Inside ISPConfig I set up another domain name, bar.com. Going to www.foo.com and www.bar.com via Firefox works just fine, but it's the email I'm having problems with. When I go under sites and into www.bar.com and go to add an email, I add it there successfully. If I go into /etc/local-host-names I see that bar.com is in there, and when I go to /etc/postfix/virtusertable I see that the email accounts I add are there.

However, when I send an email to any account I have set up, I always get the same error message:

Code:
PERM_FAILURE: SMTP Error (state 9): 550 <djcronos@bar.com>: Recipient address rejected: User unknown in local recipient table
When I go into the ISPConfig Admin Panel, Under Server Settings, the VirtUserFile is /etc/postfix/virtusertable and the Sendmail CW is /etc/postfix/local-host-names.

If there is any other information I can provide, please let me know.

Thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2006, 22:37
djcronos djcronos is offline
Junior Member
 
Join Date: Jun 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here are outputs of my /etc/main.cf and /etc/master.cf:

/etc/main.cf:
Code:
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = foo.com
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = /etc/postfix/local-host-names
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
/etc/master.cf:
Code:
smtp      inet  n       -       -       -       -       smtpd
#submission inet n      -       -       -       -       smtpd
#       -o smtpd_etrn_restrictions=reject
#       -o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       -       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission inet n      -       -       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       -       -       -       qmqpd
pickup    fifo  n       -       -       60      1       pickup
cleanup   unix  n       -       -       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       -       300     1       oqmgr
tlsmgr    unix  -       -       -       1000?   1       tlsmgr
rewrite   unix  -       -       -       -       -       trivial-rewrite
bounce    unix  -       -       -       -       0       bounce
defer     unix  -       -       -       -       0       bounce
trace     unix  -       -       -       -       0       bounce
verify    unix  -       -       -       -       1       verify
flush     unix  n       -       -       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       -       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       -       -       -       smtp
        -o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       -       -       -       showq
error     unix  -       -       -       -       -       error
discard   unix  -       -       -       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       -       -       -       lmtp
anvil     unix  -       -       -       -       1       anvil
scache    unix  -       -       -       -       1       scache
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/bin/maildrop -d ${recipient}
#
# See the Postfix UUCP_README file for configuration details.
#
uucp      unix  -       n       n       -       -       pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
#
# Other external delivery methods.
#
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=bsmtp argv=/usr/lib/bsmtp/bsmtp -t$nexthop -f$sender $recipient
scalemail-backend unix  -       n       n       -       2       pipe
  flags=R user=scalemail argv=/usr/lib/scalemail/bin/scalemail-store ${nexthop} ${user} ${extension}
mailman   unix  -       n       n       -       -       pipe
  flags=FR user=list argv=/usr/lib/mailman/bin/postfix-to-mailman.py
  ${nexthop} ${user}
Reply With Quote
  #3  
Old 18th August 2006, 09:31
narut0b0y narut0b0y is offline
Junior Member
 
Join Date: Aug 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

what's inside your virtusertable file? mine contain this

###################################
#
# ISPConfig virtusertable Configuration File
# Version 1.0
#
###################################
test.1.real.name@www.somedomain.net web1_test.1.real.name
web1_test.1.real.name@www.somedomain.net web1_test.1.real.name
test.1.real.name@somedomain.net web1_test.1.real.name
web1_test.1.real.name@somedomain.net web1_test.1.real.name
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####

i only have one user since i just recently installed the ispconfig application. mail sending and receiving are both working properly.
Reply With Quote
  #4  
Old 18th August 2006, 09:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

Please add this line at the end of the main.cf file:

virtual_maps = hash:/etc/postfix/virtusertable

and restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 18th August 2006, 18:36
Ben Ben is offline
Moderator
 
Join Date: Jul 2006
Posts: 1,029
Thanks: 7
Thanked 62 Times in 56 Posts
Default

shouldn't he run a
postmap /etc/postfix/virtusertable

before restarting or does the hashfile already exist?
Reply With Quote
  #6  
Old 18th August 2006, 19:21
djcronos djcronos is offline
Junior Member
 
Join Date: Jun 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi everyone,

Thanks till and Ben for the replies. I did what till requested, restarted postfix, and it worked!

Just a few questions so I can understand this more. What does that line do till, and secondly, what does a postmap /etc/postfix/virtusertable do?

And finally, did I do something wrong in the initial setup, or is this an extra step that needs to be added to the HOWTO?

Thanks guys!!
Reply With Quote
  #7  
Old 19th August 2006, 13:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by djcronos
What does that line do till
It adds the "database" (well, it's just a text file) with the valid email addresses to the Postfix configuration.

Quote:
Originally Posted by djcronos
and secondly, what does a postmap /etc/postfix/virtusertable do?
It transforms the text file into a format Postfix can read.

Quote:
Originally Posted by djcronos
or is this an extra step that needs to be added to the HOWTO?
The virtual_maps = hash:/etc/postfix/virtusertable line is added by the ISPConfig installer, so I guess you or someone else accidentally removed it. And the postmap command is run automatically by ISPConfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 15th November 2007, 04:51
quannv quannv is offline
Member
 
Join Date: Sep 2007
Location: Viet Nam
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by djcronos
Hi everyone,

Thanks till and Ben for the replies. I did what till requested, restarted postfix, and it worked!

Just a few questions so I can understand this more. What does that line do till, and secondly, what does a postmap /etc/postfix/virtusertable do?

And finally, did I do something wrong in the initial setup, or is this an extra step that needs to be added to the HOWTO?

Thanks guys!!
I use google mail hosting for my domain, and I get same error although I have been added virtual_maps = hash:/etc/postfix/virtusertable to main.cf.

Before moving mail hosting to google, mail sever is working fine
Reply With Quote
  #9  
Old 15th November 2007, 10:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,778
Thanks: 821
Thanked 5,333 Times in 4,184 Posts
Default

@quannv Ok, you mean that google is now the responsible mail server and not your server. This is something totally different as your server shall not be responsible for the mail anymore. You will have to set mailserver to external under Options in the website AND the co-domain options.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 15th November 2007, 11:48
quannv quannv is offline
Member
 
Join Date: Sep 2007
Location: Viet Nam
Posts: 33
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thank so much, I am done
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Recipient address rejected: User unknown in local recipent table. adrenalinic Installation/Configuration 15 25th April 2006 16:26
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 20:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.