Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th November 2007, 01:50
Krrose27 Krrose27 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default Problems and Questions

1) When connecting to my ip: 97.***.**.**, it shows the root of the site. Isn't it supposed to show the shared ip thing?

2) I have setup a dns server through godady and a tutorial on this site. I have setuo, a client and a site. The site shows up but when connecting to the site it dosent connect. Does the dns just need to update?
Reply With Quote
Sponsored Links
  #2  
Old 14th November 2007, 10:10
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Please make sure that the IP 97.... is set under management > server > settings in ISPConfig either as server IP or listed in the IP list.

2) It may take up to 48 hours until DNS records propagate.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th November 2007, 12:44
Krrose27 Krrose27 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
Please make sure that the IP 97.... is set under management > server > settings in ISPConfig either as server IP or listed in the IP list.

2) It may take up to 48 hours until DNS records propagate.

I checked this and that was the server ip. I added it to the list and recivie the same thing.
Reply With Quote
  #4  
Old 14th November 2007, 16:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's in Vhosts_ispconfig.conf, and what's the output of
Code:
ifconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th November 2007, 20:07
Krrose27 Krrose27 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
###################################
#
# ISPConfig vHost Configuration File
# Version 1.0
#
###################################
#
NameVirtualHost 97.101.41.51:80
<VirtualHost 97.101.41.51:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 97.101.41.51:80
<VirtualHost 97.101.41.51:80>
ServerName localhost
ServerAdmin root@localhost
DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.krrose27.com:80
######################################
#
#
<VirtualHost 97.101.41.51:80>
ServerName www.krrose27.com:80
ServerAdmin webmaster@krrose27.com
DocumentRoot /var/www/web5/web
ServerAlias krrose27.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web5/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web5/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/var/www/web5/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web5/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web5/user/$1/web/$3
</VirtualHost>
#
#
#
######################################
# Vhost: www.megauppit.com:80
######################################
#
#
<VirtualHost 97.101.41.51:80>
ServerName www.megauppit.com:80
ServerAdmin webmaster@megauppit.com
DocumentRoot /var/www/web6/web
ServerAlias megaupit.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web6/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web6/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/var/www/web6/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web6/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web6/user/$1/web/$3
</VirtualHost>

and ifcpnfig

Quote:
root@server1:/etc/apache2/vhosts# ifconfig
eth0 Link encap:Ethernet HWaddr 00:11:2F:0A:8F:61
inet addr:10.0.5.53 Bcast:10.0.5.255 Mask:255.255.255.0
inet6 addr: 2002:6165:2933:0:211:2fff:fe0a:8f61/64 Scope:Global
inet6 addr: fe80::211:2fff:fe0a:8f61/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:3526 errors:0 dropped:0 overruns:0 frame:0
TX packets:2694 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:366829 (358.2 KB) TX bytes:422119 (412.2 KB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:410 errors:0 dropped:0 overruns:0 frame:0
TX packets:410 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:26678 (26.0 KB) TX bytes:26678 (26.0 KB)
I ha also sent this message to till in a pm

I'm having some problems.

1) I setup ubuntu following the perfect setup for 7.10
2) I then followed the tuttorial on how setup domain ame servers on godaddy. So i bought a domain: namesever-secure.com. And setup two name servers. ns1 and ns2.namesever-secure.com and redirect them both to my ip: 97.101.41.51. Now heres the thing i dont have two servers i have 1, so im trying to connect both ns to the same ip.
3) I created a client.
4) Then added a site, krrose27.com which is registered by name cheap and set the ns's to ns1 and ns2.namesever-secure.com.
5) I also setup an a record for server1.namesever-secure.com and redirect it to my ip.

If i do dig ns1.namesever-secure.com i get:
Quote:

root@server1:/# dig ns1.namesever-secure.com

; <<>> DiG 9.4.1-P1 <<>> ns1.namesever-secure.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 2706
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ns1.namesever-secure.com. IN A

;; ANSWER SECTION:
ns1.namesever-secure.com. 172741 IN A 97.101.41.51

;; Query time: 38 msec
;; SERVER: 208.67.220.220#53(208.67.220.220)
;; WHEN: Wed Nov 14 08:57:29 2007
;; MSG SIZE rcvd: 58

if i dig @ns1.namesever-secure.com any krrose27.com:
Quote:

root@server1:/# dig @ns1.namesever-secure.com any krrose27.com
;; reply from unexpected source: 10.0.5.1#53, expected 97.101.41.51#53
;; reply from unexpected source: 10.0.5.1#53, expected 97.101.41.51#53
;; reply from unexpected source: 10.0.5.1#53, expected 97.101.41.51#53

; <<>> DiG 9.4.1-P1 <<>> @ns1.namesever-secure.com any krrose27.com
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached
however if i dig server1.namesever-secure.com i get:
Quote:
root@server1:/# dig server1.namesever-secure.com

; <<>> DiG 9.4.1-P1 <<>> server1.namesever-secure.com
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 28557
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;server1.namesever-secure.com. IN A

;; ANSWER SECTION:
server1.namesever-secure.com. 1011 IN A 97.101.41.51

;; Query time: 39 msec
;; SERVER: 208.67.220.220#53(208.67.220.220)
;; WHEN: Wed Nov 14 09:00:05 2007
;; MSG SIZE rcvd: 62
if dig @server1.namesever-secure.com any krrose27.com:
[quote]
root@server1:/# dig @server1.namesever-secure.com any krrose27.com

; <<>> DiG 9.4.1-P1 <<>> @server1.namesever-secure.com any krrose27.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 20355
;; flags: qr aa rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 1

;; QUESTION SECTION:
;krrose27.com. IN ANY

;; ANSWER SECTION:
krrose27.com. 86400 IN TXT "v=spf1 a mx ptr ~all"
krrose27.com. 86400 IN SOA ns1.namesever-secure.com. admin.krrose27.com. 2007111302 28800 7200 604800 86400
krrose27.com. 86400 IN NS ns1.namesever-secure.com.
krrose27.com. 86400 IN NS ns2.namesever-secure.com.
krrose27.com. 86400 IN MX 10 www.namesever-secure.com.
krrose27.com. 86400 IN A 97.101.41.51

;; ADDITIONAL SECTION:
ns2.namesever-secure.com. 164485 IN A 97.101.41.51

;; Query time: 0 msec
;; SERVER: 10.0.5.53#53(10.0.5.53)
;; WHEN: Wed Nov 14 09:01:02 2007
;; MSG SIZE rcvd: 210

Last edited by Krrose27; 14th November 2007 at 20:10.
Reply With Quote
  #6  
Old 14th November 2007, 20:48
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

your servers appears to be behind a router and its address is 10.0.5.53
Reply With Quote
  #7  
Old 14th November 2007, 20:58
Krrose27 Krrose27 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by daveb
your servers appears to be behind a router and its address is 10.0.5.53
correct it is behind a router.

Its internal ip is 10.0.5.53 the network ip is 97.101.41.51 wich has nescecary ports forwarded to the internal port like port 80. What do i need to change?
Reply With Quote
  #8  
Old 14th November 2007, 21:03
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

under management > server > settings in ISPConfig use your internal ip 10.0.5.53
then for dns settings for your sites use your external ip 97.101.41.51
Reply With Quote
  #9  
Old 14th November 2007, 23:36
Krrose27 Krrose27 is offline
Junior Member
 
Join Date: Nov 2007
Posts: 21
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ok so i went ahead and did this. If you goto my external ip noe u get the shared ip thing.


HOWEVER if i dig @ns1.namesever-secure.com any krrose27.com

i still get the unexcpected reply thing.


root@server1:~# dig @ns1.namesever-secure.com any krrose27.com
;; reply from unexpected source: 10.0.5.1#53, expected 97.101.41.51#53
;; reply from unexpected source: 10.0.5.1#53, expected 97.101.41.51#53
;; reply from unexpected source: 10.0.5.1#53, expected 97.101.41.51#53

; <<>> DiG 9.4.1-P1 <<>> @ns1.namesever-secure.com any krrose27.com
; (1 server found)
;; global options: printcmd
;; connection timed out; no servers could be reached





I also have this in my logs.. dont know whatit means.

root@server1:~# vi /home/admispconfig/ispconfig/ispconfig.log

14.11.2007 - 17:55:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/apache2 restart &> /dev/null
14.11.2007 - 17:55:53 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix stop &> /dev/null
14.11.2007 - 17:55:54 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/postfix start &> /dev/null
14.11.2007 - 17:55:56 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/bind9 restart &> /dev/null
14.11.2007 - 17:55:58 => INFO - /root/ispconfig/scripts/lib/classes/ispconfig_system.lib.php, Line 728: /etc/init.d/proftpd restart &> /dev/null

Last edited by Krrose27; 14th November 2007 at 23:59.
Reply With Quote
  #10  
Old 15th November 2007, 10:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,774
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
 
Default

Quote:
Ok so i went ahead and did this. If you goto my external ip noe u get the shared ip thing.
Ok, this is fine and indicates that your setup works. Now just open the website settings in the ISP-Manager and select the internal IP instead of the external IP.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with freezing and kernel error anebi Server Operation 2 19th August 2007 14:06
Multiple ISPConfig & DNS Questions and Problems bfriend Installation/Configuration 3 6th January 2007 06:14
Mandriva 2006 Install questions bersi Installation/Configuration 26 1st November 2006 16:52
questions from a newbie in a hurry... ignasigarcia Installation/Configuration 2 22nd June 2006 23:54
Users and websites aren't created Glorfindel Installation/Configuration 9 23rd February 2006 04:20


All times are GMT +2. The time now is 10:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.